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Read Me First 
Welcome to Take Control of DEVONthink 3, version 1.12, published in 
March 2023 by alt concepts. This book was written by Joe Kissell and 
edited by Kelly Turner. 

This book teaches you the basics of DEVONthink version 3 on the Mac 
and DEVONthink To Go in iOS/iPadOS. You’ll learn how to find your 
way around, get information into and out of DEVONthink, and take 
advantage of the program’s most important features. 

Copyright © 2023, Joe Kissell. All rights reserved. 

Sponsored by DEVONtechnologies 
This book was sponsored by DEVONtechnologies. Special thanks to 
Eric Böhnisch-Volkmann for his enthusiasm and support, to Christian 
Grunenberg for his clarifications about subtle features, and to Jim 
Neumann for his careful fact-checking. 

Updates and More 

You can access extras related to this ebook on the web (use the link 
in Ebook Extras, near the end). On the ebook’s Take Control Extras 
page, you can: 

• Download any available new version of the ebook for free. 

• Download various formats, including PDF, EPUB, and Mobipocket. 
(Learn about reading on mobile devices on our Device Advice page.) 

• Read the ebook’s blog. You may find new tips or information, as 
well as a link to an author interview. 
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DEVONthink’s Documentation 

I refer throughout this book to DEVONthink’s documentation. It’s 
available within the app via Help > DEVONthink 3 Help; you can also 
download it in the form of a user handbook in PDF, EPUB, or Kindle 
(Mobipocket) ebook format from the DEVONthink Handbooks and 
Extras webpage. 

Settings and Preferences 

Starting in macOS 13 Ventura, Apple renamed System Preferences to 
System Settings, and also began using Settings as the name of the 
window found in individual apps for configuring their preferences. As 
a result, if you’re using DEVONthink in Ventura or later, you go to 
DEVONthink 3 > Settings, whereas if you’re using Monterey or earlier, 
you go to DEVONthink 3 > Preferences. To avoid spelling that out 
dozens of times throughout the book, I now use a shorthand notation, 
like “go to Settings/Preferences > Editing.” 

What’s New in Version 1.12 

The twelfth quarterly update (nominally for Q4 2022, but actually 
released in Q1 2023) covers DEVONthink for Mac up through version 
3.9, and DEVONthink To Go for iOS/iPadOS up through version 3.6.4. 
This minor update changed the following: 

• Updated descriptions and screenshots of the Info Inspector and 
Document Inspector to reflect their new layout and capabilities 

• Added a bit more detail to the use of annotations in the Annotations 
& Reminders Inspector 

• Made a handful of text adjustments to account for System Settings 
changes in Ventura 

• Added a sidebar, Deep Linking with Selection Links and Annotation 
Links, about linking to specific locations in PDF documents 
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• Updated Do an Advanced Search with new screenshots and a 
mention of the Exclude Subgroups checkbox 

• Added some detail to the Use Shortcuts with DEVONthink To Go 
sidebar 

What Was New in Version 1.11 

The eleventh quarterly update (nominally for Q3 2022, but actually 
released in Q4) covered DEVONthink for Mac up through version 
3.8.7, and DEVONthink To Go for iOS/iPadOS up through version 
3.6.2. This minor update changed the following: 

• Updated all references to the Preferences window to include the 
term Settings, as explained in Settings and Preferences 

• Replaced several screenshots to reflect minor changes to icons and 
layout 

• Added a note about the Update Items command in the sidebar 
Updating Indexed Documents 

• Mentioned support for the Canon IJ Scan Utility in Scan Documents 

• Mentioned support for importing .gdoc and .gsheet files in Import 
Bookmarks from an HTML File 

• In Create a WikiLink, updated descriptions of preferences 

• Mentioned dropping links to Apple Mail messages and Calendar 
events into Markdown documents in Edit HTML and Markdown 
Documents 

• In Edit PDFs, added the new Rotate 180 Degrees command 

• Made some small updates in Use DEVONthink To Go to reflect 
recent interface and settings changes 

Note: If you’re still using Catalina or earlier, some of the windows, 
icons, and other interface elements will have a different appearance 
from what’s shown in this book. 
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Introduction 
Recently I was trying to explain DEVONthink to someone who had 
never used it. I started by saying it’s an information management tool, 
but that’s pretty vague. So I went on to say that it can hold, organize, 
and search files (like the Finder, only better); it can edit plain and rich 
text files (like TextEdit, only better); it can annotate PDFs (like Pre-
view, only better); it can store and present photos, movies, music, and 
webpages (though, admittedly, not as well as Apple’s Photos, Music, 
TV, and Safari apps); and that’s just the barest beginning. As I went 
through this litany of features, I realized that DEVONthink can take 
the place of a huge number of apps—if I had to, I could do nearly all my 
work within DEVONthink. It’s that powerful. 

As a result, when it comes to writing about DEVONthink, I almost 
don’t know where to begin. That’s my problem as an author, and it may 
be your problem as a user, too. DEVONthink has a marvelously deep, 
rich set of features, and it can adapt itself to just about any set of needs 
or work preferences. But, this wealth of power is like a 50-page restau-
rant menu in which every dish sounds equally delicious. There are so 
many excellent choices that finding a clear strategy to make the most 
of the meal—or the software, as the case may be—can be a daunting 
prospect. 

My goal in this book is to do just that: to help you wrap your brain 
around DEVONthink’s extensive options and figure out how best to 
use it to accomplish your goals. Whether you are starting out with the 
app for the first time or are a seasoned user looking for ways to get 
more out of it, I hope to show you where to focus, what to try, and how 
to think about DEVONthink in the most effective way. 

DEVONthink already has plenty of good documentation in the form of 
built-in help files (also available as a standalone ebook). The purpose 
of this book is neither to replace that information nor to explain the 
operation of every command and button. Instead, I concentrate on the 
key tasks you’ll want to accomplish. After providing an overview of the 
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app’s main concepts and interface, I walk you through the principal 
activities you’ll do over and over, such as getting information into 
DEVONthink; organizing, finding, and working with that information; 
using any of numerous techniques to automate DEVONthink; and, 
finally, getting your information back out by exporting or sharing it. 

And if all that leaves you hungry for more, I also provide a bit of 
dessert—a chapter (Dig Deeper) that goes into some of the program’s 
advanced capabilities, as well as Appendix A: Keyboard Shortcuts, 
which is sure to be helpful for power users. 

Stepping Stones 
I’ve peppered this book with a series of “Stepping Stones” sidebars 
like this one, which provide special advice for working through com-
plex choices in DEVONthink. Think of them as guides to help you 
navigate both the book and the software more easily. 

Note: DEVONthink 3 comes in standard, Pro, and Server editions 
(see DEVONthink Editions for details). When I write “DEVONthink,” 
I’m referring to features in all three; where appropriate, I point out 
which features are present only in the Pro or Server edition. 

Version 1.9 of this book is current as of DEVONthink 3.8.4. We plan to 
update this book approximately once per quarter to keep up with 
changes in DEVONthink. Even so, you may occasionally encounter 
something in the book that doesn’t quite match with what you see on 
your screen. I don’t expect these small inconsistencies to cause you any 
problems, but I do recommend reading the release notes for each 
update of DEVONthink you install for details on what’s new. And be 
sure to access the blog included in the online Ebook Extras for this 
ebook from time to time to see if I’ve added any new information. 

Tip: If there’s anything you read here that you want to learn more 
about, please let me know; my contact information is in About the 
Author and Publisher. Although I can’t guarantee I’ll cover every 
reader request, I’ll certainly take every one into consideration as I 
update the book. 

10 



            
            

            
            

     
        

 

 
      

    

         
 

            
  

  
            

   

            
        

          
      

          
        

  

          
 

DEVONthink Quick Start 
This book helps you find your way around DEVONthink 3 and explains 
how to use its most important features effectively. For the most part, 
each chapter builds on the one before it, so I recommend reading the 
book sequentially. If you choose to jump around, please read at least 
the first two chapters—Understand DEVONthink Basics and Explore 
DEVONthink’s Interface—which will help you understand the rest of 
the material. 

Get your bearings: 
• Acquaint yourself with DEVONthink’s unique conventions and 

terminology; see Understand DEVONthink Basics. 

• Learn your way around and find essential features; see Explore 
DEVONthink’s Interface. 

• Create one or more containers to hold your personal data; see Set 
Up DEVONthink Databases. 

Put DEVONthink to work: 
• Create new documents or import data from a variety of sources; see 

Get Information into DEVONthink. 

• Group, label, and tag data; add any of numerous kinds of metadata; 
and use other organizational tools. See Organize Your Information. 

• Use simple or advanced techniques to locate data you’ve previously 
stored in DEVONthink; see Find Your Information. 

• Edit data in DEVONthink or an external editor, use OCR with 
scanned documents, add annotations and imprints, and convert 
document formats; see Work with Your Information. 

• Let DEVONthink’s automation features do more of the heavy lifting 
for you; see Automate DEVONthink. 

11 



      
         

 

        
     

          
   

          
  

   
          

        
     

      

Use DEVONthink with other devices and people: 
• Keep multiple copies of DEVONthink in sync; see Sync 

DEVONthink Databases. 

• Store and manage your DEVONthink data on any iOS/iPadOS 
device; see Use DEVONthink To Go. 

• Share data locally or export it in numerous formats; see Get Infor-
mation Out of DEVONthink. 

• Use DEVONthink Server to share databases on the web; see Use 
DEVONthink’s Web Server. 

Go beyond the basics: 
• Solve problems and learn about some advanced features; see Dig 

Deeper. 

• Find a list of less obvious keyboard (and keyboard-plus-mouse) 
shortcuts; see Appendix A: Keyboard Shortcuts. 

• Find resources for further exploration; see Learn More. 
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Understand DEVONthink 
Basics 

DEVONthink isn’t difficult to use, but because it offers unique ways of 
dealing with your data, it requires you to learn a few new concepts and 
terms, and understand some behaviors that may be unexpected at first. 

Once you have a grip on the basic principles that underlie DEVON-
think’s operation, you’ll find that its features and capabilities fall into 
place more readily. Meanwhile, even though DEVONthink is both 
powerful and versatile, it’s not always the right tool for the job—so it’s 
also important to understand What DEVONthink Is Not Good For. 

What Exactly Is DEVONthink? 

Because you’re reading this book, I assume you already have a copy of 
DEVONthink, and that in turn implies that you have at least some idea 
what it is. But as I discovered when surveying a variety of DEVONthink 
users, different people think of the app in very different ways. There’s 
no one right answer, but as you get to know DEVONthink, it may be 
helpful to understand what it is (and isn’t), how it can function, and 
how it differs from comparable software. 

Among the many hats DEVONthink can wear are the following: 

• File and media browser: Like the Finder, DEVONthink can 
organize files in a hierarchical folder structure. And like Music and 
Photos, it can also store and play media such as music, photos, and 
videos (although its media capabilities are less advanced than those 
in Music and Photos). In addition, it stores metadata, extra pieces 
of information about each item (such as labels and modification 
date) in a special database, separate from the files themselves. 

13 



          
            

            
            
       

             
          

           
            

            
       

          
         

         
 

             
           

        
             

         
            

         
    

      
            

         
            
           

        
          

             
           

       

           
       

Everything you put into DEVONthink is indexed for fast searching 
and sorting, and you can group and identify information in ways the 
Finder doesn’t offer. All the original files are still available in their 
raw states on your disk, but from within DEVONthink you can see 
and use your data in much more flexible ways. 

• Snippet keeper: In the course of a day, you may want to keep 
track of URLs, notes to yourself, screenshots, parts of webpages, 
and countless other bits of information that don’t necessarily fit the 
mold of standalone files. Any app that provides a convenient way to 
capture and store such a wide variety of data can be called a snippet 
keeper. Apps such as EagleFiler, Evernote, MacJournal, Tinderbox, 
and Yojimbo—not to mention the Mac’s built-in Notes app—fall into 
this category. DEVONthink, too, can function as an outstanding 
snippet keeper, thanks to its remarkable capability to manage 
miscellaneous data. 

• Note taker: For people who spend a lot of time in classes or meet-
ings, having a tool that simplifies taking and working with notes is 
helpful. With apps such as Curio, NoteTaker, Pear Note, and Mi-
crosoft OneNote, you can not only type notes (as you could in any 
word processor or snippet keeper) but also record audio, highlight 
and annotate text and PDFs, make outlines, and do similar sorts of 
note-taking tasks. DEVONthink, too, offers several ways to facilitate 
note-taking—including audio and video notes. 

• Database: Database applications, such as FileMaker Pro, Panora-
ma X, and 4D, are in some senses the opposite of free-form note-
taking programs. By imposing a carefully designed structure on 
your data—whether it be a list of wine bottles in your basement, 
data on your company’s customers (or patients or clients), or an 
online catalog of thousands of products—databases enable you 
to filter and find data with great precision and flexibility. DEVON-
think, too, is a database of sorts, and although it doesn’t have all the 
capabilities of standalone databases, it does let you slice and dice 
some kinds of information in much the same way. 

• Web and RSS reader: There’s no shortage of Mac web browsers 
(Safari, Firefox, Chrome, Opera, and others) and RSS readers 
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(NetNewsWire, Reader, NewsFire, Vienna, etc.). DEVONthink may 
not have all the bells and whistles of a standalone web browser or 
RSS reader, but unlike the others, it lets you integrate URLs, web-
pages, news feeds, and other online content with the rest of your 
data in interesting ways, and, of course, it keeps all the content (and 
any associated metadata) indexed for fast searching. 

• Organizational tool: Although DEVONthink doesn’t try to be a 
mind-mapping program (like MindManager, MindNode, MindView, 
or TheBrain), it does have a number of capabilities that help you 
find and explore connections between pieces of data. For example, 
in addition to its support for labels, tags, and multiple pointers to 
documents, called replicants (see Words You Should Know, ahead), 
it uses artificial intelligence to classify new documents based on 
similar documents you’ve already sorted (discussed in Organizing 
Features, later in this chapter). 

In fact, DEVONthink is all these and quite a bit more. It lets you easily 
create, store, organize, find, and retrieve almost any kind of data. You 
can view your data in whatever way suits you best, and customize 
almost everything about the program and individual databases to meet 
your needs. It won’t replace the Finder for managing your files, and 
you may still need other specialized apps for dealing with certain kinds 
of data. But it’s an outstanding multitasker that can substitute for 
many other tools you may otherwise need. 
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Examples of Cool Things People Use DEVONthink For 
Just to stimulate your imagination a bit, here are some real-world 
examples of uses to which a variety of people put DEVONthink: 

✦ Writing books: Authors—including yours truly—store research 
materials, outlines, schedules, webpages, correspondence, time-
lines, drafts, screenshots, and reviews (among other documents) 
in DEVONthink. 

✦ Managing a medical practice: Physicians use DEVONthink to 
store research papers, seminar notes, patient records and corre-
spondence, lab results, and searchable scans of official documents. 

✦ Practicing law: Attorneys find DEVONthink a useful tool for 
managing the thousands of documents often required in legal 
cases—briefs, transcripts, case files, client information, templates 
of official forms, and the like. 

✦ Performing scientific research: Scientists store journal articles, 
research papers, experimental data, webpages, brainstorming 
notes, text snippets, and other tools of the trade in DEVONthink. 

✦ Developing software: Programmers and managers keep specifi-
cations, documentation, invoices, correspondence, and similar 
items in DEVONthink. 

✦ Studying religious texts: Clergy, religious scholars, and 
laypeople alike find DEVONthink useful for holding and searching 
sacred texts, commentaries, sermons, and research notes. 

✦ Maintaining a paperless office: People of all kinds find DEVON-
think Pro Office a great tool for converting scanned documents to 
searchable text, and for managing bank statements, tax records, 
receipts, business cards, and other items that would otherwise 
take up space in a filing cabinet. 

✦ Recreation: Users who are fond of such diverse hobbies as 
cooking, hill walking, martial arts, and role-playing games find 
DEVONthink the ideal repository for all their information (recipes, 
maps, notes, game playing tips, and much more). 
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DEVONthink Editions 

DEVONthink 3 is just one app, but the available features vary based on 
which of three editions you’ve paid for and unlocked via online regis-
tration or an in-app purchase. You can find a list of differences on the 
DEVONthink Editions page; here’s an overview of how they compare: 

• DEVONthink Standard: The standard edition is the baseline. It 
packs a wide range of organizational features—including multiple 
databases, RSS reading, sheets, support for a variety of file formats, 
and support for AppleScript. 

• DEVONthink Pro: The midrange choice adds features such as 
integrated support for numerous scanners, optical character recog-
nition (OCR), and email archiving. It also includes imprinting for 
PDFs and images, a download manager, a concordance, custom 
metadata, and several other useful features. 

• DEVONthink Server: The high-end edition adds just one feature: 
a web interface that enables you to share your databases over the 
web; other people can then view and edit database contents using a 
web browser, which may be especially handy for teams using more 
than one platform within their office. 

Thus, unless you specifically need the web interface, DEVONthink Pro 
is the sweet spot for most users, and what I recommend if you haven’t 
yet made a purchase and are unsure what to buy. 

A single license (to whichever edition) entitles you to two seats—that 
is, permission to use the app on two different Macs (regardless of who 
is using it on those two Macs). You can buy additional seats for any 
license at a reduced price. 

17 
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Words You Should Know 

DEVONthink uses certain terms in potentially unfamiliar ways. You’ll 
have an easier time getting the hang of DEVONthink if you start with 
a good understanding of the following words: 

• Alias: In DEVONthink, an alias is an alternative name for a docu-
ment, which you can use to reference it elsewhere in DEVONthink— 
for example, when making WikiLinks (see Create a WikiLink). 
Compare with replicant, below. 

• Classify: When DEVONthink classifies a document, it uses its 
artificial intelligence to decide which existing group a document 
best fits in, and then moves it into that group. 

• Database: The container in which DEVONthink stores content 
is called a database. On disk, this database consists of numerous 
files—settings, templates, metadata files, and so on—plus folders 
containing your documents themselves (text files, graphics, PDFs, 
etc.). Ordinarily, you need not concern yourself with these details; 
think of the database as a single big storage area for all your 
DEVONthink data. (To learn more about databases, see Set Up 
DEVONthink Databases and especially the sidebar How and Where 
Databases Are Stored.) 

• Document: Any file you create with, or import into, DEVONthink 
is called a document—that includes not only text files but also 
graphics, audio, webpages, and many other kinds of data. It also 
includes smaller “snippets” of data (such as URLs, notes, and 
sheets—described just ahead), even though you wouldn’t normally 
interact with them in the Finder as standalone files. 

• Duplicate: When DEVONthink contains two or more identical 
copies of a given document, each copy is known as a duplicate. 
(Later, in Duplicate and Replicate Documents, I discuss why you 
might want identical copies.) Although that’s what most people 
would assume the word means, I mention it here to distinguish it 
from the much different concept of a replicant, which I describe in a 
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moment. (Read the sidebar Identifying Unread, Duplicate, and 
Replicant Documents to learn how to spot a duplicate.) 

If you duplicate a document within DEVONthink, or if you import 
the same document into a DEVONthink database more than once, 
then ipso facto, DEVONthink considers each copy a duplicate. In 
some cases, DEVONthink’s artificial intelligence may also consider 
two ostensibly different documents—such as a single file you 
scanned on two different occasions—to be duplicates. But you can’t 
count on this, nor can you control DEVONthink’s threshold of 
similarity for what it counts as a duplicate. 

In general, if you later change anything about a duplicate besides its 
name or other metadata (including PDF annotations), it is no longer 
considered a duplicate. However, I know of no way to force 
DEVONthink to recognize two documents as duplicates if it hasn’t 
already determined that they are. 

• Group: When you see the word group in DEVONthink, think 
“folder.” Within DEVONthink, you can use groups to organize 
documents just as you can with folders in the Finder. Groups look 
like folders, and can be nested within each other. The only real 
difference is that a group in DEVONthink doesn’t necessarily corre-
spond to an actual folder in the Finder; it’s a construct you see only 
within DEVONthink. DEVONthink also uses “group” as a verb to 
mean “create a new group containing the selected items.” 

• Inbox: DEVONthink offers many ways to collect information from 
other places—dragging in files, using plugins to import messages 
from Mail or webpages from browsers, and so on. Depending on 
your settings and preferences, such items may need a temporary 
holding place until you decide how to group, tag, or classify them. 
That holding place is a special group called the inbox. Your inbox 
shows you all the items you’ve added to DEVONthink but not yet 
explicitly put somewhere else. In fact, you can have multiple inbox-
es—one for each database plus a global Inbox—as I explain further 
in Inboxes. 
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• Preview: The preview is an alternative name for the view/edit 
pane, the portion of a window that shows a single document and, in 
many cases, permits you to edit it too. Although you can see an 
entire, fully formatted document in a preview, you can also double-
click any document to open it in its own window (or in the default 
external app for that document type, depending on whether “Dou-
ble-click opens documents externally” is selected in Settings/Prefer-
ences > General). 

• Replicant: In contrast to duplicates, which are complete copies 
of other documents in a DEVONthink database, replicants are 
additional pointers to an existing document. Replicants let you store 
the same document in multiple groups without taking up extra space. 

You may think that sounds like aliases in the Finder, but unlike 
aliases (and like Unix hard links, for those of you who are familiar 
with such things), replicants are indistinguishable from originals. 
That is, if you create a replicant of a document, you can change either 
the original or the replicant and both instances instantly reflect the 
change. (In fact, the term “original” loses its meaning when you 
create a replicant, because every instance of a replicated document is 
identical to the others.) You can also delete either without affecting 
the other, because each replicant acts as an original, even though 
DEVONthink stores only one complete copy of the data. 

I say more about replicants in Duplicate and Replicate Documents. 
Also see the sidebar Identifying Unread, Duplicate, and Replicant 
Documents. 

• Sheet: In DEVONthink parlance, sheet is meant to evoke the idea 
of “spreadsheet.” But really, a sheet is just a document consisting 
entirely of a table. You can add, delete, rearrange, and sort columns 
and rows; but sheets can’t include formulas or calculations, produce 
charts, or do any other fancy spreadsheet-like stuff. See Create 
Documents in DEVONthink for more on sheets. 

• Smart group: Just as the Finder has smart folders, Mail has smart 
mailboxes, and Music has smart playlists, DEVONthink has smart 
groups. Like the other examples, smart groups are, in fact, saved 
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searches—you define certain criteria, and DEVONthink dynamically 
keeps your smart group updated with all the documents meeting 
those criteria. I discuss smart groups further in Use Smart Groups. 

• Tag: A tag in DEVONthink, like a tag in the Finder, is a word or 
phrase you use to identify one or more documents. For example, 
say you have lots of recipes (perhaps stored in various groups), but 
because their titles and contents don’t have any features in com-
mon, you want a quick way to tell DEVONthink, “This is a recipe.” 
So you create a tag called “recipe” and apply it to each of those 
documents. Then you can search, sort, and perform other opera-
tions based on that tag. 

Each document can have any number of tags. Group names can 
optionally function as tags, too, although they’re special tags that 
also identify a document’s location in your database hierarchy. For 
more on tags, see Tag Documents. 

• Trash: When you delete a document in DEVONthink, it goes into 
a Trash group—not to the Finder’s Trash—so you can later retrieve 
deleted documents if you change your mind. There’s a Trash group 
for each database as well as a global Trash group, but they’re all 
displayed under a single Trash icon in the sidebar. 

To empty the DEVONthink Trash—which, surprisingly, moves its 
contents out of DEVONthink and into the Finder’s Trash—choose 
DEVONthink 3 > Empty Trash. (Despite the warning DEVONthink 
displays when emptying its Trash, the items aren’t deleted perma-
nently until you empty the Finder’s Trash.) 

• View: A view is the arrangement of DEVONthink’s main window. 
You can adjust many aspects of the window using the View menu; 
see Item List. 

Importing vs. Indexing 

The word “import” may evoke the idea of a complex, one-time opera-
tion of moving data from one app to another, changing its format in 
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the process. But in DEVONthink, import just means moving a docu-
ment (or other outside data) into DEVONthink. You may do this 
dozens of times a day! When you import a document into your DE-
VONthink database, the app does all of the following: 

• Copies the original document to (or creates it in) the folder in which 
DEVONthink stores its database 

• Indexes the document’s contents, enabling fast searching without 
having to scan every file, every time 

• Updates the DEVONthink database to reflect the document’s title, 
attributes, and other metadata 

This standard approach to importing data from outside DEVONthink 
leaves you with two copies of the document—the original, still in its 
existing location on your disk, and the copy DEVONthink stores. That 
means changes to one won’t be reflected in the other, and you’ll use 
twice the disk space (unless you then delete the original file). On the 
other hand, it also means all your DEVONthink data is kept safely 
together in one place, and even if you delete the original document 
(intentionally or otherwise), your DEVONthink database remains 
complete and intact. 

Note: I cover the mechanics of importing and indexing later, in Use 
the Import or Index Command. 

However, you can add items to your DEVONthink database without 
copying them into DEVONthink’s storage area—indexing without 
importing. (That is, you can accomplish the second two bulleted items 
above without the first one.) 

When you do this, DEVONthink stores only a reference to the original 
file. You can still group, replicate, tag, and otherwise manipulate that 
reference in DEVONthink just as though it were any other document, 
but because it’s effectively an alias to a file, changes you make to that 
document inside DEVONthink are reflected in the original on your 
disk and vice versa. If you index entire folders (which become groups 
in DEVONthink) and you move an item within DEVONthink from one 
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indexed group to another, the original file moves to the corresponding 
folder in the Finder. 

Deleting documents works much the same way, but you can modify the 
behavior to suit your needs. When you delete indexed documents in 
DEVONthink (whether they’re indexed individually or are part of an 
indexed folder) and empty DEVONthink’s Trash, an alert like the one 
in Figure 1 appears. If you click “Only in database,” DEVONthink’s 
copy disappears permanently but the original file remains in the 
Finder. Click Files and the original file disappears in the Finder too 
(while any indexed folders remain in place); click Files & Folders to 
delete the original copies of both the files and folders. On the other 
hand, deleting an indexed file in the Finder doesn’t delete the docu-
ment from DEVONthink, but it does mean DEVONthink can no longer 
access its data—all that remains is its metadata and the index entries 
for its content. (In some cases, even moving an indexed file in the 
Finder can have the same effect.) 

Figure 1: Use this dialog to determine what happens when you 
delete an indexed item and empty the Trash. 
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Updating Indexed Documents 
Although DEVONthink usually updates its index automatically when a 
file on disk changes, sometimes things fall through the cracks— 
especially if the indexed file is on a network volume. Similarly, if 
you’ve renamed an item, changed its Spotlight comments, or made 
any other changes in DEVONthink while the original was unavailable, 
the corresponding file on disk might not update immediately when it’s 
once again available. And so, at any time, you can force DEVONthink 
to recheck the links between its index and external files by selecting 
one or more documents or groups and choosing File > Update In-
dexed Items (if no items are indexed, the command reads Update 
Items). When you do this, DEVONthink updates its database to reflect 
the files’ current contents, updates metadata in the original files on 
disk as necessary, and removes from the index any files that no 
longer exist. 

Note, however, that if you index a folder (as opposed to individual 
files), when you update the index, DEVONthink not only picks up 
modified and deleted files, but also adds to the index any new docu-
ments you may have added to that folder. 

In a given database, you can freely mix and match imported and 
indexed content. So, on any given occasion, how should you choose 
which method to use? 

As with everything in DEVONthink, there’s no single right answer, but 
I suggest looking at the decision this way: 

• If you want to maintain access to a file in the Finder but also keep 
track of it in DEVONthink, index it. (You can always move the item 
into your DEVONthink database later, if you change your mind.) 

• If you’re content having DEVONthink be the only place the docu-
ment is located, import it—and then delete the original. (To see how 
to do this in a single step, see the sidebar Import, OCR, and Delete.) 

For example, if you maintain a folder with hundreds of spreadsheets, 
and ordinarily open them from the Finder—but also want to track 
certain of them in connection with a project in DEVONthink—then 
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indexing is the right move. It keeps the originals in place, but lets you 
take advantage of DEVONthink’s numerous organizational features. 

If, however, you want to use DEVONthink to store old email messages, 
or all the notes related to a class you’re taking, or the word processing 
files and screenshots for a book you’re writing—and see no need to 
access those items from the Finder independently—then importing 
(and deleting the originals) makes more sense. 

What about importing but not deleting the originals? You’re free to do 
that too, of course, keeping in mind that you’ll use up extra disk space 
and that you could get confused over which copy of the document is 
which if you make changes to one but not the other. However, that 
might be the strategy you want if you’re using some existing files (such 
as graphics) for a special, self-contained project and want to make sure 
any changes you make for that project don’t affect the originals. 
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Stepping Stone: Try DEVONthink as You Read 
As you read this book, it may be helpful to try some of the things 
I discuss. So, if you haven’t already begun building a DEVONthink 
database, I suggest starting one and importing a small selection of 
files—preferably, ones containing mostly text—right now, just to have 
something to experiment with (you can always delete them later). 
Similarly, it’s useful to have a few groups in your database. 

It’s possible to use DEVONthink without creating any database at 
all—you can just drag stuff into the global Inbox and work with it 
there, because behind the scenes, the global Inbox is a separate 
database. However, I recommend against doing this for the same 
reason I recommend against keeping all your email in your inbox: it 
defeats the purpose of an inbox as a temporary way station and 
makes organization harder. 

So here’s what I suggest. First, create a new database by choosing 
File > New Database. Name it whatever you like and store it in the 
default location (~/Databases) as a temporary sandbox. Create an 
empty group by choosing Data > New > Group. Give the group a 
name (any name will do; use “Stuff” if you can’t think of anything 
else). Repeat this with a couple of other groups. 

Then, drag a handful of files (say, a dozen or so) from the Finder 
onto one of the newly created group icons in DEVONthink. Good 
choices to start with are word processing files, HTML files, PDFs 
(perhaps even this very ebook), and plain text files. 

Organizing Features 

Many of DEVONthink’s capabilities could be considered organizing 
features—even such simple and obvious things as its support for labels 
and hierarchical groups and tags. However, a pair of unique features 
that use DEVONthink’s artificial intelligence (AI) go above and beyond 
in helping organize your data: See Also and Classify. 

See Also is simply a list of documents (in the See Also & Classify 
inspector; see Classify Documents) that are similar to the one(s) you 
currently have selected, ranked in order of most to least similar based 
on an AI analysis of each document’s contents. This list helps you 
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discover connections between documents and locate material that’s 
relevant to whatever you’re working on at the moment. 

The Classify feature shows you which groups already contain docu-
ments similar to the one(s) currently selected—again, ranked in order 
of most to least similar. This list can help you identify the best place to 
file a document. The top choice (or, in some cases, more than one) is 
also available near the bottom of the Data menu: Classify to “Group 
Name” (or Classify to X groups). Choose this command and DEVON-
think puts the selected item(s) in the group(s) it thinks match best. 

Auto Group Is Dead. Long Live Group Similar Items. 
DEVONthink 2 had a nifty feature called Auto Group that used artifi-
cial intelligence to examine selected items’ contents, create new 
groups automatically, and sort the selected documents into those 
groups based on shared attributes. That feature was dropped in the 
transition to DEVONthink 3, but there is a new feature that behaves 
similarly, although it’s a bit obscure: Group Similar Items. 

In DEVONthink 3, select the items that need sorting, hold down the 
Shift key, and choose Data > Group Similar Items (⌘-Option-Shift-
G). DEVONthink creates new groups for the selected documents it 
deems most similar to each other, and moves those documents into 
the new groups. After you use this command, you’ll want to rename 
the automatically created group(s) and check to see if you agree with 
the results. 

See Also Everywhere with DEVONsphere 
If you like DEVONthink’s See Also command, you can use it system-
wide, thanks to the DEVONsphere app ($9.95). This app uses the 
same technology as See Also to identify items on your Mac that are 
related to whatever you’re looking at—an email message, webpage, 
document, or whatever. 
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About DEVONthink’s Artificial Intelligence (AI) 
When DEVONthink says a feature uses “artificial intelligence,” what 
does that mean? To oversimplify somewhat, DEVONthink has a fairly 
sophisticated algorithm that examines the text in a given document 
(along with document properties and custom metadata), compares it 
to the contents of all other documents, and mathematically computes 
the degree of similarity for each one. (It’s analogous to the process a 
spam filter uses to determine, based on an analysis of an email 
message’s contents, whether it’s most likely spam or legitimate.) This 
helps you determine where a document belongs and which docu-
ments might be related to it. 

Note that DEVONthink’s AI does not examine filenames or tags, so 
you can’t use them to give DEVONthink “hints” as to what you think 
should go where. And, because DEVONthink’s decisions are largely 
based on word similarity, if you have multiple groups whose files 
contain quite similar words, DEVONthink may suggest the wrong 
destination. Remember, it’s not magic—just statistics! 

DEVONthink’s AI engine is also used by the Summarize feature, and 
helps DEVONthink suggest names for scanned documents. 

What DEVONthink Is Not Good For 

If it’s not obvious by now, I like DEVONthink a lot, and I think it’s a 
fantastically useful, powerful, and flexible app. Nevertheless, it’s not 
the right tool for every job, and there are some tasks that it could 
theoretically accomplish…but not very well. 

So, to save you the grief of trying to force a round peg into a square 
hole, let me give you a few examples of DEVONthink’s limitations: 

• Cataloging photos: If you’re working on a project that includes 
photos (even a lot of photos) along with other types of data, it’s no 
problem to keep your photos in DEVONthink. However, keep in 
mind that DEVONthink can’t do half the things Photos can do (not 
to mention other photo library apps such as Adobe Lightroom CC). 
For that reason, I do not recommend using DEVONthink as the 
primary tool for storing and organizing all your digital images. 
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• Managing music: What’s true of photos is equally true of music 
and other audio. DEVONthink can store audio files, no problem, 
and it can even play them back, but that’s about it. You can edit 
some metadata for audio files in DEVONthink, but forget play 
counts, the iTunes Store, equalization, format conversion, and all 
the other things you rely on Music for. 

• Outlining: Even though you could use a series of nested groups to 
create a rudimentary outline, or manually make a bulleted or num-
bered list with varying levels of indentation, DEVONthink lacks a 
proper text-based outliner (with collapsible entries) along the lines 
of the one in Microsoft Word or OmniOutliner. 

• Web browsing: When it comes to viewing the odd webpage here 
and there (especially when following links from other documents in 
your database), DEVONthink’s built-in web browser is adequate. 
However, I’d never recommend it as a primary web browser, be-
cause it lacks many of the tools and convenience features of pretty 
much every standalone browser—form autofill, integrated search 
engine support, browsing history, and so on. (DEVONtechnologies 
does, however, make a capable standalone web browser; see the 
sidebar Using DEVONagent Pro with DEVONthink.) 

• Reading news feeds: For news feeds relating to a project that 
you’re tracking in DEVONthink, the built-in RSS reader makes it 
easy to pull in and index relevant content. When it comes to reading 
feeds, most users prefer a dedicated app such as Reeder or Net-
NewsWire, but for some purposes (such as using smart rules to 
evaluate new articles), DEVONthink may be a better choice. 

• Editing complex documents: DEVONthink’s text-editing 
capabilities are adequate, but you wouldn’t use them to write a 
technical book (like this one) or an academic paper. Instead, store 
your files in DEVONthink and edit them in your favorite word 
processor. Ditto for spreadsheets and other complex documents. 
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Explore DEVONthink’s 
Interface 

Now that you know the basic concepts and terms that DEVONthink 
uses, it’s time to learn your way around. Because of the many ways 
DEVONthink can display your data and some of the unique tools it 
offers, you’ll be on a firmer footing if you take a few moments to read 
this chapter and learn how the interface is organized, where to find the 
things that you’ll use most often, and what some of the program’s icons 
and other controls do. 

Support Assistant 

The first time you launch DEVONthink, a window called the Support 
Assistant opens (Figure 2) to welcome you and offer a tour of the app 
as well as links to tips, tutorials, support, and other help. 

Figure 2: The Support Assistant welcomes you with tips and 
tutorials. 
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The Support Assistant window appears every time you launch DEVON-
think. To keep it from doing so, deselect the Show This Window When 
DEVONthink 3 Opens checkbox. (You can then display it manually, 
whenever you want, by choosing Help > Support Assistant.) 

Although it may not be obvious at first glance, you can access lots of 
useful features from this window: 

• Newsletter subscription: To subscribe to a free periodic news-
letter with DEVONthink tips, enter your email address under 
“Newsletter.” Then click the blue checkmark icon to subscribe. 

• Tip and extra of the day: The right side of the Welcome screen 
presents a random selection from the tips and extras, all of which 
are found elsewhere in the Support Assistant. 

• Technical support: Click the Get Support link at the bottom 
of the window for shortcuts to the DEVONthink FAQ, user forum, 
and contact page, plus tools to retrieve a lost license (or buy a 
license if you’re still using the free trial), update your name or email 
address, and read the DEVONtechnologies blog. 

• Extras: Click the Install Extras link at the bottom of the window 
to display a screen with extra AppleScripts and templates (beyond 
those installed automatically or via the Add-Ons window, discussed 
next); you can install any of these by clicking the Install button 
beneath it. (To remove an installed item, click Remove.) You can 
also check the “Install & update extras automatically” box at the 
bottom, which installs all the extras immediately and keeps them up 
to date automatically. 

• Setup: Click the Setup link at the bottom of the window for a quick 
three-step overview of how to get started with DEVONthink—make 
a database, install add-ons, and customize. (Feel free to skip these; I 
cover all these things later in the book.) 

• Tips and tutorials: Click the Tips & Tutorials link at the bottom 
of the window to show a selection of text-based tips (at the top) and 
step-by-step illustrated tutorials (at the bottom). 

31 



          
         

           
          

    

      
        

      

Tip: To return to the initial screen of the Support Assistant at any 
time, click the Welcome link at the bottom of the window. 

Add-Ons 

If you haven’t already installed the add-ons from within the Support 
Assistant, choose DEVONthink 3 > Install Add-Ons to display the 
Install Add-Ons window (Figure 3). 

Figure 3: This window enables you to install useful add-ons with 
just a few clicks. (The “Install Avision ExactScan Support” checkbox 
appears only if you already have ExactScan installed.) 
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For now, I recommend leaving the default items selected, clicking 
Install, and following the prompts, because the additional tools will be 
useful to you. If you choose to skip this now, or omit any of the add-on 
options, you can always return to this window later. I describe each of 
these add-ons and how to use them later in this book. 

Main Window 

When you begin using DEVONthink, the main window looks some-
thing like Figure 4. This is where nearly all the action happens. 
DEVONthink 3 integrates almost everything into a single window, with 
sidebars, toolbars, and context-sensitive inspectors—much like Apple’s 
iWork apps. 

Figure 4: The main window in DEVONthink looks something like this 
by default. 

Because every aspect of the window is customizable, yours may look 
different from the one shown here. But let’s take a quick spin through 
the major parts of the default window. Figure 5 below shows the main 
window as it appears with most optional areas visible—but with no 
documents yet in DEVONthink. I explain each labeled area ahead. 
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Figure 5: The main parts of the DEVONthink window: ⓵ toolbar, 
⓶ sidebar, ⓷ item list, ⓸ path bar, ⓹ information bar, ⓺ view/edit 
pane (or preview), ⓻ navigation bar, ⓼ tag bar, ⓽ inspectors. 

Note: DEVONthink 3 supports Dark mode in macOS Mojave and 
later; you can enable this in System Settings > Appearance or 
System Preferences > General. (With Dark mode enabled on your 
Mac, documents in DEVONthink have a dark background and white 
text by default; to change this, go to Settings/Preferences > General 
> Appearance and uncheck “Use dark background for documents.”) 
In this book, however, all the images are shown using the Light 
appearance. 

DEVONthink 3 offers a flexible set of controls to create almost any 
layout you may want. You can selectively show or hide almost every 
part of the window, and choose a vertical or horizontal arrangement of 
the item list and view/edit pane. (It also continues to offer two Full 
Screen options.) Keep reading in this chapter for further details. 

Toolbar 
The toolbar at the top (Figure 6) provides quick access to many 
commonly used DEVONthink features, such as showing or hiding parts 
of the window, marking and labeling documents, and searching. The 
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contents of the toolbar change according to what (if anything) is 
currently selected. 

Figure 6: Access frequently used commands via the toolbar (shown 
here as it appears in Big Sur and later). 

To learn what any control does, hover over it briefly with your pointer, 
and a pop-up tooltip tells you its function. If you want to rearrange the 
items on the toolbar, add new ones, or remove ones you don’t need, 
choose View > Customize Toolbar. Using the dialog that appears, drag 
icons onto or off of the toolbar, or drag them to other positions on the 
toolbar. You can also determine whether icons, labels, or both appear 
using the Show pop-up menu. Click Done when you’re finished modi-
fying the toolbar. 

Each control on the toolbar is accessible in at least one other way (such 
as a menu command or keyboard shortcut). So, if you prefer to hide 
the toolbar to give yourself more space, choose View > Hide Toolbar. 

Sidebar 
Along the left side of the window is the sidebar, which is shown in 
Figure 7. To be more precise, DEVONthink can show any of four 
different sidebars, depending on which icon is selected at top. The 
Navigate sidebar shown below is the default and most common 
one, but there’s also the Reading List sidebar, the Import 
sidebar, and the Extras sidebar, all discussed ahead. 
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Figure 7: The sidebar displays your favorites, inbox, open databas-
es, and other frequently accessed items. Left: as it starts out, mostly 
empty; right: populated with some example items. 

You can hide the sidebar by choosing View > Hide Sidebar; to display it 
again, choose View > Show Sidebar. If the sidebar is hidden, however, 
you won’t be able to see or access your global Inbox (see Inboxes), 
Trash, favorites, global smart groups, or global smart rules. 
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Navigate Sidebar 
The “main” sidebar view, shown above in Figure 7, shows global items 
(such as the Inbox, tags, and Trash from your global database, plus 
smart groups and smart rules); it also displays your open and recent 
databases, and your favorite databases, documents, and groups (see All 
About Favorites). It’s handy to show this, for example, when you want 
to drag something from one database to another. 

If you want to use the keyboard to move around within the Navigate 
sidebar, go to Settings/Preferences > General > Interface and select 
“Keyboard navigation” (in the Sidebar section). Having done that, you 
can do the following in the Navigate sidebar: 

• Move up or down using ↑ or ↓. 

• Expand or collapse a group using ← or →. 

• Rename the selected item by pressing Return and typing a new 
name. 

• Remove the selected item from the sidebar by pressing Delete or 
Backspace. 

• Switch to the previous or next database with ⌘-Option-R and ⌘-
Option-E, respectively. 

Note: You can select multiple groups, smart groups, and/or feeds in 
the sidebar at the same time and see their merged contents in the 
main view. 

By default, DEVONthink unifies all your databases under the Open 
Databases heading, and it unifies all your inboxes (in much the same 
way as Apple Mail) under the Globals heading. However, if you prefer, 
you can keep databases and/or inboxes separate. 

You can alter these settings in Settings/Preferences > General > 
Interface in the Sidebar section: 

• With “Unify databases” checked (the default), each database along 
with its contents is an entry under Open Databases (Figure 8, left). 
If you uncheck “Unify databases,” only the database names are 
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shown under Open Databases; select one to show its expanded 
contents under its own sidebar heading (Figure 8, right). 

Figure 8: The effect of having “Unify databases” on (left) and off 
(right). In the latter, the selected database, expanded under its own 
heading, has an asterisk (*) next to its name under Open Databases. 

• With “Unify inboxes” checked (the default), each database’s inbox 
appears in the Inboxes group under Globals (Figure 9, left). If you 
uncheck “Unify inboxes,” only the Global Inbox appears under 
Globals, while each database’s inbox appears under that database’s 
name in the Open Databases section (Figure 9, right). 
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Figure 9: The effect of having “Unify inboxes” on (left) and off 
(right). 

All About Favorites 
The Favorites list at the top of the Navigate sidebar is for anything 
you want to be able to access quickly. To add a database, document, 
or group to the Favorites list, select it and choose Data > Add To > 
Favorites. 

Apart from the sidebar, you can also access your favorites using the 
Go > Favorites submenu; they also appear in the Sorter and in 
various other locations (such as the Move To, Duplicate To, and 
Replicate To submenus). You can rename favorites in the sidebar; 
doing so affects only the favorite itself, not the original item. 
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Reading List Sidebar 
The Reading List sidebar (Figure 10) functions much like the 
Reading List in Safari and other browsers: it displays documents 
you’ve marked for later reading. 

Figure 10: Documents to be read appear in the Reading List side-
bar. 

To add a document to the Reading List, select it and choose Data > 
Add To > Reading List (or the comparable commands on the Action 

menu or the contextual menu). The Reading List maintains its own 
read/unread status for each document, separate from the document’s 
main status. Documents are marked unread by default, but when you 
select one, its status changes to read. (If All is selected at the top of the 
list, it shows both read and unread items; click Unread to show only 
unread items.) To remove an item from your Reading List (without 
deleting it from your database), right-click (or Control-click) it and 
choose Remove Item from the contextual menu. You can rearrange the 
Reading List via drag and drop. 
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Import Sidebar 
The Pro and Server versions of DEVONthink have an Import side-
bar (Figure 11), which adds yet another way to import scanned 
documents and email messages. For more details, see Scan Documents 
and Add Email Messages, respectively. 

Figure 11: The Import sidebar provides just one of several ways to 
import scanned documents and email messages. 

Extras Sidebar 
The Extras sidebar, like the Support Assistant window, provides access 
to useful, up-to-date content and tools from DEVONtechnologies, 
including scripts, templates, smart rules, tips, tricks, and news (Fig-
ure 12). 
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Figure 12: The Extras sidebar gives you another way to access the 
latest tools and info from DEVONtechnologies. 

Item List 
The item list, sometimes referred to as the view, is the portion of the 
window (labeled ⓷ in Figure 5) that lists your documents and 
groups—it’s the one part of the window that’s always present, though 
you can change its appearance at any time. As in the Finder, you can 
display the items in the list as Icons, List, or Columns, as well as using 
Cover Flow (which was present in older versions of macOS, before 
being replaced with Gallery view in Mojave). At your option, the item 
list may also be accompanied by the view/edit pane, sidebar, inspector, 
and other window elements. 

You can switch item list views by using commands in the View portion 
of the View menu, or by clicking the icons on the information bar. 
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Note: As I describe DEVONthink 3’s views, I’ll also refer back to the 
views DEVONthink 2 used (some of which use the same names), in 
an effort to help you create a window layout that resembles what you 
may have used in the older version. 

Stepping Stone: Pick a Layout, Any Layout 
DEVONthink tries to be helpful by providing many different ways to 
configure your window and view your data, but switching between 
layouts can be disorienting. Documents may disappear, sort order 
may change, and other display elements may rearrange themselves 
in an unfamiliar way. So most people tend to pick a collection of 
layout settings that works for them most of the time, and stick with 
it—switching only when a need arises. 

I suggest trying out each view (and other layout options) with your 
own DEVONthink data as you read this chapter, and perhaps taking a 
few notes on which ones seemed most or least helpful for future 
reference. Given the way I use DEVONthink, I personally prefer to 
have the sidebar, inspector, and Standard view/edit pane visible, 
along with either List view or Column view. 

View as Icons 
Icon view (Figure 13), which displays large thumbnails of each 
document, is perhaps the least useful option. While in Icon view, you 
can use the slider on the information bar to adjust the size of the icons. 
You can also sort the icons in many ways (by name, kind, size, and so 
on) using the pop-up menu next to that slider. 
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Figure 13: Icon view shows resizable thumbnails of each item. 

Tip: To approximate DEVONthink 2’s Icon view, enable the sidebar, 
set the View to “as Icons,” and set the preview to None. 

In Icon view only, you can choose View > Show Details or View > Hide 
Details (⌘-Option-L) to toggle the display of additional details about 
each document or group (Figure 14), giving Icon view some of the 
additional benefits of List view. 

Figure 14: Show extra info in Icon view with the Details command. 
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View as List 
List view (Figure 15) provides more detail about each document, as 
well as a hierarchical view of all your groups. By default, List view 
shows Name, Modified (date and time), Kind, Size, and URL columns. 
To change which columns appear, choose a column name from the 
View > List Columns submenu. As you might expect, you can sort by a 
column by clicking its name; reverse the sort order by clicking again; 
drag and drop to rearrange columns; and resize columns by clicking 
the border between two adjacent column headers and sliding the 
pointer left or right. 

Figure 15: List view provides more (and configurable) detail about 
each item in your database, and lets you see the contents of groups 
at a glance. 

Tip: To approximate DEVONthink 2’s List view, enable the sidebar, 
set the View to “as List,” and set the preview to None. 
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A Word About Sort Order 
Each view can automatically sort its contents in a wide variety of 
ways (such as by Location, by Due Date, or by Word Count). If the 
view includes column headers, you can click a header to sort by that 
criterion, and click again to reverse the sort order. (Right-click or 
Control-click the column header to add or remove columns.) 

To adjust the sort order for views without column headers, or using 
criteria not shown in a column, use the pop-up menu on the informa-
tion bar next to the view icons (the menu’s name reflects the current 
sort order); choose Ascending or Descending from this menu to 
reverse the order. Alternatively, choose an item from the View > Sort 
submenu. 

If you prefer to manually drag items into just the order you like, 
choose Unsorted. 

View as Columns 
Column view (Figure 16) lets you quickly navigate a deep hierarchy of 
groups without losing your place or running out of room on the screen. 

Figure 16: Navigate complex hierarchies quickly in Column view. 

Tip: To approximate DEVONthink 2’s Column view, enable the side-
bar, set the View to “as Columns,” and set the preview to Standard. 
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As in the Finder, you can drag the dividers between columns to resize 
them individually, Option-drag them to change the width of all col-
umns at once, or double-click a separator to auto-resize to the width of 
the longest name. You can also sort by any criterion you prefer. To 
change the sort criterion, choose a command from the View > Sort 
submenu; choose Ascending or Descending from this menu to reverse 
the sort order. 

Tip: DEVONthink’s Column view (unlike the Finder’s) lets you sort 
each column by a different criterion if you like—for example, the first 
by name, the second by date modified, and the third by size. Click in 
a column and then choose a command from the View > Sort sub-
menu to sort that column. 

Tip: To approximate DEVONthink 2’s Split view, enable the sidebar, 
set the View to “as List,” and set the preview to Widescreen. 

Missing Views 
Although I’ve added notes about how to get DEVONthink 3 to approx-
imate DEVONthink 2’s views, not everything can be mapped. For 
example, DEVONthink 3 has no exact equivalent to DEVONthink 2’s 
Three Pane view, which added a column between the sidebar and the 
item list/preview with a list of the selected database’s groups. That 
arrangement is largely unnecessary now that the sidebar shows each 
database’s groups, but if you want to approximate the old Three Pane 
view, see the DEVONtechnologies blog post How to Simulate Three 
Pane View. 

There’s also no exact equivalent to DEVONthink 2’s Tag view, which 
showed an extra column on the right listing all the tags in the select-
ed database. However, you can see tags for the selected document in 
numerous other ways: 

✦ Tags appear in the Info inspector. 

✦ You can display tags in a filter pane at the bottom of the Navigate 
sidebar by clicking the Tags icon. 

✦ You can also display tags at the bottom of the view/edit pane by 
choosing View > Show Tags. 
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View as Cover Flow 
Cover Flow (Figure 17) displays a large thumbnail of each document 
in the current group in a horizontally scrolling list; it’s useful primarily 
for graphics. The selected item (in the middle; a bit larger than the 
others) shows a tooltip with the document’s name and resolution; a 
full-size image appears in the view/edit pane. 

Figure 17: Cover Flow shows previews of each document. 
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Identifying Unread, Duplicate, and Replicant Documents 
DEVONthink uses styles, icons, and (optionally) colors to identify 
documents of certain kinds: 

✦ Unread: When a document name appears in bold and has a bullet 
in the Flag column, it’s marked as unread. (By default, docu-

ments are marked as read when you view them; to change this, 
go to Settings/Preferences > General and uncheck “Automatically 
mark items as read.” You can manually change the read/unread 
status with Data > Mark > As Read or As Unread.) 

✦ Duplicate: By default, duplicates have a special icon ( ) next to 
their names. If you select “Mark duplicates and replicants in color” 
(Settings/Preferences > General > Appearance), DEVONthink 
instead displays the name of each duplicate document in blue 
(omitting the icon). Note that duplicates can have different names 
from each other. 

✦ Replicant: By default, each replicant appears with an icon ( ) 
next to its name. If you select “Mark duplicates and replicants in 
color” (in Settings/Preferences > General > Appearance), DEVON-
think hides the icon and displays the name of each replicant in red 
(and italics). If you delete all but one replicant of a document, the 
remaining document’s icon disappears (or its name reverts to 
black, as the case may be). 

These attributes may be combined; for example, an unread, duplicat-
ed document has both a boldface name and the appropriate duplicate 

icon (or a blue color). And, if you replicate a duplicate, each 
replicant gets an icon ( ) indicating that dual status. 

Path Bar 
Just above the item list is a horizontal strip with two sections divided 
by a vertical line. The left-hand section is the path bar, which helps 
you navigate within your database. It shows the item currently selected 
in the sidebar and a “bread crumb” path of enclosing groups, if any. 
You can click any item in this path to jump to that group, right-click 
(or Control-click) it to see a contextual menu with Open and Reveal 
commands, or ⌘-click it to open it in a new window. There are also 
back  and forward icons, which work like those in a web browser for 
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moving to previously viewed documents. (You can right-click, Control-
click, or click and hold the icons to see a list of earlier or later loca-
tions; ⌘-click an item in the history list to open it in a new window.) 

Information Bar 
Immediately to the right of the path bar is the information bar, which 
(as the name suggests) displays information about the currently 
selected item(s), such as the number of items in the current view and 
the number of items (if any) currently selected. 

On the right side of the information bar is a pop-up menu to change 
the sort order (using any of dozens of pieces of metadata) and icons to 
switch between Icon, List, Column, and Cover Flow views. 

View/Edit Pane 
The view/edit pane (sometimes referred to as the preview) is the 
portion of the window (labeled ⓺ in Figure 5) that displays the 
contents of the selected document, if any. In most cases, it lets you edit 
it, too. Although you can double-click any document to open it in its 
own window if you prefer (or in an external app, depending on the 
setting of Settings/Preferences > General > Interface > “Double-click 
opens documents externally”), you can often do all your editing right in 
the view/edit pane. I discuss editing further (whether in the view/edit 
pane or otherwise) in Edit Documents in DEVONthink. 

As in the Finder, web browsers, and most document-based apps, the 
view/edit pane can have multiple tabs, each showing a different docu-
ment. The tab bar is normally hidden if only one document is open; to 
display it all the time, go to Settings/Preferences > General > Interface 
and check “Always show tab bar.” Most controls for working with tabs 
(such as New Tab and Close Tab) are found on the Window menu. 

You can drag tabs left or right to reorder them; scroll through a large 
number of open tabs; close a tab without switching to it first; and, in 
Big Sur or later, use the spring-loading effect (as in the Finder) to drag 
something onto a tab, wait until it opens, and then continue dragging it 
to a specific location. 
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To open multiple documents, each in its own tab, hold down Option 
and choose Data > Open In Tabs (⌘-Option-O). (If the view/edit pane 
is not visible when you use this command, DEVONthink opens a 
separate document window, with each document in a different tab.) 

Note: You can change the magnification of the view/edit pane by 
choosing View > Zoom > Zoom In or View > Zoom > Zoom Out (hold 
⌘-Control and press + [plus] or – [minus], respectively). 

Widescreen 
The widescreen preview option (View > Widescreen or ⌘-7), positions 
the view/edit pane on the right side rather than at the bottom. This 
arrangement makes more efficient use of screen real estate on large 
monitors (especially widescreen monitors). Figure 18 shows a 
widescreen preview along with List view; compare with Figure 15, 
which shows the same thing with a standard preview. 

Figure 18: With the widescreen option turned on (as shown here 
with List view), DEVONthink positions the view/edit pane on the right 
rather than at the bottom. 

Tip: By default, if you’re using Column view, the widescreen preview 
shows only one column, but you can drag the divider between the 
item list and the view/edit pane left or right to change the size of the 
item list (and thus the number of columns shown). 
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Full Screen 
If you find screen clutter distracting, you can use either of two Full 
Screen modes. First, you can opt for macOS-style Full Screen mode, 
which applies to the entire DEVONthink window; to enter this mode, 
choose View > Full Screen > Window (⌘-Control-F) or click the Full 
Screen icon in the upper-left corner of the window. To leave Full 
Screen mode, press Esc. 

Alternatively, you can use DEVONthink’s document-specific Full 
Screen mode. When you choose View > Full Screen > Document (⌘-
F7), the selected document fills your entire screen; in the case of plain 
text and rich text documents, your entire screen turns black by default 
while text becomes bright green (Figure 19). To leave Full Screen 
mode, press Esc. 

Figure 19: For minimalist text editing, choose Full Screen mode. 

To adjust Full Screen mode’s font, size, colors, and text width, go to 
Settings/Preferences > Editing and make changes in the Full Screen 
section. 

Navigation Bar 
At the top of the view/edit pane is a narrow strip of controls called the 
navigation bar (Figure 20; also labeled ⓻ in Figure 5). The selec-
tion of controls on the bar varies according to what type of document 
(if any) is selected and its current state. 

Figure 20: The navigation bar as it appears for a PDF document. 
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In general, the navigation bar contains controls for (you guessed it) 
navigating within the view/edit pane, such as visiting the next or 
previous page within a web browser or PDF, as well as previous loca-
tions elsewhere in DEVONthink (using the same back  and forward 
icons as on the path bar). One other control that appears consistently 
on the right side of the navigation bar is the Show Editing Bar icon, 
which replaces the contents of the navigation bar with controls appro-
priate for editing the document type selected (e.g., one set of controls 
for text, another for graphics, and yet another for PDFs). I say more 
about this later, in Edit Documents in DEVONthink. 

Tag Bar 
Any document in a database can have one or more tags to help as-
sociate it with related content. One way to see those tags is to use the 
tag bar (Figure 21), which is labeled ⓼ back in Figure 5 (see Tag 
Documents for more). Group tags (that is, tags 
representing group names) show extra tabs on the right side; ordinary, 
non-group tags  do not. 

Figure 21: The tag bar can appear at the bottom of the window to 
enable you to view and edit tags. 

The tag bar can appear at the bottom of the view/edit pane, whenever 
the view/edit pane is visible. To toggle it on or off, choose View > Show 
Tags or View > Hide Tags (⌘-Control-Option-T), or click the Show/ 
Hide Tags icon on the toolbar. 

Inspectors 
Just as the sidebar pane appears on the left side of the window and 
may display any of several different sidebars, the inspector pane 
(labeled ⓽ in Figure 5) appears on the right side of the window and 
may display any of seven different inspectors, depending on which icon 
is selected at the top. From left to right, they’re the Info inspector, 
the Annotations & Reminders inspector, the Content inspector, 
the Document inspector, the Concordance inspector, the See Also 
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& Classify inspector, and the Search inspector. (The currently 
selected icon appears in blue.) I describe each of these ahead. 

Info Inspector 
Besides listing statistics about the current document, this inspector 
(Figure 22) lets you rename the document; exclude it from classifica-
tion, search, See Also, and tagging; modify labels and tags; see and 
navigate to duplicates and replicants; add aliases; and lock or unlock 
the document. I discuss many of these activities elsewhere. 

Figure 22: The Info inspector lets you view and change numerous 
document characteristics. 

The Properties tab, which was located in the Document inspector 
before version 3.9, includes items such as author, title, subject, and 
keywords. 
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DEVONthink Pro and Server expand the capabilities of the Info in-
spector by adding a Custom tab, where you can add any of numerous 
built-in or user-defined metadata types. To learn more about metadata 
generally and custom metadata specifically, refer to Work with Meta-
data, later in this book. 

In case the inspector is hidden or displaying a different pane, you can 
also display the information from the Info inspector in a popover by 
selecting a document and choosing Tools > Get Info (⌘-Shift-I) or 
clicking the Info icon on the toolbar. 

Annotations & Reminders Inspector 
The Annotations & Reminders inspector (Figure 23) provides the 
tools to set reminders (including alarms) about the current document 
(see Use Reminders), view or add Finder comments, and add or edit 
annotations (separate files containing comments about this file; see 
Template). 

Figure 23: The Annotations & Reminders inspector lets you set 
reminders and add comments and annotations. 
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In this context, an annotation is a text note you add to a document. 
DEVONthink stores these annotations as separate documents (annota-
tion files) that are linked to the originals; you can see them, for exam-
ple, in the Annotations smart group at the top level of the database. 

Note: DEVONthink uses the word annotation in two senses. Annota-
tion files are linked documents containing comments on other docu-
ments (the sense described here), while ordinary annotations (such 
as those you add to PDFs or graphics) appear within a document and 
can include notes, shapes, and other extra-textual additions. 

Content Inspector 
The Content inspector displays the table of contents for PDF, Mark-
down, and EPUB documents that include one; it also shows thumb-
nails for PDF documents (Figure 24). Both the table of contents and 
the thumbnails are live, so you can click an item to navigate to that 
point in the selected document. 

Figure 24: If your document contains a table of contents, you can 
view it (and navigate using it) in the Content inspector. 
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Document Inspector 
The Document inspector (Figure 25) shows a wide variety of docu-
ment-level metadata. 

Figure 25: The Document inspector shows PDF annotations (and 
rich-text highlights), attachments, links, and mentions. 

The Annotations tab shows highlights in RTF files and PDF annota-
tions (not to be confused with DEVONthink’s annotation files); the 
Attachments tab displays attachments in files that support them; the 
Links tab shows any hyperlinks found in PDF and RTF files, as well as 
in web archives and other web-based documents (outgoing links are 
found at the top under the Links heading, while incoming links are 
found at the bottom under the Incoming Links heading; see Work with 
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Item Links and WikiLinks for more on using links); and the Mentions 
tab shows other documents that mention this one (by including this 
document’s name, prepended with an @ sign, somewhere in the text). 

Concordance Inspector 
Do you wonder whether you’re overusing certain words, or are you 
curious about how often certain terms in a document occur relative to 
other terms? Select the document and choose Tools > Inspectors > 
Concordance > List or click the Concordance icon in the inspector. 
The Concordance inspector (Figure 26) lists every word in your 
document by frequency (number of occurrences). 

Figure 26: The Concordance inspector shows all the words in your 
document, sorted by frequency. 
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I discuss the Concordance in more detail later, including how to use 
the feature across multiple documents—or even an entire database— 
and the Cloud and Graph options (see Search Using the Concordance). 

Note: The Concordance appears only in the Pro and Server versions 
of DEVONthink 3. 

See Also & Classify Inspector 
One of DEVONthink’s coolest and most powerful features is found in 
the See Also & Classify inspector. The See Also and Classify features 
use artificial intelligence to help you determine where a document 
should go and what other documents may be related to it. 

To open this inspector (Figure 27), select a single document and then 
choose Tools > Inspectors > See Also & Classify (Control-S). You can 
use the controls just under the search field to choose whether the 
analysis is done by content or (if applicable) by tags, and whether it’s 
confined to the current database. The next portion of the inspector lists 
groups that may be a good place to store the document. The bottom 
portion lists other documents that have similar contents to the one 
you’ve selected. I discuss these features further in Classify Documents. 
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Figure 27: The See Also & Classify inspector helps you move 
documents to their proper home and find related documents. 

Search Inspector 
DEVONthink offers several ways of searching, but the Search inspector 
(Figure 28) is the place to go if you want to search and/or replace 
within the current document. Matches are listed at the bottom of the 
inspector and highlighted in the view/edit pane. To learn more about 
searching within a document, see Search Within a Document. 
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Figure 28: The Search inspector lets you do simple searches and 
replacements within the selected document. 

Panels 

A few windows in DEVONthink, called panels, look different from 
normal windows or popovers and provide extra info or special features. 
The following are the panels you’re likely to see most frequently. 

Activity 
On the Activity panel, you can follow the progress of tasks that take a 
while to complete. To display this panel if it’s not visible, choose 
Window > Activity (⌘-Option-A). Examples of what it may show: 

• When you sync your database with another location (see Sync 
DEVONthink Databases), the Activity panel shows you the syncing 
progress. (If you’re syncing directly between two Macs, it appears 
on both.) Ordinarily it disappears when the sync is complete. 
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• In DEVONthink Pro or Server, when you choose Data > OCR > “to 
searchable PDF” (or configure the app to perform OCR automatical-
ly on newly scanned documents), the Activity panel appears, show-
ing the progress of each document as it is recognized and any 
documents waiting for their turn. 

Note: Another way to view current activity is to look at the bottom of 
the Navigate sidebar, where an Activity pane appears as needed, and 
disappears when there’s no further activity to report. 

Download Manager 
When you download a file from the web using the built-in web browser 
in DEVONthink Pro or Server, a Download Manager panel appears, 
much like the one in Safari or Firefox. It shows your current, pending, 
and recent downloads and lets you stop or redirect them. 

To open this window, choose Window > Download Manager. 

Log 
The Log panel, which you can toggle by choosing Window > Log, lists 
errors and other status messages generated during DEVONthink’s 
normal activities. These may include notices that documents have been 
imported or exported, for example, or that the database has been 
converted from an older format. 

Note: The log can also appear in a popover when you click the Log 
icon on the right side of the toolbar. 

If you find the Log panel intrusive and want to prevent it from appear-
ing unless you explicitly display it, uncheck the “Show log automatical-
ly” box in the lower-left corner of the Log panel. (DEVONthink ignores 
that setting if it needs to display information on a critical error.) 
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Document Windows 

If your monitor is sufficiently large, you may find it comfortable to do 
all your viewing and editing right in the view/edit pane of DEVON-
think’s main window. However, it’s often more convenient to view, 
edit, or create documents in their own windows, which also provide 
extra toolbar icons for your convenience. 

Note: DEVONthink can edit many types of documents and can 
display the contents of even more types (see Edit Documents in 
DEVONthink). If you double-click a document DEVONthink can’t 
display, the document opens in its default application instead. 

To open a document window, double-click any document (or choose 
a command from the Data > New submenu to create a new one from 
scratch). The appearance of the window and the controls available on 
the toolbar vary according to the type of document you’re editing. For 
example, Figure 29 shows the window for a rich text document. 

Figure 29: When you open a document in its own window, you get 
more room to work—plus a separate (and customizable) toolbar. 

Inboxes 

The next-to-last item I want to introduce you to on this interface tour 
is the inbox, which as I’ve already mentioned is meant as a storage 
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place for newly imported or indexed documents you haven’t yet sorted. 
In this respect it’s rather like the inbox in your email app. (Just as I 
recommend trying to keep one’s email inbox empty most of the time, 
I recommend the same for DEVONthink—the app is much more useful 
and effective when you group, or at least tag, each document.) 

Because DEVONthink supports multiple databases, it has multiple 
inboxes, too—one for each database, plus a global Inbox (which is 
technically a separate database). Even if you’ve only ever created a 
single database, you still have two inboxes, because the global Inbox is 
always present. This fact can be either a blessing or a curse, depending 
on your point of view. 

Your global Inbox appears at the top of the sidebar under Globals, 
which means that if your sidebar is hidden, you can’t access it. (Choose 
View > Navigate, click the Sidebar icon on the toolbar, or press ⌘-
Option-1 to display the sidebar.) 

Note: It’s all too easy to throw a bunch of documents into your inbox 
and forget about them, but DEVONthink works better when docu-
ments are in groups. It’s also best to move items from your global 
Inbox into specific databases on a regular basis. You can learn about 
these tasks in the sidebar Stepping Stone: Get Stuff Out of Your 
Inbox(es). 

So, when you import a new document, where does it go—the global 
Inbox or the one for a particular database? It depends primarily on 
your preferences, as I discuss later in Decide Where Your Documents 
Will Go. 
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DEVONthink in Other Applications 
DEVONthink can change what you see in other applications by adding 
menu commands and other interface elements. A few examples: 

✦ New Services menu commands (see Use the Services Menu) 

✦ The Inbox that may appear in the sidebar of Finder windows and 
in Save dialogs (see Use the System-Wide Global Inbox) 

✦ Extensions for Safari, Chrome, and Firefox (see Clip to DEVON-
think Browser Extension), and browser bookmarklets (see Web 
Bookmarklets) 

✦ New commands in Apple Mail (see Use the Mail Plugin) 

Workspaces 

Workspaces let you save arrangements of open databases, windows, 
documents, and tabs—plus the currently visible inspector, any selected 
sidebar filter, view selections, and advanced search options—and recall 
them instantly. If you rearrange items on your screen (or switch to a 
different workspace), you can return the display to its previous state 
with a single menu command. 

Here’s what you can do with workspaces: 

• Create a workspace: Choose Go > Workspaces > Add. Enter a 
name for your workspace and click OK. 

• Restore an existing workspace: Choose Go > Workspaces > 
Name of Workspace. You can also press ⌘-Option-number, where 
the number corresponds to the order in which workspaces are listed 
at the bottom of the Go menu. 

• Modify a workspace: To update an existing workspace to reflect 
the current arrangement of on-screen elements, choose Go >Work-
spaces > Update “Name of Workspace”. 
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• Edit a workspace: To edit a workspace’s name or order in the Go 
menu, or to delete it, choose Go > Workspaces > Edit. Then: 

‣ To rename a workspace, double-click its name, enter a new 
name, and press Return. 

‣ To rearrange workspaces, click and drag. 

‣ To delete a workspace, select it and click the minus button. 
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Set Up DEVONthink 
Databases 

Now that you know your way around DEVONthink, it’s time to create 
one or more databases and start collecting information. You can set up 
a database with just a few clicks, but you may also want to customize 
(and even password-protect) your database. 

Create a New Database 

I mentioned earlier that you can use DEVONthink without explicitly 
creating a database, because the global Inbox functions (to a limited 
extent) as a built-in database. However, to use all of DEVONthink’s 
features effectively, you’ll want to create at least one database. (Later 
on, if the need arises, you can create more databases and copy or move 
items from one database to another.) 

To create a database: 

1. Decide whether you want your database to be encrypted. (See the 
sidebar Encrypting a Database, ahead, for guidance.) 

2. Choose File > New Encrypted Database (for an encrypted database) 
or File > New Database (for an unencrypted database). A file dialog 
appears. 

3. Enter a name for your database and choose a location (or accept the 
default location, which is now ~/Databases). Note that DEVONthink 
expressly prevents you from storing your database in any cloud-
synced location, such as Dropbox or iCloud Drive (including the 
Desktop and Documents folders, if you sync those via iCloud), 
because such locations aren’t safe to use with databases. You can, 
however, sync your databases via Dropbox or iCloud Drive; see Sync 
DEVONthink Databases. 
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4. If you’re encrypting your database, enter and verify a password, and 
choose a maximum size for your database—the largest size to which 
DEVONthink will permit it to grow. 

5. If you want to keep the information in your DEVONthink database 
from being indexed by Spotlight, uncheck Create Spotlight Index. 
Doing so doesn’t prevent you from searching within DEVONthink, 
but it does prevent the contents of the database from appearing in 
system-wide Spotlight searches. (You might deselect this option if 
you’re encrypting your database and you want to ensure that no one 
with access to your Mac could search its contents, even though 
they’d be unable to open the resulting documents.) 

6. Click Create. 

DEVONthink creates a new, empty database. 

Encrypting a Database 
If you need to keep the contents of a database private, you can ask 
DEVONthink to encrypt it using AES-256 encryption. With this option 
enabled, the database can’t be opened without the password you 
specify, and as long as it’s closed, your data is safe from unautho-
rized parties. However, once you’ve opened an unlocked the data-
base, anyone with access to your Mac can see its contents. 

Encrypting a DEVONthink database makes the most sense when it 
contains sensitive data and your Mac is in an environment where 
other people can access it. If you’re the only person who uses your 
Mac—and especially if you already have FileVault enabled—using 
DEVONthink’s encryption adds little in the way of security, while 
requiring you to enter a password every time you open the database. 

Although DEVONthink doesn’t permit you to convert a database from 
encrypted to unencrypted (or vice versa), you can achieve essentially 
the same results by creating a new database of the desired type, 
dragging all your data from the old database to the new one, and 
then deleting the first database. 
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How Many Databases Do You Need? 
DEVONthink lets you create as many databases as you want, and 
have any or all of them open at the same time. But how many 
databases do you need? There’s no single right answer—it’s up to 
you—but you may want to consider these factors: 

✦ Searching: When you use the search field at the top of the main 
DEVONthink window, it uses the most recently used search scope 
by default (if possible); otherwise, it searches the currently select-
ed database. To change the default search scope, go to Settings/ 
Preferences > General > General and choose the scope you want 
from the Search Scope pop-up menu. You can also change the 
scope of the in-progress search, but only after you’ve started your 
search. 

✦ Sharing: When sharing your data using the built-in web server in 
DEVONthink Server (see Use DEVONthink’s Web Server), you can 
enable or disable sharing for any database, but you can’t control 
access on a lower (e.g., group) level. So if you want to share just 
a portion of your data, put that portion in its own database. 

✦ Organization: You can create smart groups, replicants, and so on 
within a database but not across databases. So if there’s a set of 
data that is completely self-contained, that might go in a separate 
database, whereas any data you want to intermingle with other 
data should be collected together in a single database. 

If you’re using DEVONthink as an all-purpose snippet keeper, note 
taker, and organizational tool, it usually makes sense to keep every-
thing in a single database. On the other hand, if your work involves 
distinct projects that don’t interact with each other, the best course is 
to use a separate database for each one. 

Either way, remember that you can later split a database in two, or 
combine two databases into one (for example, by dragging groups 
from one database to another) if your needs change. Also keep in 
mind that if your database reaches many gigabytes in size, as can 
happen if you use it to store thousands of scanned documents, 
performance may suffer. In that case, dividing your data into some-
what smaller units can help. 
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Configure Database Properties 

In most cases, DEVONthink’s default options for each database are 
adequate. However, you can tweak a few database-wide settings that 
may be of interest. To see these settings, select a database (or anything 
in a database) in the sidebar and choose File > Database Properties. 

The Database Properties popover (Figure 30) appears. The lower 
portion of this popover contains statistics—the number of items of 
different sorts that appear in your database. 

Figure 30: Set database properties in this popover. 
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The top half of the popover shows your database’s location, and has 
controls for adjusting these database characteristics: 

• Create Spotlight Index: DEVONthink always indexes your 
database internally. But if this box is checked (as it is by default), 
DEVONthink makes the database contents available in your system-
wide Spotlight index too. 

• Rebuild: To rebuild the database’s Spotlight index (not the data-
base itself), click Rebuild. This may be necessary if searches fail to 
return obvious document matches. 

• Name: To rename your database, type a new name here. This 
changes the name as it appears in DEVONthink, as well as the file 
as it appears in the Finder. 

• Comment: Enter any descriptive notes about the database as a 
whole here; when exporting files, these comments are used as the 
Finder’s Spotlight Comments. 

• Exclude Groups from Tagging: When this checkbox is selected 
(as it is by default for new databases), groups and tags are indepen-
dent from each other in that database. This means, for example, 
that group names won’t appear as auto-complete choices when you 
enter tags, though DEVONthink does not prevent you from manual-
ly creating a new tag with the same name as a group. 

When this checkbox is deselected, all group names automatically 
function as tags too, unless you have explicitly excluded a particular 
group from being used as a tag (by selecting the group, going to the 
Info inspector, and checking Tagging in the “Exclude from” 
section). Groups that can be used as tags (which DEVONthink calls 
group tags) have icons that look like a stack of tags , while groups 
that are excluded from tagging have icons that look like a stack of 
rectangles . 

If you like to use both groups and tags, leaving this checkbox select-
ed is a good idea, as it prevents confusion that can arise from having 
both a group and a tag with the same name. 
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• Inherit Tags of Groups: When this is selected, any tags applied 
to a group are also applied to children (sub-groups) of that group. 

• Case Insensitive Tagging: When this is deselected, you can have 
multiple tags that differ only in capitalization (like recipes and 
Recipes) but are nevertheless treated differently. When this is 
selected, DEVONthink prevents you from having tags that vary only 
in capitalization. 

• User and Password: To require a username and password when 
syncing a database, click the padlock icon so it changes to un-
locked. Enter a username and password in the fields provided and 
click the padlock icon again to lock it. (To remove password 
protection, repeat the procedure but leave the Password field 
blank.) But note that this is weak protection that affects only sync-
ing, and is independent of whether you’ve encrypted the database. 

Tip: You can also change the icon of your database in this popover, 
just as you would in a Finder Get Info window. 

How and Where Databases Are Stored 
DEVONthink stores all its data in a container it refers to as a “data-
base.” The database isn’t a single file, however, but rather a whole 
bunch of files. Some of them contain settings, metadata, and other 
information about the arrangement and attributes of your documents. 
The documents themselves are also stored, each as a separate file, 
in a series of folders inside the database (though their organization 
will be largely inscrutable to the casual observer). 

DEVONthink stores its databases, by default, in your ~/Databases 
folder. Each unencrypted database is stored in a package (sometimes 
called a bundle), a folder with a special setting that makes it look and 
act like a single file in the Finder, while encrypted databases are 
stored in special disk images. A DEVONthink database has the name 
of your database followed by the extension .dtBase2 for unencrypted 
databases, or .dtSparse for encrypted databases. 

Your global Inbox, meanwhile, is a separate database, stored in 
~/Library/Application Support/DEVONthink 3. 
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Get Information into 
DEVONthink 

Whether you’re starting from scratch with newly created data or 
importing content from existing files or Internet sources, DEVONthink 
offers many mechanisms for collecting information. In fact, the biggest 
problem you may have is deciding which method you should use to put 
a particular piece of information into your database. 

In this chapter, I begin by discussing what you can put in DEVONthink 
and helping you figure out where you want DEVONthink to place 
newly added content by default. With this important decision out of 
the way, I then explain the major ways of adding data. I finish with 
Joe’s Recommendations for Getting Stuff into DEVONthink, a topic 
aimed at helping you come to grips with all the choices. 

What Can I Put in DEVONthink? 

In case you’re wondering what kinds of documents you can put in 
DEVONthink, the answer is any kind at all! DEVONthink can index 
anything containing text, and it can display nearly any kind of text or 
graphics file, most audio and video files, and even documents from 
Microsoft Office and Apple’s Pages, Numbers, and Keynote apps. 

Even if you import a document that DEVONthink can’t display, the 
document can stay in the database, and you can open it using another 
app (see Edit Documents in External Apps). 

Decide Where Your Documents Will Go 

As you use DEVONthink, you can put each document in a specific 
group, in a catch-all inbox—perhaps in any of several databases—or 
in the global Inbox. For the most part, you get to choose where docu-
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ments go, although there are cases in which you may not have realized 
what your choice was, so the result may be confusing if you’re not 
familiar with DEVONthink’s system. 

The general rule (to which there are a few exceptions) is that docu-
ments go in either of two places: 

• Where you put them 

• A default destination, which you can choose (within limits) 

When you create a new document from within DEVONthink—and that 
includes importing or indexing documents using the File > Import or 
File > Index Files and Folders command—it goes in the currently 
selected group, if any; if a tag is selected, or if no group is selected, it 
goes to the inbox of the selected database. In other words, documents 
created from within DEVONthink are always in the “where you put 
them” category. 

Likewise, if you drag a document, text clipping, email message, or 
anything else from the Finder or another app into the DEVONthink 
window, it goes where you drop it—into a particular group, an inbox, 
or the top level of the database, as the case may be. Once again: it goes 
where you put it. 

However, if you start from outside DEVONthink—for example, when 
scanning a paper document, dropping a file on DEVONthink’s Dock 
icon, using the Services menu (see Use the Services Menu), or using 
a bookmarklet (see Web Bookmarklets)—the imported document goes 
to your default destination for importing data. 

To choose your default destination, go to Settings/Preferences > 
Import and set the Destination preference to one of these: 

• Global Inbox: Everything you import or index goes straight to the 
global Inbox, no questions asked. This is the default. 

• Select Group: If you select this radio button, the next time you 
import or index something starting from outside DEVONthink, a 
special panel appears (Figure 31), allowing you to select the loca-
tion of your choice (and optionally add tags). You can also click New 
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Group to create a new group and put the document there; if you’re 
unsure where to put it, select your global Inbox or a database-
specific inbox. 

Figure 31: This panel appears when Select Group is your default 
destination and you add something from outside the app. 

Which of these options you choose depends on whether you prefer to 
organize as you go or sort later, as I discuss in the sidebar Stepping 
Stone: Sort Now or Sort Later?, just ahead. 
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Stepping Stone: Sort Now or Sort Later? 
There are varying schools of thought about how and when to go 
about organizing one’s data. But assuming you’ve gotten over the 
initial hump of organizing a modest set of documents, the ongoing 
question remains as to how you deal with the new documents you 
add to DEVONthink. 

There are two basic approaches: 

✦ Sort now: Set your default Destination to Select Group, and sort 
every item as you import it. The advantage is that DEVONthink’s 
inboxes won’t get cluttered, and you’ll never have to confront 
hundreds or thousands of documents in need of a proper destina-
tion. In addition, you’ll be able to find things faster (even without 
searching), and Classify will work better. But the downside is that 
the Groups panel will keep popping up, interrupting your work— 
and if you end up dealing with this by selecting Inbox every time, 
you might as well change your preferred destination to the global 
Inbox. 

✦ Sort later: A more Zen-like approach is to toss everything into 
your inbox (global or otherwise) and not worry about it. After all, 
DEVONthink has excellent search capabilities, not to mention the 
Group Similar Items and Classify commands, which can help you 
sort a large backlog of documents in a hurry. This approach isn’t 
for neat freaks, as it requires a certain tolerance for messiness 
and ambiguity, and a willingness to search for almost everything 
you need. 

Having tried both, my personal feeling is that the interruption of the 
Groups panel is more irritating than inbox clutter, so I tend to sort 
later. However, I’m disciplined enough to do (computer-assisted) 
manual sorting once or twice a week, so it goes quickly—and my 
Inbox never accumulates too many documents. 
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Stepping Stone: Finding a Way to Get Your Stuff into 
DEVONthink 
No matter what app you’re using or what sort of data you’re looking 
at, there’s probably a way—and maybe a dozen ways—to add it to 
DEVONthink. I’m about to show you quite a few of those ways, but 
you may find it helpful to think of them as falling into three broad 
categories. 

✦ Start in DEVONthink: You can create several kinds of documents 
without ever leaving DEVONthink (see “Create Documents in 
DEVONthink,” just ahead); you can also ask DEVONthink to grab 
files stored elsewhere on your Mac (see Use the Import or Index 
Command). You can even Use the Built-in Web Browser and Read 
RSS Feeds. 

✦ Start in another app: Whether it’s a file in the Finder, a text 
selection in a word processor, a page in a web browser, or a mes-
sage in Mail, you can add info from just about any other app to 
DEVONthink (in some cases, even if DEVONthink isn’t running). 
See Use Drag and Drop, Use the System-Wide Global Inbox, Use 
the Services Menu, Use the Sorter, Web Bookmarklets, Add Email 
Messages, and Use the PDF Menu. 

✦ Start with your scanner: You may be able to touch a button 
on your scanner to scan a document and import it directly into 
DEVONthink (see Scan Documents, which also discusses other 
ways of getting scans into your database). 

Don’t feel you have to memorize all these options—just read the rest 
of this chapter to get a sense of what’s possible, and as you do, jot 
down the two or three options you’re most likely to use. And be sure 
to read Joe’s Recommendations for Getting Stuff into DEVONthink, at 
the end of this chapter, where I wrap it all up. 

Create Documents in DEVONthink 

Many people use DEVONthink primarily as a place to store documents 
that originated elsewhere, but you can also generate many types of 
documents without leaving the app. If you’re using DEVONthink to 
take notes, perform research on the web, or brainstorm ideas for your 
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next novel, it’s more efficient to create your documents within 
DEVONthink than to create them elsewhere and import them. 

To create a new document, choose a command on the Data > New 
submenu or the Data > New from Template submenu. (Some of these 
commands also have toolbar icons, keyboard shortcuts, or both.) Many 
options are available, and I encourage you to explore them if you have 
time. What follows are the document types you can create in DEVON-
think. 

Note: When you create a new document, you can edit it right in the 
view/edit pane of the main window; or, assuming default prefer-
ences, double-click the document to open it in a separate window. 
(If, in Settings/Preferences > General > Interface, you select 
“Double-click opens documents externally,” double-clicking opens the 
document in another app, but you can still open it in a DEVONthink 
window by selecting it and choosing Data > Open or pressing ⌘-O.) 

With Clipboard 
To make a new document in the current (or default) location with the 
contents of the clipboard, choose Data > New > With Clipboard (⌘-N). 
If the clipboard contains styled text, the note will be in Rich Text 
format; if it’s unstyled text, it will be in plain text format; and if it’s a 
graphic, it will be stored as a TIFF image. 

Plain Text 
To create a plain text document, choose Data > New > Plain Text (⌘-
Control-Option-N). This is what I normally use for notes that don’t 
specifically need styles, which is most of them—I find the consistency 
of a single font and size more pleasing to my eyes. You can, however, 
make a copy of a plain text document in Rich Text format by choosing 
Data > Convert > To Rich Text. 

Rich Text 
Rich text, in DEVONthink’s usage, means text that can contain a 
variety of fonts, sizes, styles, and colors, as well as graphics and links; 
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rich text documents are stored on disk as .rtf (Rich Text Format) 
or .rtfd (Rich Text with attachments) files. To create a rich text docu-
ment, choose Data > New > Rich Text (⌘-Control-N). You’ll find the 
formatting controls on the Format menu or its submenus. 

Formatted Note 
A formatted note, like a rich text document, can contain styled text, 
graphics, and links. Although the range of formatting options is some-
what smaller than what rich text offers (for example, tables and num-
bered or bulleted lists aren’t supported), the advantage of this format 
is that DEVONthink saves the document in HTML format. (In fact, it’s 
a special, self-contained HTML document that has all graphics embed-
ded within it.) This means you can drag the document to any web 
browser to view it (or drag it to the Finder and then post it on a web 
server), no exporting required. To create a formatted note, choose 
Data > New > Formatted Note. 

Markdown Text 
If you like to write using Markdown formatting (or with the Multi-
Markdown variant), you can do so in DEVONthink and switch between 
the Markdown code (text-only mode) and the rendered page (preview 
mode). To create a new Markdown document, choose Data > New > 
Markdown Text. The document is initially in text-only mode so you 
can type your text and Markdown code; click the Preview icon on 
the editing bar or choose View > Document Display > Preview (⌘-
Control-P) to view the final, rendered product. You can also view the 
Markdown source and the rendered result at the same time (provided 
your screen is wide enough) by clicking the Side-by-Side icon or 
choosing View > Document Display > Side-by-Side (⌘-Control-Y). 

Note: For more information on working with Markdown (and HTML) 
documents in DEVONthink, see Edit HTML and Markdown Documents. 
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HTML Page 
An HTML page is just that—a page composed of HTML. That may 
sound just like a formatted note, but they’re different. DEVONthink 
always displays and edits formatted notes in WYSIWYG mode. Howev-
er, HTML pages are rendered (that is, shown in uneditable preview 
mode) by default; if you switch to source mode by clicking the Source 

icon on the editing bar or choosing View > Document Display > 
Source (⌘-Control-X), you can then see and edit the underlying HTML 
source (just as you can with Markdown documents). Similarly, click 
the Side-by-Side icon to show the HTML source and the rendered 
page simultaneously. To create a new HTML page, choose Data > 
New > HTML Page. 

Sheet 
DEVONthink uses the term sheet to mean a document containing 
tabular data (a grid of columns and rows). DEVONthink’s sheets have 
a great deal of flexibility, with 13 different data types (including single- 
and multi-line plain text, rich text, dates, and numbers), many with a 
variety of formatting options. 

To create a sheet: 

1. Choose Data > New > Sheet. 

2. In the dialog that appears (Figure 32), type a name for your first 
column and press Return. 

Figure 32: Add columns to a new sheet in this dialog. 
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3. Choose a data type for this column from the Type pop-up menu. In 
some cases, you’ll need to specify additional characteristics—for 
example, numbers and dates can have different formats, and the Set 
option lets you specify a list of choices for each field in that column 
(which appear as their own pop-up menu). 

4. To add another column, click the plus button and repeat step 3. 
Continue for as many columns as you want your table to have. (You 
can always add more later.) Then click OK. 

The newly created sheet (Figure 33) is initially empty, with a single 
blank row. You can begin typing immediately to fill in data. To add a 
new record (row), choose Tools > Sheets > New Record, or click the 
New Record icon on the editing bar. To add or remove columns or 
rows, use the other (self-explanatory) commands on the Tools > Sheets 
menu or the corresponding editing bar icons. 

Figure 33: A new sheet with just one blank record added. 

If you want to add, change, remove, or rearrange columns, you can 
view the dialog from step 2 again by choosing Tools > Sheets > Edit 
Columns or clicking the Edit Columns icon on the editing bar. 

Note: Unlike spreadsheets, DEVONthink’s sheets offer no formulas or 
calculations—they’re really just tables. However, DEVONthink does 
include a few AppleScripts on the Script > Sheets submenu that 
can perform calculations in sheets, such as computing the sum and 
mean of a row or column. 
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DEVONthink Pro and Server offer another way to view and interact 
with sheets: form view, which shows a single record in a form-like 
layout (Figure 34), which you may find friendlier and more conve-
nient for data entry. To switch to form view, choose View > Document 
Display > Form View or press ⌘-Control-X. (To switch back to table 
view, choose View > Document Display > Table View or press ⌘-
Control-P.) 

Figure 34: This is the same sheet as in the previous example, but 
shown in form view. 

Note that the order of the form items from top to bottom matches the 
order of columns in the table view (and changes if you rearrange those 
columns). You can’t otherwise customize the form view. 

Template 
When you create a new document, you need not always start with a 
blank slate. Instead, you can use a template to create a document that 
already contains boilerplate text, variables, and other custom attribut-
es. The Data > New from Template submenu contains several lower-
level submenus full of additional commands, all of which can be used 
to create new types of data (of one sort or another) in your database. 

Tip: You can add even more templates by choosing Data > New from 
Template > More Templates and clicking the Install button under-
neath any template that interests you. 

To oversimplify slightly, a template is an ordinary document that 
optionally includes one or more special codes called template place-
holders that result in the insertion of variables such as the current date 
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and time or a link to a selected document (see the sidebar Using 
Placeholders, ahead). When you create a document from a template, 
you’re essentially making a copy of that prebuilt document and allow-
ing DEVONthink to fill in the placeholders with the currently applica-
ble data. 

For example, if you choose Data > New from Template > Productivi-
ty > Phone Note, DEVONthink displays a window like the one in 
Figure 35. Notice that in addition to the boilerplate text, it has the 
date and time it was created and fields to fill in other details. All these 
were provided by variable codes in the template file. 

Figure 35: A new phone note has the date and time prefilled. 

To edit an existing template: 

1. Choose Data > New from Template > Open Templates Folder to 
open the folder in ~/Library/Application Support/DEVONthink 3/ 
Templates.noindex in the Finder. 

2. Locate the template (with an extension of .dtTemplate) in that folder 
or one of its subfolders. Optional but recommended: Make a copy of 
the template and give it a new name, in order to keep the original 
intact. 

3. Right-click (or Control-click) the template or copy, and choose 
Show Package Contents from the contextual menu. 
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4. In the folder corresponding to your language (for example, Eng‐
lish.lproj), you’ll see a .rtf file with the template’s name. Double-
click that file to open it in TextEdit (or whatever app you’ve config-
ured as the default for editing .rtf files). Then you can edit it just as 
any other document (see Figure 36). 

Figure 36: The template from the previous figure, open for editing 
as an RTF document in TextEdit. Notice the %date% and %time% 
placeholders. 

5. When you’re finished, save and close the document. 

Note that a handful of templates DEVONthink includes don’t have 
a .dtTemplate extension but rather a .templatescriptd extension. These 
are smart templates, which use AppleScript rather than simple place-
holders and are considerably more powerful. I say more about smart 
templates in Use Smart Templates, later in this book. 

Tip: You can create your own template by making a new document in 
DEVONthink and choosing Export > as Template, or by saving docu-
ments in the application of your choice and dragging them to the 
~/Library/Application Support/DEVONthink 3/Templates.noindex 
folder or one of its subfolders. You can also edit the existing tem-
plates, or remove them, as you prefer. 

Templates are useful and flexible, and I could spend quite a few pages 
talking about them—but there are other pressing matters at hand! So 
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try some of the existing templates to get a feel for what’s included with 
the app, and make your own if you feel the urge. 

Using Placeholders 
DEVONthink uses special variables called placeholders to represent 
spots in templates (and other contexts) where information should be 
filled in dynamically. For example, in Figure 36 above, the place-
holders %date% and %time% are replaced with the current date and 
time, respectively, when you create a new document from this 
template. DEVONthink supports over 20 template placeholders, all of 
which take the form of a word surrounded by percent (%) symbols. 
See the topic “Template Placeholders” on the “Smart Templates” 
page of the DEVONthink documentation for details. 

However, templates aren’t the only place where DEVONthink uses 
placeholders. In other locations, a much longer list of placeholders is 
available, and they’re represented as little blue tokens rather than as 
text strings. The other spots where you can use placeholders are: 

✦ Imprints: In the Pro and Server editions of DEVONthink, place-
holders can be used in PDF imprints to do things like adding page 
numbers, headers, and footers. See Add Imprints. 

✦ Smart rules and batch processing: Smart rules perform prede-
fined actions on documents when certain trigger conditions occur; 
these actions can include various kinds of placeholders. See Work 
with Smart Rules. 

✦ WikiLinks: The template used for new WikiLinks documents can 
include placeholders. See Work with Item Links and WikiLinks. 

To see what placeholders are available in these other contexts and 
insert them, right-click (or Control-click) and explore the Insert 
Placeholder submenu of the contextual menu. The DEVONthink 
documentation has more details in the “Placeholders” topic. 

Use the Import or Index Command 

For adding individual documents, the methods described later in this 
chapter (using drag and drop, the Services menu, the Sorter, and so 
on) make the most sense. But if you want to suck in hundreds or 
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thousands of documents at once, a more logical approach may be to 
use DEVONthink’s Import or Index command. (Flip back to Importing 
vs. Indexing if you need a refresher on these options.) 

Import 
To import files and folders, do the following: 

1. Choose File > Import > Files and Folders. 

2. Navigate to the location where the items are stored. 

3. Select one or more files or folders (⌘-click to select more than one 
item), and click Open. 

DEVONthink imports the items, putting them in the location you 
specified in your preferences. 

Note: There are several other commands on the File > Import 
submenu, designed for handling specific kinds of data or importing 
from other apps (such as Evernote and Yojimbo). I discuss some of 
these commands elsewhere in this book. 

Index 
To have DEVONthink index files and folders (without copying their 
contents into its database), do the following: 

1. Choose File > Index Files and Folders. 

2. Navigate to the location where the items are stored. 

3. Select one or more files or folders (⌘-click to select more than one 
item), and click Open. 

DEVONthink indexes the items, putting references to them in the 
location specified in your preferences. Items that are indexed rather 
than physically stored in your database appear with a tiny Finder 
icon to the right of their filenames. 

If you later decide that you want a given indexed document to be 
imported instead, select it and choose Move Into Database from the 
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Actions pop-up menu on the toolbar, or right-click (or Control-
click) it and choose Move Into Database from the contextual menu. 

Use Drag and Drop 

The method I use most often to get information into DEVONthink is 
good old-fashioned drag and drop. You can drag almost anything to 
DEVONthink—one or more files or folders, selected text or graphics in 
most applications, the URL from a browser’s address bar, and so on. 
(For the most part, if you can drag it, you can drag it to DEVONthink.) 

However, when I say, “drag to DEVONthink,” that could mean several 
different things, any of which you may want to use from time to time: 

• Dock icon: Drag something to DEVONthink’s Dock icon to import 
it to your default location. 

• A group or tag: Drag something to any group or tag in a visible 
DEVONthink window to add it to that group or apply that tag. Keep 
in mind that if you drag something from outside DEVONthink to an 
ordinary tag (not a group tag), the item will be stored in the data-
base’s inbox. 

• The DEVONthink window: You can drag items directly into the 
main DEVONthink window—for example, drop items on any inbox, 
database, group, or tag in the sidebar or in any view. When you drag 
something into the DEVONthink window and your pointer is over 
a valid target area, that portion of the window is outlined in blue 
and your pointer acquires a green plus badge. 

• The Sorter: DEVONthink has an optional window called the 
Sorter that can take the form of a menu extra on your main menu 
bar or a slide-out panel with an onscreen control called a docked 
tab. When the Sorter is visible, you can drag items onto any data-
base, group, or tag in it. See Use the Sorter for details. 

When you drag a file to DEVONthink in any of these ways, DEVON-
think ordinarily imports the file—that is, it copies it into its database 
and doesn’t delete the original. If you want to import it and move the 
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original to the Trash, hold down ⌘ while dragging it. Or, if you prefer 
to index a file—without making a copy of it—hold down ⌘ and Option 
while dragging it. (That’s the same shortcut used to make an alias in 
the Finder, which is roughly analogous to what you do when you index 
a file in DEVONthink.) 

Import, OCR, and Delete 
It’s also possible to automatically import a file, perform OCR on it, 
and delete the original—all in a single step! The easiest of several 
ways to do this uses a smart rule (see Work with Smart Rules for 
details). 

To set this up, start by indexing the folder in the Finder where you’ll 
put documents you want to perform OCR on, and create a destination 
group for the final product within DEVONthink. Then set up a smart 
rule as shown in Figure 37. 

Figure 37: This smart rule runs OCR on anything you drag into the 
indexed folder, then moves that item into your database. 

Now, when you drag a file into that folder, the smart rule runs: 
DEVONthink performs OCR on the document, moves the document 
into your database (thus deleting the original from the folder in the 
Finder), and then moves it into the destination group you specified. 
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Use the System-Wide Global Inbox 

Because DEVONthink supports multiple databases, it also offers a 
global Inbox where you can store items without having to decide 
immediately which database to put them in (see Inboxes for more 
details). This global Inbox is basically a special, always-open database 
that appears in DEVONthink’s sidebar. However, you can also make it 
available in the Finder and in any app’s Save dialogs; in this context, I 
refer to it as the system-wide global Inbox—in other words, a system-
wide shortcut to the global Inbox. 

The system-wide global Inbox isn’t installed automatically. If you 
didn’t opt to install it when you first ran DEVONthink, choose 
DEVONthink 3 > Install Add-ons, check Global Inbox in Save Dialogs, 
and click Install. Thereafter, you should see an Inbox icon in the 
sidebar of Finder windows under Favorites (Figure 38). If you prefer, 
you can drag it to a different location within the Favorites group. 

Figure 38: Your system-wide global Inbox (shown here circled in 
red) appears in the sidebar in your Finder windows. 
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Warning! Don’t rename the Inbox shortcut in the Finder, as that will 
break a bunch of things in DEVONthink. 

To add a file or folder to your DEVONthink database from the Finder, 
simply drag it to this convenient icon. 

However, dragging files to the system-wide global Inbox icon works 
much differently from what you may expect if you’re used to dragging 
files to DEVONthink in any other way. Specifically: 

• When you drag something to the system-wide global Inbox, you 
move that file or folder to DEVONthink rather than just copying it; 
the original disappears. (To force a copy instead, hold down Option 
as you drag; to force an index rather than an import, hold down ⌘ 
and Option.) 

• Dragging to the system-wide global Inbox icon always puts the 
item(s) in DEVONthink’s global Inbox, regardless of your prefer-
ences for how imports are usually handled. Items dragged to this 
icon never prompt you to select a group. 

• If DEVONthink is running, the system-wide global Inbox icon 
essentially functions as a one-way drop box—it always appears 
empty, because it sends everything you put in it directly into your 
global Inbox. If DEVONthink isn’t running, it acts as a regular 
folder; you can drag things out of it later if you wish. 

Now, this different behavior may, in fact, be exactly what you prefer. 
For example, if you like to put documents into DEVONthink and then 
delete the originals, simply dragging them to the system-wide global 
Inbox saves you the extra step of deleting. But just be sure you know 
what you’re getting yourself into. 

The system-wide global Inbox also appears in the sidebar of every 
application’s standard Save dialog (Figure 39). 
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Figure 39: The system-wide global Inbox (shown here circled in 
red) appears in the sidebar of Save dialogs. 

When saving a file from your favorite word processor, graphics editor, 
or other app, you can select that icon in the sidebar as the destination 
and thereby save it directly into your DEVONthink global Inbox! If 
you create a lot of documents in other apps that you want to store in 
DEVONthink, this saves you numerous steps. But, beware: the files 
you save in this way won’t show up in the Finder; the only place you’ll 
see them is in DEVONthink’s global Inbox. So that should be the first 
place you look if you’re missing a file that you’re sure you saved. 

Tip: The global Inbox isn’t much good if documents stay in it forever. 
For help dealing with all the items that accumulate there, see the 
sidebar Stepping Stone: Get Stuff Out of Your Inbox(es). 

Use the Services Menu 

One of the Mac’s best-kept secrets is a mechanism called Services, 
which lets an app share some of its capabilities with other applications. 
Using services, you can take advantage of a handful of DEVONthink 
features even when you’re working in other apps. Specifically, services 
provide yet another way to get information into DEVONthink (along 
with a couple of other cool capabilities). 

91 



            
            

             
               

             
             

            
       

           
            

      

      
      

           
     

          
     

Services appear in several places. One is the Services submenu of the 
application menu (that is, the menu bearing the name of the current 
application—e.g., the Mail menu if you’re in Mail). Select a file in the 
Finder, or text in Safari, say, and go to this menu to see what services 
apply to whatever it is you’ve selected. You can also find services listed 
at the bottom of the Actions pop-up menu on the toolbar of 
Finder windows and at the bottom of the contextual menu that appears 
when you select something and right-click (or Control-click). 

In addition, some services have keyboard shortcuts (as shown on the 
Application > Services submenu and in Figure 40), and you can add 
your own shortcuts (as I describe shortly). 

Figure 40: DEVONthink adds a bunch of commands to the system-
wide Services menu. Those that apply to selected text appear here. 

DEVONthink can add up to 12 commands to the various Services 
menus; all are prefixed with “DEVONthink 3”: 

• Add to DEVONthink 3: Imports the selected items (for example, 
in the Finder) to DEVONthink’s default destination. 
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• Add to Reading List: Applicable only to web URLs; adds the 
destination page to DEVONthink’s Reading List. 

• Capture Bookmark: Applicable only to web URLs; adds the URL 
to DEVONthink as a bookmark. 

• Capture Web Archive: Applicable only to webpages; stores the 
current page in DEVONthink as a web archive. 

• Take Plain Note, Take Rich Note, Take Formatted Note, 
and Create Markdown Document: Creates new documents in 
the selected format from the current text selection. (See Create 
Documents in DEVONthink for the distinctions among these for-
mats.) 

• Append Plain Note and Append Rich Note: Adds the selected 
text to the note most recently taken via a DEVONthink service. 

• Lookup: Opens a new search window in DEVONthink, with the 
selected text filled in. 

• Summarize: Creates a new note containing a summary of the 
selected text. 

You can turn each service on or off individually, and customize its 
keyboard shortcut, as you prefer: 

1. Go to System Preferences > Keyboard > Shortcuts > Services. 

2. In the list on the right, navigate to the service you want to enable 
or disable, and check (or uncheck) its box. All of DEVONthink’s 
services start with “DEVONthink 3,” but they’re found under vari-
ous headings—Add to DEVONthink 3 is found under “Pictures,” 
Capture Web Archive is found under “Files and Folders,” and the 
others are all located under “Text.” 

3. Optionally, to add (or change) a keyboard shortcut for a service, 
double-click the space to the right of the service name and press 
your desired key combination. 

The changes you make to services become available immediately. 

93 



       
        

  

             
             

             
           

         

            
           

           
           

   

               
            

           
              

   

Note: There’s also a mechanism called PDF Services that can be used 
to add documents to DEVONthink; see Use the PDF Menu, ahead. 

Use the Sorter 

Yet another way to add information to DEVONthink is to use a special 
panel called the Sorter. The sorter provides a way to add nearly any 
sort of content to the location of your choice in DEVONthink no matter 
what app you’re using or what’s on your screen—without switching to 
DEVONthink itself—as well as a way to search your open databases. 

The Sorter runs only when DEVONthink is open, and even then, only 
when you’ve enabled it. To turn on the sorter, go to Settings/ 
Preferences > Sorter and choose either Show as Menu Extra (the 
default) or Show as Dock Tab from the Appearance pop-up menu; to 
hide it, choose None. 

If you choose Show as Menu Extra, you’ll see a new menu in your main 
menu bar called DEVONthink (if Text is selected next to Menu Extra 
Title in the Sorter preference pane) or with the nautilus icon (if 
Icon is selected). In either case, click that item on the menu to show 
the Sorter (Figure 41). 
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Figure 41: The Sorter as it appears on the main menu bar. 

On the other hand, if you choose Show as Dock Tab, a translucent tab 
appears docked at the side of your screen; you can choose any of six 
locations for the docked tab by clicking a radio button on the Position 
display. Whichever spot you choose will display a gray tab that hovers 
over all other windows; when you click it, the Sorter slides out from 
that location (Figure 42). Click the tab again to hide the Sorter. 
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Figure 42: The Sorter as it appears when you click its docked tab. 

Once you’ve displayed the Sorter (in either way), you can use it to 
perform quite a few different DEVONthink actions: 

• Add something to DEVONthink: Drag a file, folder, or text 
selection to the Inbox or one of the group icons; or, if the Sorter is 
hidden, simply drag the item to the menu bar icon or tab itself, and 
when the Sorter slides open, drop the item onto your icon of choice. 

• Take a note: To type a quick note into DEVONthink, open the 
Sorter and click the Take Note icon, type your note (optionally 
with name, URL, tags, and other metadata, and in your choice of 
format), choose a location, and click Add. (You can assign a key-
board shortcut to the Take Note action by going to Settings/Prefer-
ences > Sorter and clicking the Take Note Hotkey button.) 

• Copy the selection: Similar to the Take Note feature (but without 
an icon in the Sorter) is the Copy Selection feature. Assign a key-
board shortcut to this action by choosing Settings/Preferences > 
Sorter and clicking the Copy Selection Hotkey field. Now, when you 
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make a selection in any document and press that key combination, 
the Sorter opens with the selected text prefilled in the Body field. 

Note: The first time you do this, you may see an accessibility warn-
ing. If so, click Open System Settings/System Preferences. In Ventu-
ra or later, turn on the DEVONthink 3 switch, authenticate when 
prompted, and close System Settings. In Monterey or earlier, click 
the lock icon and enter your password. Then select the DEVON-
think 3 checkbox and close System Preferences. 

• Record a voice or video note: To store an audio note or video 
note in DEVONthink, click the Voice Note icon or Video Note 

icon on the Sorter’s toolbar, respectively. Click the Record 
icon, pause for a second or so, and begin speaking. When you’re 
finished, click the Stop icon, fill in the desired metadata, and 
click Add. (To change which camera or microphone is being used, 
use the pop-up menu next to the Record icon.) 

Note: To record audio or video, DEVONthink must be permitted to 
access your computer’s microphone and/or camera. Go to System 
Preferences > Security & Privacy > Privacy > Microphone, and select 
DEVONthink in the list; select Camera in the list on the left and do 
the same. 

• Capture the screen: To capture the contents of the screen as a 
DEVONthink document, click the Screen Capture icon on the 
Sorter’s toolbar. Click Screen (⌘-1), Window (⌘-2), or Selection 
(⌘-3), as you prefer (optionally selecting “Include this window” to 
show the Sorter itself in the screenshot). If you select Window or 
Selection, next select the desired area and click the mouse button. 
Fill in the desired metadata and click Add. 

• Capture a web clip: To capture the contents of a webpage, click 
the Web Clip icon on the Sorter’s toolbar. Then click your default 
browser (to capture its frontmost tab or window), “URL on the 
clipboard” (to capture a URL you’ve previously copied), or “Enter 
manually” (to capture a URL you type in). Fill in the desired meta-
data and click Add. You can also assign a keyboard shortcut to 
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capturing a web clip using the Sorter; choose Settings/Preferences > 
Sorter and click the Clip to DEVONthink Hotkey button. 

Tip: Note that each web clip format also has its own keyboard short-
cut, as shown on the pop-up menu. 

Whichever format you choose, you can also optionally select the 
Clutter-Free checkbox (press ⌘-F to toggle it) to save the page in an 
uncluttered and nicely readable format—without ads and most 
other distractions. You can also optionally click Preview to see what 
the clip will look like in its reformatted state. 

Make the Sorter Tab Less Visible 
If you want to use the Sorter in docked tab mode but find that gray 
tab too distracting, you can increase its translucency to the point that 
it’s nearly invisible. To do this, go to Settings/Preferences > Sorter 
and uncheck Full (next to “Visibility”). Hover your pointer over the 
Sorter tab for a moment and move it away. From this point on, the 
tab then darkens only when you hover over it, and is just a faint 
image otherwise. 

Use the Share Extension 

Extensions give apps additional ways to talk to each other and ex-
change data. One type of extension, the Share extension, lets apps add 
commands to the Share pop-up menu (or, in some cases, a submenu 
of that menu) that appears in the Finder, most Apple apps, and a large 
number of third-party apps. By choosing a command from this menu, 
you can send the document, webpage, or other content you’re currently 
viewing to another app or web service. 

To add the DEVONthink Share extension to the Share pop-up menu 
in apps such as Safari and Notes: 

1. In Ventura or later, go to System Settings > Privacy & Security > 
Extensions > Sharing; or, in Monterey or earlier, go to System 
Preferences > Extensions > Share Menu as shown in Figure 43 (or, 
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alternatively, open an app that supports Share extensions, such as 
Safari, Preview, or Notes, click the Share icon on the toolbar, and 
choose More from the pop-up menu). 

Figure 43: Select this checkbox to include the Add to DEVONthink 3 
command on your Share menus. 

2. Select the Add to DEVONthink 3 checkbox. 

3. In Ventura or later, click Done and close System Settings; in Mon-
terey or earlier, close System Preferences. 

Once you’ve done this, Add to DEVONthink 3 appears on the Share 
menu in every app that includes one. To capture information into 
DEVONthink from that app, choose Share > Add to DEVONthink 
(keeping in mind that the command may be on a submenu). If the 
Sorter is enabled, a note appears with the selected information filled 
in; if the Sorter is disabled, a similar-looking Take Note window 
appears. Either way, fill in the desired information and click Add (in 
the Sorter) or Save (in the Take Note window). 
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Note: DEVONthink has its own Share pop-up menu; see Share 
Data. 

Add Web Content 

Although several other options discussed in this chapter work for web 
content, DEVONthink also provides two web-specific options for 
adding webpages to DEVONthink: 

• Clip to DEVONthink Browser Extension: This extension works in 
Safari, Chrome, and Firefox. Once installed, you can simply click the 
Clip to DEVONthink icon to add the entire webpage. You’ll be 
able to choose from variety of formats for storing the page, includ-
ing rich text, HTML, PDF, or only the bookmark. 

• Web Bookmarklets: This option may be right for you if you’re using 
a browser for which there’s no Clip to DEVONthink extension. But 
regardless of your browser, a bookmarklet may be the fastest way to 
add a webpage: there’s an individual bookmarklet for each format, 
so if you know what you want, adding a page to DEVONthink can be 
a one-click operation. (There is also a bookmarklet that works the 
same as the Clip to DEVONthink browser extension, allowing you to 
choose the format you want each time—but that takes more clicks.) 

Note: DEVONthink also has a built-in web browser and can act as an 
RSS reader; for more about those features, skip ahead to Use the 
Built-in Web Browser and Read RSS Feeds. 

Clip to DEVONthink Browser Extension 
When you install DEVONthink, it automatically adds a Clip to DE-
VONthink extension to Safari (though you still have to enable it in 
Safari by going to Safari > Settings/Preferences > Extensions and 
selecting the Clip to DEVONthink 3 checkbox). You can also optionally 
add the extension to Chrome or Firefox. To do so, choose DEVONthink 
3 > Install Add-ons; select one or both of Google Chrome Extension 
and Firefox Extension, and click Install. Then switch to the browser(s) 
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in question and follow the prompts to complete the installation 
process. 

To capture a page while you’re browsing, click the Clip to DEVONthink 
icon. If the Sorter is enabled, it appears; otherwise, the Clip to 

DEVONthink window (Figure 44) appears. Either way, you see the 
same options. 

Figure 44: When you use the Clip to DEVONthink browser extension 
or bookmarklet, you can add a note, enter tags, and choose a format 
here. 

You can then simply click Add (to accept all the defaults) or make 
changes first—everything is optional, including additions or changes to 
the Name and URL fields, comments, tags, and other metadata. (In 
most browsers, though not Safari 13, any selected text on the webpage 
is prefilled into the Comments field.) You can also choose a location 
from the Location pop-up menu at the bottom of the window. Of 
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special note, however, is the variety of formats you can choose from the 
Format pop-up menu (as we’ve seen elsewhere in DEVONthink): 

• Plain Text: Saves the entire page or the selected text as plain text. 

• Rich Text: Saves the entire page, including text styles, as rich text. 

• Bookmark: Saves only the page’s URL. 

• Formatted Note: Saves the document, including text styles, as a 
formatted note. 

• HTML Page: Saves the HTML source of the page (without 
graphics). 

• Markdown: Saves the entire page (even if you have text selected) 
as Markdown. This will produce only an approximation of the 
original formatting. 

• Web Archive: This choice, the default, saves the page’s entire 
contents (including any graphics) as a web archive, which lets you 
view it again in its current state even if you’re offline (or if its con-
tent changes later). 

• PDF (One Page): Saves the entire webpage as a (perhaps very 
long) single-page PDF. 

• PDF (Paginated): Saves the entire webpage as a PDF with page 
breaks. 

Tip: Keyboard shortcuts are available for each of these, as shown on 
the pop-up menu. 

Of these formats, I tend to go with PDF (One Page), which is more 
compact and universal than a web archive, and yet faithfully repro-
duces what the webpage looked like when I captured it. 

Whichever format you choose, you can also optionally select the 
Clutter-Free checkbox (press ⌘-F to toggle it) to save the page in an 
uncluttered and nicely readable format—without ads and most other 
distractions. You can also optionally click Preview to see what the clip 
will look like in its reformatted state before committing to it. 
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Once you’ve selected the location and format you want, and entered 
any tags or a note if you want them, click Add to save the page. 

Web Bookmarklets 
Another way to get web content into DEVONthink is bookmarklets— 
special strings of text that your browser sees as bookmarks, but which 
contain JavaScript code that let them perform interesting tasks. 

DEVONthink offers eight bookmarklets, each of which stores data in 
a different way. The most versatile of these is Clip to DEVONthink, 
which works exactly like the Clip to DEVONthink browser extension 
I described just above. 

The other seven bookmarklets capture content to your default destina-
tion in a single, specific format, with no extra options. The Archive, 
Bookmark, HTML, PDF, and PDF (Paginated) bookmarklets operate 
just as their counterparts in Clip to DEVONthink do. To save just 
selected text from a page as a (plain text) note, choose the Selection 
bookmarklet. To save all the text from the current page as a note, 
choose the Text bookmarklet. 

To install the bookmarklets, follow these steps: 

1. Open the browser you want to use, and go to the DEVONtechnolo-
gies Handbooks and Extras page. 

2. Make sure your Favorites (or Bookmarks) bar is visible. If not, then 
in Safari, choose View > Show Favorites Bar; in Chrome, choose 
View > Always Show Bookmarks Bar; or in Firefox, choose View > 
Toolbars > Bookmarks Toolbar. 

3. Under the page’s Bookmarklets heading, drag the Drag to Book-
marks button next to Clip to DEVONthink directly onto the Fa-
vorites (or Bookmarks) bar. Repeat, if desired, with any or all of the 
other bookmarks. 

4. If you prefer all your DEVONthink bookmarklets to be grouped in 
a folder on your Favorites (or Bookmarks) bar, use your browser’s 
bookmark editing tools to create a folder and drag the bookmarklets 
to that folder. 
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(If you use a different browser, the steps should be similar; if in doubt, 
check the browser’s documentation for how to install bookmarklets.) 

Once the bookmarklets are installed, using them is a simple matter of 
clicking the bookmarklet’s name (or choosing one of the bookmarklets 
from the a pop-up menu) on your Bookmarks bar (Figure 45). 

Figure 45: Use bookmarklets to grab web content from a browser. 

Using DEVONagent Pro with DEVONthink 
DEVONtechnologies makes a standalone web browser (well, they’d 
refer to it as “an internet research application with a built-in web 
browser”) called DEVONagent Pro ($49.95), which excels at 
massively complex web searches and filtering, summarizing, and 
mapping connections among the resulting data. It’s more than the 
average person needs for casual browsing, but for serious research, 
it’s a powerful tool. 

When browsing in DEVONagent Pro, there’s no need for bookmarklets 
or extensions, because the program has built-in links to DEVONthink. 
Just go to the Data menu and choose the format you want from the 
Add to DEVONthink section—Resource (such as HTML content or 
image), Bookmark, Rich Text, Summary, Formatted Note, Markdown, 
PDF (One Page), PDF (Paginated), Web Archive, or “via Clip to 
DEVONthink” (if you want to add a note or specify other details). 
DEVONagent Pro can also maintain its own archive, and later transfer 
documents from the archive into DEVONthink in any of these formats. 
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Add Email Messages 

You can easily add individual email messages—or even thousands of 
messages at a time—to DEVONthink. Of course, there’s nothing wrong 
with keeping email messages in your email client, but DEVONthink 
offers interesting advantages for at least some of your messages: 

• You can store correspondence about a project with related files. 

• You can use all of DEVONthink’s organizational features (repli-
cants, tags, See Also, etc.) with your email messages, which proba-
bly goes far beyond what your email client offers. 

• You can use DEVONthink’s fast and flexible searching. 

Note: Email archiving requires DEVONthink Pro or Server. 

You can import your messages into DEVONthink manually by drag 
and drop, but there are several automated ways: you can use the 
Import sidebar (described next) or the Import menu command, or you 
can Use the Mail Plugin (or Use the Mail AppleScripts) with Apple 
Mail or Use the Outlook AppleScripts. 

Note: If you use MailTags (part of the MailSuite plugin for Apple 
Mail), tags you applied to messages using MailTags are imported, 
along with the messages, as DEVONthink tags. See Tag Documents 
for more on tags. 

Import Messages Using the Import Sidebar 
The easiest way to import email messages in bulk—if you’re using 
Apple Mail, Microsoft Outlook, or Microsoft Entourage—is to use the 
Import sidebar. Follow these steps: 

1. At the top of the sidebar, click the Import icon (or choose View > 
Import). 

Note: In some situations, clicking that icon may cause your email 
client(s) to open, if they’re not already open. 
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2. If no email clients appear under the “Emails” heading, hover over it 
and click Show. DEVONthink should then display any of the sup-
ported clients you have installed. 

3. Select a client name (such as Apple Mail). Depending on how many 
mailboxes and messages you have, it may take a few moments or 
more for DEVONthink to refresh its display. 

Note: If this doesn’t work for you, make sure the Mail plugin is 
installed; see Use the Mail Plugin. 

DEVONthink shows each account and mailbox in the selected 
client(s); the number of messages in each one appears to its right. 
When you select a mailbox, its messages appear in a table view. 

4. Select an account or mailbox, or one or more individual messages. 
In the Email inspector (Figure 46) that appears on the right, you 
can use the Search field, Show pop-up menu, and checkboxes to 
filter the display of the selected account or mailbox. 
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Figure 46: The Email inspector lets you filter messages and set 
options for importing email. 

5. Select a destination for the imported messages from the Destination 
pop-up menu. 

Note: If you want DEVONthink to make its best effort to preserve 
message threads, go to Settings/Preferences > Files > Emails and 
select “Group conversation threads” before importing email. But be 
aware that DEVONthink may be unable to group messages the same 
way your email client does. 

6. Click the Import button to import only the messages selected in the 
table view—or, if no messages are selected, all the messages current-
ly visible in the table view. Or, to import the entire selected mailbox 
(or account), click the Archive Mailbox button. 

Individual messages are stored at your chosen location in a group 
bearing the name of their mailbox. Archived mailboxes, on the other 
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hand, are stored in a hierarchy of groups that includes the name of the 
account and client, and that is, in turn, contained in an Emails group. 

Import Unix Mailboxes 
If you use Thunderbird or another email app (besides Mail, Outlook, or 
Entourage) that stores its messages in standard Unix mailbox (.mbox) 
format, you can choose File > Import > Unix Mailbox, navigate to 
the .mbox file, and click Open to import the messages as a group in your 
current location. Alternatively, you can drag an .mbox file onto the 
DEVONthink icon in the Dock. (This command also works on .mbox 
packages exported by Apple Mail.) 

Use the Mail Plugin 
If you use Apple Mail, you can also send one or more selected mes-
sages to DEVONthink from within Mail, making it easy to archive 
particular messages (as opposed to entire mailboxes or large sets of 
messages) as you work. 

Before you can do this, you must make sure DEVONthink’s Mail plugin 
is installed. In Mail, select a message, pull down the Message menu, 
and look for a command called Add to DEVONthink 3. If it’s not there, 
quit Mail, open DEVONthink, choose DEVONthink 3 > Install Add-
ons, check Apple Mail Plugin, and click Install. Then reopen Mail. (If 
this is your first time using the DEVONthink plugin in Mail, there’s an 
extra step: go to Mail > Preferences > General > Manage Plug-ins, 
select DEVONthink.mailbundle, and click Apply and Restart Mail. You 
may also be prompted to grant DEVONthink full disk access in System 
Preferences > Security & Privacy > Privacy > Full Disk Access, if you 
have not previously done so.) 

To use the plugin, simply select one or more messages and choose 
Message > Add to DEVONthink 3 (⌘-Control-Option-M). DEVON-
think imports the message(s), storing them in the location specified in 
your preferences. (If you’ve set the Destination to “Select group” in 
Settings/Preferences > Files > Import, you can not only choose the 
location for the imported messages on the fly but also enter tags for the 
messages; if you import only one message at a time, you can also enter 
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a name.) You can also add the entire contents of the currently selected 
mailbox to DEVONthink with ⌘-Control-Option-Shift-M, but do so 
carefully, as you might end up importing a vast number of messages 
unintentionally. 

Use the Mail AppleScripts 
Although the Mail plugin and its associated menu command provide 
the easiest way to import Mail items into DEVONthink, there’s another 
option in case you have more specific needs: AppleScript. 

The scripts are found on the system-wide Script menu, which 
should appear among the little icons on the right side of your menu 
bar. If you don’t see it there, open the Script Editor utility (found in 
Applications/Utilities/), choose Script Editor > Preferences, and 
select “Show Script menu in menu bar.” (You can then quit Script 
Editor.) 

When you’re running Mail, five DEVONthink-specific scripts appear at 
the bottom of the Script menu, all of which are self-explanatory and 
apply to whatever is currently selected: 

• Add attachments to DEVONthink 

• Add mailbox(es) & attachments to DEVONthink 

• Add mailbox(es) to DEVONthink 

• Add message(s) & attachments to DEVONthink 

• Add message(s) to DEVONthink 
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The Mail Rule AppleScripts 
Besides AppleScripts that run from the system-wide Script menu 
and Mail’s Script menu, DEVONthink also includes several scripts 
you can use as actions in Mail rules, such that when messages match 
your rule’s criteria, DEVONthink performs certain activities, such as 
adding the message and/or its attachments to your database. (Note 
that one of these scripts, “Mail Rule - Add links to DEVONthink,” 
requires DEVONthink Pro or Server.) 

To use them, go to Mail > Settings/Preferences > Rules, click Add 
Rule, and set up a condition (such as matching a sender or subject). 
Then choose Run AppleScript for the action, and choose one of the 
scripts beginning with “Mail Rule.” 

Use the Outlook AppleScripts 
If you use Microsoft Outlook for email, you can also send messages or 
mailboxes to DEVONthink without leaving your email client. In this 
case DEVONthink relies on AppleScripts to do its thing. 

The scripts are found on the system-wide Script menu on the right 
side of your menu bar. If you don’t see it there, open the Script Editor 
utility (found in Applications/Utilities/), choose Script Editor > 
Preferences, and select “Show Script menu in menu bar.” (You can 
then quit Script Editor.) 

When you’re running Outlook, two DEVONthink-specific scripts 
appear at the bottom of the Script menu, both of which are self-ex-
planatory: 

• Add Mailbox to DEVONthink 

• Add Message(s) to DEVONthink 

Select the mailbox(es) or message(s) you want to import, and then 
choose the appropriate script from the menu. 

Work with Imported Messages 
When you view an imported email message in DEVONthink, it looks 
much like the original—generally, including headers and any text 
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styles. However, URLs in plain text messages may not initially be 
clickable links, and certain attachments may not appear. If this hap-
pens, switch from the default preview mode to text-only mode by 
choosing View > Document Display > Text Alternative (⌘-Control-X) 
or clicking the Text icon on the navigation bar. 

You can do nearly all the same things with imported email messages 
that you can with other DEVONthink documents. You can also do one 
extra thing: reply to the message! To reply, choose Data > Send Reply. 
DEVONthink switches to your default email client and opens a new 
message window, pre-addressed to the sender of the selected message, 
with the message contents quoted in the window. 

Use the PDF Menu 

Every Mac app that can print also has the capability to create PDF files. 
One common use of this feature is saving PDF copies of webpages with 
purchase confirmations in your ~/Documents/Web Receipts folder; 
another is attaching PDF copies of documents from any program to 
email messages. 

The commands used to send PDF files of the current document to 
various locations are found in the PDF pop-up menu at the bottom of 
every Print dialog (Figure 47). 
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Figure 47: In any Print dialog, choose Save PDF to DEVONthink 3 
from the PDF pop-up menu to add a PDF of the current document to 
DEVONthink. 

DEVONthink adds a command to this menu: Save PDF to DEVON-
think 3. Choose File > Print followed by this command to save any-
thing printable directly to DEVONthink as a PDF. (I use this capability 
all the time for web receipts, because it’s just as easy as choosing Save 
PDF to Web Receipts Folder but has the benefit of putting the item 
with all my other financial info in DEVONthink.) 

Scan Documents 

DEVONthink makes a great place to keep digital copies of paper 
documents, and if you have a scanner, chances are excellent that 
DEVONthink’s integrated scanner support will enable it to talk to your 
scanner directly, rather than forcing you to scan into a separate app 
and then import each document into DEVONthink. 

Note: Although any edition of DEVONthink can communicate with a 
scanner, only DEVONthink Pro and Server include OCR capabilities 
and the Import sidebar. 
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Generally speaking, scanned documents (as opposed to scanned 
pictures) are stored in PDF format. A PDF file can contain both a 
bitmapped image of the scanned document (such that if you were to 
print it, it would look just like the original) and an invisible layer with 
the document’s text, which can be indexed, searched, selected, copied, 
annotated, and so on. DEVONthink Pro and Server can perform optical 
character recognition (OCR) on the scanned image—automatically or 
manually—to add the searchable text layer; or if you prefer, you can 
use another app to do that. (ABBYY FineReader Pro, Acrobat Pro, 
PDFpenPro, ReadIRIS Pro, and numerous other Mac apps can do this; 
your scanner may even have included bundled OCR software.) 

Depending on what scanner you have, what software it comes with, 
and how the hardware and software are set up, you may be able to use 
either of two methods to get scanned documents into DEVONthink: 

• Scanner-initiated: You load a document into your scanner’s 
sheet feeder and press a button. As soon as the document is 
scanned, your scanner’s software sends it directly to DEVONthink, 
which can then (if you like) automatically perform OCR. (In a 
variation of this method, the scanner’s software performs the OCR 
and then sends the document to DEVONthink.) This is my preferred 
method, because it’s the simplest, and it works well with dedicated 
document scanners such as Fujitsu’s ScanSnap series, Raven scan-
ners, and Canon scanners that use the Canon IJ Scan Utility. 

Note: Do not set your scanner’s software to save documents to the 
system-wide global Inbox, as that will lead to undesirable results. 
Rather, direct the output to the DEVONthink 3 app. 

• User-initiated: You place a document in your scanner (typically, a 
flatbed scanner) and then, in DEVONthink, click the Import icon 
in the sidebar (or choose View > Import) and select your scanner 
under Devices. (If you don’t see Devices, hover over the Image 
Capture label and click Show.) You can then make any desired 
changes to the settings and initiate the scan. As long as your scan-
ner or digital camera works with Image Capture, it should work 
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here. This option avoids the need to launch any external app. I say 
more about this ahead, in Pull an Image from a Scanner or Camera. 

Tip: When you launched DEVONthink 3 for the first time, you should 
have been prompted to install the optional ABBYY FineReader soft-
ware, which provides OCR capabilities. If you didn’t install it previous-
ly, do so now—OCR won’t work without it. To do so, choose DEVON-
think 3 > Install Add-ons, check ABBYY FineReader OCR, click Install, 
and follow the prompts. 

Tip: If you already have scanned documents on your disk and you 
simply want DEVONthink to perform OCR to make them searchable, 
see the tip Perform OCR on Documents in Your Database. 

Because scanning involves so many variables—and because DEVON-
think’s built-in help does such a nice job of covering all the steps to 
take in various situations—I’m not going to provide detailed instruc-
tions for every scanner here. 

Tip: Make sure to set your scanner’s resolution to at least 300 dpi. 
At lower values, DEVONthink’s OCR quality suffers. (Conversely, over 
600 dpi, file size increases dramatically without much improvement 
in accuracy.) In my tests, 300 dpi provided the best combination of 
image quality, OCR accuracy, and file size. 

I do, however, want to call your attention to a few key scanning topics. 

Use a Fujitsu ScanSnap 
Fujitsu’s ScanSnap scanners make an especially good match for 
DEVONthink Pro Office, and they require only a few quick setup steps. 
The short version is: open the ScanSnap Home app and set 
DEVONthink as the destination for new scans. (For all the details, see 
this post on the DEVONtechnologies blog.) 

After that one-time setup, simply pop one or more documents in your 
ScanSnap, press the button, and wait a few moments (depending on 
document length and your settings) for the scanned, searchable PDF to 
show up in DEVONthink. 
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Note: In a surprise move, after claiming it wouldn’t happen, Fujitsu 
in July 2020 released 64-bit ScanSnap Manager software supporting 
Catalina and later as well as both newer scanners and several now-
discontinued models, such as the S1100, S1300, S1500, and 
S1500M. If you have an older scanner that isn’t supported by any 
current Fujitsu software and want to use it with DEVONthink, you 
may be able to do so using ExactScan (mentioned next). 

Use ExactScan 
ExactScan is software that enables many PC document scanners to 
work on a Mac—and even supports older Mac document scanners. If 
you have ExactScan installed and a compatible scanner, DEVONthink 
can interact with it in almost exactly the same way as with a Fujitsu 
ScanSnap (described just previously). If you have ExactScan installed, 
go to DEVONthink 3 > Install Add-Ons, select “Install Avision Exact-
Scan Support” and click Install to configure ExactScan to send scans 
directly to DEVONthink. 

Use a Raven Scanner 
If you have a Raven scanner and have installed the Raven Desktop 
software, you can use DEVONthink as a destination for your scans. 
Follow the setup instructions in Connecting to DEVONthink in Raven 
Desktop. Then, adjust the settings in Configure OCR Preferences for 
OCR (if desired). 

Pull an Image from a Scanner or Camera 
If you have a Fujitsu ScanSnap or another document scanner that can 
be configured to “push” scanned images directly to DEVONthink, 
you’ll enjoy the convenience of being able to scan and import 
documents in a single step, merely by pressing a button on your 
scanner. However, if you have a scanner (or digital camera) that 
expects all scans to be initiated from within an app on your Mac, you 
can still “pull” documents from it into DEVONthink. 

Note: This feature requires DEVONthink Pro or Server. 
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Follow these steps: 

1. Click the Import icon in the sidebar (or choose View > Import) 
and select your scanner under Devices (Figure 48). If necessary, 
wait for it to warm up. 

Figure 48: Use this view to control your scanner from within 
DEVONthink. 

2. Your scanner may automatically display a preview image; if not, 
click Overview to capture one. 

3. In the inspector on the right, set your desired preferences, including 
the location to which scanned documents will be saved. If you want 
DEVONthink to perform OCR on the newly scanned document, 
select the OCR checkbox. 

4. Click Scan. 

DEVONthink stores the image in the location you chose. 

Configure OCR Preferences 
If your scanner’s software doesn’t perform OCR itself, you can have 
DEVONthink automatically convert documents to searchable form as 
soon as a scan is complete. To set up DEVONthink’s OCR preferences 
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(which also apply when you manually convert documents to searchable 
PDFs), go to Settings/Preferences > OCR (Figure 49). 

Figure 49: Set preferences for both automatic and manual OCR in 
this preference pane. 

Your options, along with my suggestions, are as follows: 

• Convert Incoming Scans: Choose “to Searchable PDF” to make 
DEVONthink perform OCR automatically on all scans initiated from 
within DEVONthink or sent to DEVONthink by known scanning 
software (such as ScanSnap Home, ExactScan, and Brother’s iPrint 
& Scan) and save the document as a searchable PDF. That’s the 
most common use case and my recommendation for most people. 
However, DEVONthink 3 supports additional formats—you can also 
choose “To RTF document,” “To Word document,” or “To Web 
Archive” to save the scanned and OCR’d document in one of those 
more readily editable (if less visually accurate) formats. You can 
also choose “To Comment” or “To Annotation” to add the recog-
nized text as metadata in either of those formats, without changing 
the original document. 

If you choose No Action, the scans will still be imported into DE-
VONthink, but only as bitmapped images. (You can do OCR later, 
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however; see the tip Perform OCR on Documents in Your Database, 
ahead.) 

• Resolution: Set the resolution of the image layer in the PDF by 
entering a number from 150 to 300 (dpi). 

• Original Document: If you check Move to Trash, after 
DEVONthink creates a searchable PDF, it moves the original scan 
(with just the bitmapped image) to the Trash—in this case, the 
Finder’s Trash, not DEVONthink’s. In most cases, that’s probably 
what you want, because otherwise you’ll end up with two copies of 
every scanned document. 

• Searchable PDF: If “Enter metadata after text recognition” is 
checked, as it is by default, then every time you scan a document 
into DEVONthink, the app displays a dialog (Figure 50) in which 
you can enter a title, subject, tags, and other metadata. A scrollable 
preview of the document, on the left, helps you remember what’s in 
it—handy if you’re scanning a large stack of documents at once. 

Figure 50: To name and tag scanned documents as the text is 
recognized, select “Enter metadata after text recognition” in the OCR 
preference pane, which results in this dialog appearing after each 
scan. 
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If you don’t enter this data as you scan, you’ll end up with files with 
unhelpful names like “20190916_004” and no tags. On the other 
hand, if you’re scanning lots of documents at once, stopping what 
you’re doing every minute or two to enter document details can be a 
drag. Because I usually scan only one or two documents at a time, I 
find it most effective to leave this box checked. 

If you leave Compress PDF checked, as it is by default, DEVONthink 
performs lossless compression on the PDF, which is a good thing as 
the file takes up less disk space. 

• Custom dictionary: If you scan documents that may contain 
unusual words that wouldn’t be found in DEVONthink’s built-in 
dictionaries, you can add your own custom dictionary (which is 
simply a word list) to improve recognition accuracy. To do this, 
select Use Dictionary, and then click Configure to choose your 
language and enter your list of words. 

• Primary Language: Choose the language that most of your docu-
ments will be in (presumably English if you’re reading this book). 

• Secondary Languages: If you expect to scan documents in any 
language other than the primary language, select each of those 
languages in the Available list and click the left arrow button to add 
them to the Selected list. (I put French in this list, because many of 
the documents I scan are in French.) 

Import Previously Scanned Documents 

If you have a bunch of scanned documents that don’t already have a 
searchable PDF text layer, DEVONthink (Pro or Server) is happy to 
import them and perform OCR after the fact. These images need not 
have come from a scanner as such—even photos or screenshots can be 
used, although accuracy depends on resolution, sharpness, contrast, 
and other factors. 
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To import images and convert them to searchable PDFs, follow these 
steps: 

1. Choose File > Import > Images (with OCR). 

2. Navigate to the folder where the images are stored. Select one or 
more files (⌘-click to select multiple files). 

3. To set additional options, click the Options button: 

a. To move the original file in the Finder to the Trash after DE-
VONthink imports it, check “Move original to trash”; to leave the 
original in place, uncheck the box. 

b. If you want the documents to be converted to a format other than 
PDF, choose the format you want (RTF, Word, or web archive) 
from the Convert pop-up menu. 

4. Click Open. 

DEVONthink now imports the selected files, performs OCR, and 
(depending on your preferences) may prompt you for titles and other 
metadata. 

Perform OCR on Documents in Your Database 
What if you have a scanned PDF or other graphic that’s already in 
DEVONthink but isn’t yet searchable? No problem. Select one or more 
documents in DEVONthink and choose Data > OCR > to Searchable 
PDF. DEVONthink recognizes the text and, if Move to Trash is 
checked in Settings/Preferences > OCR, moves the original 
bitmapped image to the Trash. (The Data > OCR menu also contains 
commands for converting documents to RTF, Word, and web archive 
formats, and for adding recognized text as comments or annota-
tions—leaving the original document unchanged.) 

Import from Bookends 

DEVONthink Pro and Server also support importing bibliographic 
information from Bookends. To do this, choose File > Import > Refer-
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ences from Bookends. DEVONthink imports Bookends references as 
rich text documents and stores them in a group called “Bookends.” If 
your Bookends items included keywords, those appear in the Docu-
ment Properties of the documents; you can convert them to DEVON-
think tags by selecting the document(s) and choosing Data > Tags > 
Convert Keywords to Tags. 

Import Bookmarks from an HTML File 

If you have an HTML file containing a list of bookmarks (for example, 
one exported from Safari), DEVONthink can import it. Choose File > 
Import > “Bookmarks from HTML file,” select one or more files, and 
click Open. DEVONthink creates a new group for each HTML file, 
preserving the hierarchy of the original bookmarks, and names each 
bookmark automatically. 

Note: When importing or indexing local copies of files downloaded 
from Google Docs or Google Sheets (.gdoc or .gsheet), DEVONthink 
treats them as bookmarks. 

Use the Built-in Web Browser 

DEVONthink includes Apple’s WebKit, the same rendering engine 
Safari uses to display webpages. So a webpage viewed in DEVONthink 
should look the same as it would in Safari. The difference is that even 
though you can store bookmarks, follow links, use multiple tabs, and 
click previous/next page buttons, DEVONthink treats each page as a 
separate (dynamic) document. That means (among other things) 
there’s no editable address bar—only the URL of the current page. So 
even though DEVONthink can show you the contents of webpages, it’s 
not so much a browser (that is, it doesn’t facilitate random browsing) 
as a tool that can fetch, render, and store webpages. 

There being no address bar, how do you open a webpage in the first 
place? Choose Script > Tabs > Open Location…, enter a URL, and 
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click OK. DEVONthink then displays the resulting webpage as an 
ordinary document (Figure 51). 

Figure 51: You can display any webpage in DEVONthink as though it 
were a regular document. 

Having found a webpage you like, you can add it to your database if 
you want to save it. To do so, use one of the following commands on 
the Tools > Capture submenu (most of which mirror those used by the 
Clip to DEVONthink Browser Extension): 

• Bookmark: Stores a bookmark for the page—that is, a document 
containing only its URL. When you select this bookmark in your 
database, DEVONthink attempts to connect to the site to download 
and display the page, in whatever state it’s in at that point. Alterna-
tively, you can capture the address by choosing Data > New > 
Bookmark. (Or, drag the page’s address from the navigation bar 
onto a group or tag.) 

• Rich Text: Stores the page as a rich text document. 

• Formatted Note: Stores the page as a formatted note. 

122 



         
        
      

       

            

         

         

       
          

      
  

         
        

          

      
        

          
          

        
       

       
       

      

         
        
 

           
           

        
             

• Markdown Text: Attempts to store an approximation of the 
page’s content formatted as Markdown, though actual results are 
highly variable based on the page design. 

• HTML Page: Stores the webpage as an HTML file. 

• Web Archive: Stores the page and any associated media as a web 
archive. 

• PDF (One Page): Stores the page as a (non-paginated) PDF file. 

• PDF (Paginated): Stores the page as a paginated PDF file. 

Note: If Clutter-Free Layout is selected on the Tools > Capture 
submenu when you choose one of the above options other than 
Bookmark, DEVONthink attempts to remove ads and other non-article 
content when saving the page. 

• Clip to DEVONthink: Displays the Clip to DEVONthink dialog 
(see Clip to DEVONthink Browser Extension), which lets you 
choose a format, change the name, add tags, and so on. 

Downloading and Importing an Entire Site Automatically 
To download and import an entire website (available only in Pro and 
Server editions), choose File > Import > Website, enter the URL, and 
click OK. Then, in the Download Manager panel, select the site, click 
the actions icon, and choose Download To > Database Name or 
Global Inbox (that is, anything except Folder) from the pop-up menu. 
Go back to that pop-up menu, choose Options, and select your 
preferences. (For details on the available options, consult the DEVON-
think documentation.) Finally, click the Start button. 

Be aware that downloading an entire site may take an extremely long 
time and use an appalling amount of disk space—so use this feature 
with caution. 

DEVONthink doesn’t attempt to be a full-featured browser, but it does 
offer a few common browser features—if you know where to find them: 

• Tabbed browsing: DEVONthink can open multiple browser tabs 
in a single window or the view/edit pane, but to use this capability, 
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you must first turn it on—go to Settings/Preferences > General > 
Interface and check “Enable tabbed browsing.” (If you want the tab 
bar to be visible even when just one webpage is open, also check 
“Always show tab bar.”) 

Thereafter, to open a link in a new tab, ⌘-click it (to keep the tab in 
the background) or ⌘-Shift-click it (to switch to the new tab). 

You can switch to a particular tab by clicking it or close it by clicking 
its close icon; you can also press ⌘-Shift-] to move to the next 
tab or ⌘-Shift-[ to move to the previous tab. You can’t, however, 
rearrange tabs within a window. 

Tabbed Browsing Isn’t Just for Webpages! 
With tabbed browsing on, the same behavior in DEVONthink applies 
to links in PDF and rich text documents—as do the previous/next 
page controls. In fact, you can open any number of documents, of 
any kind, in separate tabs (select the documents, hold down the 
Option key, and choose Data > Open in Tabs, ⌘-Option-O). However, 
tabbed browsing in DEVONthink is far less advanced than what you’ll 
find in a modern web browser, and depending on how you use the 
app, you may find tabs to be more cumbersome than separate 
windows. 

• Previous/next page: To move to the page you previously visited 
in the current window, view/edit pane, or tab, press ⌘-[ or click the 
Go Back icon on the navigation bar; to move forward to the next 
page, press ⌘-] or click the Go Forward icon. 

• Reload: Right-click (or Control-click) anywhere on the page and 
choose Reload from the contextual menu; or click the Reload icon 
on the navigation bar. 

Read RSS Feeds 

Just as DEVONthink can display individual webpages as documents, it 
can grab all the articles from an RSS (or Atom, RDF, or JSON) news 
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feed, treating each article as a separate document and displaying its 
contents using the same WebKit rendering engine.

To add a feed, navigate to the location where you want to store it and 
choose Data > New > Feed. In the dialog that appears (Figure 52), 
enter the feed’s URL (which usually begins with either feed://, filled in 
by default, https://, or http://), optionally type one or more tags 
(pressing Tab after each one) and enter a name if you want to override 
the feed’s default name, and click Add. DEVONthink connects to the 
feed and downloads its current articles.

Figure 52: Enter a feed’s URL and any tags you want to apply to it 
in this dialog.

Tip: You can put feeds anywhere, but if you plan to use DEVONthink 
for most of your feed reading, I suggest making a new group called 
Feeds at the top level of your database and putting your feeds there.

To read an article in a feed, select the article under the feed name 
(Figure 53); doing so marks it as read. To manually change an arti-
cle’s read status, select it and choose Data > Mark > As Unread (or 
As Read), or press ⌘-K. These commands are also available on the 
Mark submenu of the Actions (  or ) pop-up menu and the 
right-click/Control-click contextual menu.



        
  

            
            

       
            

               
             

             
          

   

           
   

Figure 53: Feeds appear much like groups, and each article in a 
feed is a separate document. 

A feed behaves much like a group, in that it contains other documents. 
A feed’s tags are inherited by all its constituent articles, but unlike 
ordinary groups, feeds don’t pass on their own names to enclosed 
documents as group tags. In other words, if you have the CNN.com 
feed in a Feeds group, every news article in the feed gets the Feeds tag, 
but not a CNN.com tag. You can, of course, manually change the tags 
of any individual article, or even drag an article to an entirely different 
location—once it’s in DEVONthink, you can treat an RSS article just 
like any other document. 

DEVONthink offers several ways to adjust feed behavior, all found in 
Settings/Preferences > RSS (Figure 54). 
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Figure 54: Set preferences here for handling RSS feeds. 

You can adjust the following preferences: 

• Check for Updates: Choose how often DEVONthink should check 
each feed for new articles. The default is Every 15 Minutes, but you 
can choose an interval as short as Every 5 Minutes or as long as 
“Every day”; you can also choose “After opening the database,” 
“After synchronizing the database,” or Manually. 

Note: To refresh a feed manually—even if you’ve chosen automatic 
periodic updates in Settings/Preferences > RSS—select the feed (not 
an individual article in the feed) and choose Refresh Feed from the 
Actions pop-up menu on the toolbar, or right-click (or Control-
click) the feed name and choose Refresh Feed from the contextual 
menu. 

• Convert Categories to Tags: Many RSS feeds label each article 
with categories defined by the creator. To assign these categories to 
articles as tags, leave this box checked. However, keep in mind that 
these tags persist even after the articles are deleted; if you have a 
large number of feeds, this setting can lead to an overwhelming 
number of tags. 

• Remove Articles: RSS feeds contain only a limited number of 
articles (typically 10–20 or so); as new ones are added, old ones 
disappear. You can have older articles disappear from DEVONthink 
too by choosing a time period from this pop-up menu, such as 
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“After one week” or “After two months.” Or, choose Manually, and 
the articles remain there until you delete them. (If you check “Also 
unread articles,” this setting applies to unread articles too; if it’s 
unchecked, only read articles are removed automatically.) 

Note: Even if you have the RSS preferences set to delete older 
articles automatically, you can exclude an entire feed, or a particular 
article, from automatic deletion. To do so, select it, choose Data > 
Mark > As Locked, pr press ⌘-Control-K. (You can also use the 
comparable command on the Actions pop-up menu or the right-
click/Control-click contextual menu.) 

• Feed Format: Use this pop-up menu to choose the format in 
which DEVONthink saves RSS articles. The default choice, Auto-
matic, saves articles as HTML documents, but if you prefer, you can 
also choose Rich Text, Formatted Note, Markdown, Web Archive, 
PDF (One Page), or PDF (Paginated). If you check “Use clutter-free 
layout,” DEVONthink attempts to remove ads and other likely 
unwanted non-article content from the articles. 

• Feed Style Sheet: DEVONthink uses Cascading Style Sheets 
(CSS) to determine the appearance of feed articles. Normally, you 
probably want Simple.css or Leopard.css, both of which offer clean 
styled text on white backgrounds (but with different fonts and 
spacing). 

Default.css is a plain-text style sheet with a small font; there’s also 
Tiger.css, which is similar to Leopard.css but has a lower-contrast 
gray background (and yes, those names are quite anachronistic!). 
After changing the style sheet, switch to a different article to refresh 
the display with the new styles. 

Tip: If you’re handy with CSS, you can create your own style sheet 
and put it in ~/Library/Application Support/DEVONthink 3/Style‐
Sheets; it then appears in this pop-up menu. 
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Joe’s Recommendations for Getting 
Stuff into DEVONthink 

Whew! That’s a lot of ways to get data into DEVONthink, and, in fact, 
there are a few more that I didn’t mention. You can’t fault the app for a 
lack of flexibility—no matter where you are or what sort of data you’re 
looking at, there’s at least one way, and probably several, to add it to 
DEVONthink. 

If you’re feeling overwhelmed with all these choices, you’re not alone. 
Sometimes I mentally go around in circles trying to pick the best way 
to get, say, text from a webpage into DEVONthink. Clip to DEVON-
think extension? (Using which format?) Bookmarklet? (Which one?) 
Services menu command? (Which one?) Share extension? Print to 
PDF? Drag and drop to the Sorter…or the Dock icon…or an open 
DEVONthink window? Or what about a keyboard shortcut? I could use 
the one for the Take Rich Note command on the Services menu or the 
one for the Sorter’s Copy Selection command, or I could copy, switch 
to DEVONthink, and press ⌘-N to paste the contents of the clipboard 
as a new note! It’s enough to make you crazy, thinking about all the 
ways you can proceed. 

Everyone’s different, and I don’t pretend to have a one-size-fits-all 
solution. But after thinking about my own experiences and listening 
to what many other DEVONthink users had to say, I’ve come up with 
some guidelines that you may find helpful: 

• Small screen: Are you feeling cramped on an 11-inch MacBook 
Air? Is your display (of whatever size) filled with windows ten layers 
deep? If so, you’ll want to avoid more screen clutter. If you use the 
Sorter, display it as a menu extra using the icon rather than text. 
Consider hiding your Dock and using Spaces to put DEVONthink in 
a space by itself. Then, to get data into DEVONthink from another 
program, use the Sorter menu bar icon (which, as you’ll recall, pops 
out the Sorter as needed when you drag something to the icon), the 
Services menu, the Share extension, or, in a web browser, the Clip 

129 



           
  

         
             

           
          

           
           

            
           

     

            
             

            
           

      

           
             

        
        

           
            
   

             
            

           
            
          

             
        

         
       

      
          

to DEVONthink extension or a bookmarklet. In the Finder, use the 
system-wide global Inbox. 

• Large screen: If you’re fortunate enough to have, say, a 27-inch 
iMac and a secondary display or two, make the most of your screen 
real estate by keeping the Sorter open in docked tab mode (with 
databases and groups expanded to show as much as possible) in a 
convenient location, and use drag and drop to put clippings and 
documents right where you want them. Or, if you have serious 
screen space (like a Mac Pro with six displays), you could devote a 
whole display just to DEVONthink and then drag anything you want 
to save directly into the app. 

• Low RAM or slow CPU: If you have an older or slower system, 
or one without much RAM, you may prefer to have as few apps 
running at a time as possible. In that case, the system-wide global 
Inbox is your friend, because it lets you capture data without 
DEVONthink having to run in the background. 

• Keyboard focus: People who prefer to keep their hands on the 
keyboard will want to get used to the keyboard shortcuts for two of 
DEVONthink’s Services: Take Plain Note [⌘-(] and Take Rich Note 
[⌘-)], which work on selections in many different applications. 
And, if you’ll have the Sorter open anyway, also visit DEVONthink 
3 > Preferences > Sorter and assign a convenient keyboard shortcut 
to Copy Selection Hotkey. 

• Neat freak: If you believe in the motto “a place for everything, and 
everything in its place,” then it may bother you to dump everything 
into an inbox (especially if it’s the global Inbox) and sort things 
later. So, if you already have an arrangement of groups and tags 
you’re happy with and you want to make sure everything is classi-
fied immediately, keep the Sorter running so you can drag data to a 
specific location, and set DEVONthink’s Destination preferences (in 
Settings/Preferences > Files > Import) to “Select group,” so you’re 
prompted to choose a group each time you import. 

• Compulsive collector: Perhaps you’re capturing information 
constantly, importing new data every few minutes, and it’s too time-
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consuming and intrusive to figure out where everything goes in real 
time. In that case, set your default Destination to “Global inbox,” 
and get in the habit of reviewing its contents from time to time 
(perhaps using the Classify command to help you sort). 

• Joe: If you’re Joe Kissell…I know, you’re not me, but if you’re 
curious to know what I do, here it is. I have my default Destination 
set to “Global inbox,” because I prefer to organize my documents 
after the fact rather than take the time to do that when I capture 
them (although the option I’d prefer is one that doesn’t exist—Inbox 
of My Chosen Database). When I’m working on my iMac Pro, I 
have the Sorter shown as a docked tab, since I have plenty of space, 
but on my MacBook Pro I show it as a menu extra (in icon mode) 
because I need every last pixel. 

In Safari, I typically use the (unpaginated) PDF bookmarklet 
(because it requires fewer clicks than the Clip to DEVONthink 
extension), and for random files or text selections, I drag them 
to the system-wide global Inbox or, if it happens to be more 
convenient, to DEVONthink’s Dock icon (on the right side of my 
screen). I also occasionally use the Save PDF to DEVONthink 3 
command on the PDF menu in the Print dialog. But most of the 
contents of my database comes come by way of scanning, thanks 
to my trusty Fujitsu ScanSnap scanner and automatic OCR. 

I regularly sort through my inbox, using the Classify command 
where possible, to put everything in a logical location. 
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Organize Your Information 
Once you’ve gotten into the habit of collecting data in DEVONthink, 
you may quickly discover that you have hundreds or even thousands 
of pieces of information. Although you could, if you wanted, simply 
keep everything in your inbox and then search for whatever you need, 
DEVONthink offers numerous ways of grouping, labeling, tagging, and 
otherwise organizing your information. Once you’ve shown DEVON-
think how you prefer to have your information organized, you can also 
take advantage of its almost magical Classify features. 

The better you organize your data in DEVONthink, the easier it is to 
find what you’re looking for and to see the connections between related 
items. 

Understand Groups and Tags 

Before I tell you how to group and tag documents, I want you to know 
a bit about how the two mechanisms operate. 

Groups and tags are two ways of categorizing documents. Conceptual-
ly, they follow different models: you put documents in groups (so a 
document normally exists in only one location), whereas you apply 
tags to documents (so a document can have any number of tags). Of 
course, DEVONthink’s use of replicants makes it possible for a single 
document to exist in more than one location, but tags let you apply 
multiple categories to a document more simply and directly. 

Groups tend to work best for data that has a largely self-evident logical 
structure, whereas tags are generally more freeform and subjective— 
how you want to think of particular documents rather than what data 
they objectively contain. 

In order to enable groups and tags to work together as effectively as 
possible, DEVONthink uses the same underlying construct for both. 
That is to say, behind the scenes, both groups and tags are merely 
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labels—pieces of metadata associated with documents. In many re-
spects, groups and tags function (and even look) almost exactly the 
same, and you can mix and match groups and tags freely (but see the 
sidebar Stepping Stone: Are You a Grouper or a Tagger?, ahead). 

However, there are some subtle differences in behavior between 
groups and tags, and they interact in sometimes surprising ways. 

Stepping Stone: It All Makes Sense Once You Get the 
Hang of It 
I’m going to lay out some basic facts here—principles that govern 
the way tags and groups behave—but before doing so, I want to 
reassure you that you need not memorize, or even understand, all 
of this in order to use groups and tags effectively! Take a couple of 
deep breaths, and try grouping or tagging a few of your example 
documents as you read through this to see these principles in action. 
And if you still feel a bit lost, skip ahead a few pages to the next 
“Stepping Stone” sidebar for more guidance. 

To reduce the likelihood of confusion, you should be aware of the 
following facts: 

• Every tag is also a group—of sorts. All your tags are listed under 
Tags in the Globals portion of the Navigate sidebar, and if you drag 
a document from outside DEVONthink to one of these tags (mean-
ing it’s not already in an inbox or some other group), the only place 
that document appears in your database (other than in its inbox) is 
in that tag’s “group.” 

• Groups and tags can both be hierarchical—you can nest one inside 
another, as many levels deep as needed, just like folders in the 
Finder. You can drag and drop groups anywhere they appear in your 
database to rearrange them, but it may not be obvious how to 
rearrange tags. The easiest way to do so is to go to the Tags list 
under Globals in the Navigate sidebar and drag one tag onto anoth-
er, thus making the first tag a “child” of the second one (and causing 
all child documents to inherit the parent tags). 
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• When you create a new database, groups do not function as tags by 
default, but you can enable them to if you like; having done so, you 
can then individually prevent particular groups from being used as 
tags, just as you could before. DEVONthink refers to a group that 
also functions as a tag as a group tag. 

To enable group names to be used as tags, first select a database in 
the sidebar and choose File > Database Properties. Then make sure 
Exclude Groups from Tagging is unchecked. This makes all groups 
eligible to be used as tags, as indicated by group tag icons that 
look like stacks of tags. To then prevent a particular group from 
being used as a tag, select that group and choose Tools > Get Info. 
In the Exclude From section, check Tagging. Groups that are ex-
cluded from tagging have group icons that look like stacks of 
rectangles. 

• In the various locations in which DEVONthink shows tags (such as 
in the tag bar at the bottom of the window and Tag view), group tag 
names appear in stacked tokens, whereas tags you create 
manually—that is, ordinary tags—appear in plain tokens. 

• When group tags are enabled, documents have tags not only for 
the group tag that contains them, but also for any group tags higher 
in the structure. So, if a document is in the Cakes group tag, which 
is inside the Desserts group tag, which is inside the Recipes group 
tag, it gets Recipes, Desserts, and Cakes tags. 

• Both ordinary tags and group tags apply dynamically—if you change 
the hierarchy of groups or of the tags in your Tags list, all docu-
ments in those groups, or marked with those tags, update them-
selves to reflect the current arrangement. 

• You can have more than one group or group tag with exactly the 
same name, because DEVONthink places no restrictions on how 
many times you can reuse a group or group tag name. However, 
avoid doing this if you can, as it increases the likelihood that you’ll 
accidentally apply the wrong tag. 

134 



           

             
           

           
        

            
             

             
           

 

          
            

            
             
            

       

If you’ve enabled groups to be used as tags, additional curiosities arise: 

• If a document is in a group, ipso facto, it’s tagged with that group’s 
name. If you remove the group’s tag from the document, the docu-
ment disappears from that group (and, if that was the document’s 
only tag, DEVONthink moves it to that database’s inbox). 

• If you replicate a document to another group, not only the new 
replicant, but all replicants get the tag of the new group name (and 
its parent groups). So, if a document is in the Cookies group and 
you replicate it to the Sweets group, both replicants will be tagged 
with both group names. 

If all that leaves your head spinning, don’t worry. It is a lot to keep 
straight, but my advice is to spend some time playing with groups and 
tags (following the instructions in the next couple of topics) and see for 
yourself how they work. If you get stuck or find that something isn’t 
working the way you expect, refer back to the preceding list, which may 
help you make sense of what you’re seeing. 
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Stepping Stone: Are You a Grouper or a Tagger? 
Grouping and tagging are fundamentally different approaches to 
categorization. In some situations, using both together can cause 
confusion if you’re not careful. My feeling is that most people will find 
DEVONthink easier to use if they stick with either groups or tags—at 
least for the bulk of their categorization needs. Which one should you 
use? It depends on your needs and how you think: 

✦ Grouper: You might be a “grouper” if you’ve set up an extensive, 
well-thought-out hierarchy of folders in the Finder or mailboxes 
in your email app, and if you fastidiously file everything. If so, 
continue that practice in DEVONthink, and ignore tags. But try to 
give every group a unique name—perhaps one reflecting its posi-
tion in the hierarchy (such as “Taxes 2019” instead of just 
“2019”). If you find that a document belongs in two different 
places, use a replicant rather than a tag. (Groups may also be 
best if other people will use your database, as it’s often easier to 
locate unfamiliar material in a good hierarchy than by guessing at 
what tags another person may have used—even though tags may 
be hierarchical, too.) 

✦ Tagger: You might be a “tagger” if you prefer Gmail’s labeling 
approach over filing each message in a single, specific mailbox; if 
your email inbox contains thousands of messages; or if you fre-
quently use tags to identify files in the Finder (and pay little 
attention to file organization). In DEVONthink, a tag person might 
decide to keep everything in the inbox (despite my advice to the 
contrary elsewhere in this book), apply tags as necessary, and use 
search as the main way to find things. One downside: DEVON-
think’s artificial intelligence features, such as See Also and Classi-
fy, won’t be of any use, as they rely on (ordinary) groups. 

If you do use groups and tags together, please do yourself a favor 
and make sure groups are excluded from tagging (the default setting 
for new databases), as discussed a few pages back. Keeping the two 
entities conceptually separate will save you lots of agony. In addition, 
I suggest limiting yourself to a relatively few broad groups with fairly 
obvious, uncontroversial names, and then using tags for more per-
sonal or subjective categories. For example, if you store lots of 
recipes, you might use groups for things like “soups,” “salads,” and 
“desserts,” while using tags for “make-ahead,” “dinner party,” and 
“holiday.” 
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Create and Use Groups 

Creating groups is as easy as creating folders in the Finder (and in 
some cases, easier). DEVONthink gives you lots of ways to get docu-
ments into groups, including moving, duplicating, replicating, and 
using the groovy Classify features. 

Create a Group 
You can make a group in the current location in your DEVONthink 
database in any of the following ways: 

• Choose Data > New > Group (⌘-Shift-N). 

• From the Actions pop-up menu on the toolbar, choose New > 
Group. 

• Right-click (or Control-click) anywhere a group or document may 
appear and choose New > Group. 

After creating a new group (in any of these ways), type a name for it 
and press Return; you can select it and click its name later to rename 
it. The names of empty groups are shown in gray; when a group con-
tains one or more items, the name is shown in black. 

Grouping Documents Using the Group Items Command 
If you plan to create a new group and then immediately move docu-
ments into it, you can do both tasks in one operation. To do this, 
select one or more documents and choose Data > Group Items (⌘-
Option-G) or use the Group Items command on the Actions pop-
up menu or the right-click/Control-click contextual menu. 

DEVONthink puts the new group in the same location as the existing 
documents. Thus, grouping documents in your inbox creates a group 
in your inbox; You can relocate the group by clicking and dragging it. 

DEVONthink places no restrictions on how many groups you can 
create, how deeply you can nest them, or what you can name them 
(you can even have multiple identically named groups in the same 
location if you like, which strikes me as problematic). However, I tend 

137 



           
         

              
      

    
    

         

  
      
      

        
       

      
     

         
         

      
       

      
        

          
           

            

    

            
           

 

        

           

to get the best results—especially when using features that rely on 
artificial intelligence—with a modest number of groups in a database 
(say, fewer than a hundred or so), nested only a few layers deep, and 
with more than a few documents in each one. 

Tip: Besides conventional groups and group tags, DEVONthink lets 
you make dynamic collections of documents called smart groups, 
which are, in fact, saved searches. See Use Smart Groups for details. 

Stepping Stone: Artificial Intelligence and Document Length 
The DEVONthink features that use artificial intelligence—such as See 
Also & Classify (discussed shortly)—work best on documents with 
text contents of between roughly 50 and 1,000 words. With less text, 
DEVONthink doesn’t have enough material to make a good evalua-
tion. And longer documents tend to be broader, making it more 
difficult to match them with more specific texts. 

Therefore, if you’re deciding how much text to select or to create 
when making a new document, aim for a short-to-moderate length. 
And, consider excluding very long documents (such as ebooks) from 
the artificial intelligence features to produce better matches for 
everything else: select each document, choose Tools > Get Info and 
check the Classification and See Also boxes in the Exclude section. 

Move Documents 
You can freely reorganize your documents whenever you like. The 
fundamental way to do so is to manually move them between loca-
tions. To move one or more selected items, do any of the following: 

• Drag the item(s) to another group. 

• From the Actions pop-up menu on the toolbar (or at the 
bottom of the sidebar, for selections in the sidebar), choose Move 
To > Name of Group. 

• Right-click (or Control-click) the document, and choose Move To > 
Name of Group. 

• Choose Data > Move To and select a group in the popover. 
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Note: The top of the Move To submenu shows recent destinations to 
which other items have been moved. The lower part of the menu 
shows groups from all open databases. 

Classify Documents 
If you’re not sure where a document belongs—or if you have a pretty 
good idea but want to save yourself the effort of navigating to that 
location—you can use the Classify features to help you choose a home 
for each piece of data. These features examine the contents of a docu-
ment and, by comparing them to the contents of other documents in 
your database, recommend one or more locations in which to store it. 

Classify Documents Manually 
To classify a single document manually, select it and choose Tools > 
Inspectors > See Also & Classify (Control-S) or click the See Also & 
Classify icon at the top of the inspector. For now, pay attention to 
the top of the inspector—the Groups portion (Figure 55). 
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Figure 55: The Groups portion of the See Also & Classify inspector 
shows groups that may be a good home for the selected document. 

The groups listed here are the ones DEVONthink deems to have 
contents most similar to the document you’ve selected; the column to 
the left of the group names contains bars that indicate the approximate 
level of relevance for each group. The topmost group (that is, the one 
with the highest score) is selected by default. To move the document 
into this group, click Move To or press Control-C. 

If you think a different group is a better match, double-click that group 
name, or select it and then click Move To. And, if you think the docu-
ment belongs in more than one group, ⌘-click to select more than one 
and click Move To; DEVONthink puts a replicant of the document in 
each one. 
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Use the Classify and Classify To Commands 
If, after using the Classify feature of the See Also & Classify inspector 
for a while, you realize that you nearly always accept DEVONthink’s 
default choice, you can skip a step or two and have DEVONthink move 
a document—or more than one document—right into the highest-
scoring group. DEVONthink 2 used a command called Auto Classify to 
accomplish this; in DEVONthink 3, the command is Classify to “Group 
Name” (for single documents with only one recommended group), 
Classify to X groups (for documents that appear to belong in multiple 
groups), or simply Classify (if multiple documents are selected). 

To use whichever version of the Classify command, select one or more 
documents and then choose Data > Classify (with or without additional 
words in the command); this also appears on the Actions pop-up 
menu on the toolbar and the right-click/Control-click contextual 
menu. DEVONthink then examines each one and moves it to the 
location it deems best. (If it can’t find a suitable location, it leaves the 
document where it is and displays an error message in the Log panel.) 

Note: The Classify command works on each document individually; it 
doesn’t necessarily put all selected documents in the same group. 
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Using See Also 
Even after you’ve decided how best to group (or tag) documents and 
any desired replicants, you may still want to discover which other 
documents in your database have similar or related content. Select-
ing a document and looking in the bottom (Documents) section of the 
See Also & Classify inspector can help you find connections you 
weren’t previously aware of, or additional avenues to explore. 

For example, if I’m collecting data on some of my favorite films, I 
might run across a webpage about Steve Martin and put that in an 
Actors group. Months later, perhaps I’m trying to expand my collec-
tion of banjo music, so I select a webpage in a different group about 
Béla Fleck and look in the See Also & Classify inspector. Chances are, 
one of the documents shown will be that page about Steve Martin, 
who is also an accomplished banjo player. 

Like the Classify portion of the window, each item in the Documents 
section includes a Score bar that graphically shows how relevant 
DEVONthink believes each similar document is to the one you’ve 
selected. To display one of the documents, click its title. 

By the way, in case you were wondering…DEVONthink 2 actually used 
the term “See Also” in the user interface as a label for what is now 
the Documents section of the See Also & Classify inspector. In ver-
sion 3, that term survives only as a menu command. 

Duplicate and Replicate Documents 
In some cases you may want to make an exact copy of a document (a 
duplicate) or create a pointer that lets DEVONthink store just one 
copy, but display it in an additional location (a replicant). 

Make a Duplicate 
The most common reason to make a duplicate is that you want to 
modify a document but leave the original intact. (For example, you 
may want to use last year’s annual report as the basis for this year’s 
report, making additions and modifications as necessary.) 
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To duplicate a document, first select it in the item list (not in the 
sidebar) and then do any of the following: 

• Choose Data > Duplicate (⌘-D) to make a duplicate in the same 
location. 

• Hold down the Option key while dragging the document to another 
group. 

• From the Actions pop-up menu on the toolbar, choose Dupli-
cate To > Name of Group. 

• Right-click (or Control-click) the document, and choose Duplicate 
To > Name of Group from the contextual menu. 

• Choose Data > Move To (⌘-Control-M), hold down Option, and 
select a destination in the popover. 

Make a Replicant 
Replicants let you store a single document or group in several different 
places in your database without taking up extra disk space. (You 
cannot replicate a document across databases.) Because all replicants 
are pointers to the same underlying file, changes you make to any 
replicant are reflected in all of them. Replicants make sense for docu-
ments that don’t belong in just one group, but fit well into several (and 
for groups that seem to belong in multiple places). 

For example, if you have an ebook copy of The Hunchback of Notre 
Dame in your database, that might belong in your Paris group, your 
Fiction group, or your History group. With replicants, it can be in all 
three at the same time, and any annotations you make in any location 
are visible in the others too. 

To replicate a document or group, first select it in the item list (not in 
the sidebar) and then do any of the following: 

• Hold down the ⌘ and Option keys while dragging the item to 
another group. 

• From the Actions pop-up menu on the toolbar, choose Repli-
cate To > Name of Group. 
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• Right-click (or Control-click) the item, and choose Replicate To > 
Name of Group from the contextual menu. 

• Choose Data > Move To (⌘-Control-M), hold down ⌘-Option, and 
select a destination in the popover. 

Where’s My Replicant? 
You can tell a document or group is a replicant by the presence of the 

or icon next to its name—or its color, if you have that preference 
turned on—but how do you find the other replicants? 

To find out, select the document and choose Go > Next Instance (⌘-
Option-→) to jump to the next one, or Go > Previous Instance (⌘-
Option-←) to jump to the previous one. Or, choose Tools > Get Info 
(or look at the Info inspector); the locations of all the replicants 
appear in the Instances pop-up menu on the Information panel. 

Note: If your replicant appears with its name in red but no icon, 
that’s because in Settings/Preferences > General > Appearance the 
checkbox “Mark duplicates and replicants in color” is selected. 

For all practical purposes, having a replicant of a document in three 
groups is equivalent to having a single document with three tags 
applied. You may need to experiment with both approaches to see 
whether one or the other (or a combination) works best for you. 
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Stepping Stone: Get Stuff Out of Your Inbox(es) 
Do you have thousands of messages in your email inbox that you 
long ago gave up on sorting? The same phenomenon can easily 
happen to your DEVONthink inbox(es) if you collect text snippets, 
webpages, scanned PDFs, and other documents at a furious pace but 
can’t take the time to file each one as you go. Before you know it, 
you’re overwhelmed! 

The inbox is fine as a temporary holding area, but DEVONthink works 
much better when items are grouped (or tagged, or both) and moved 
out of the inbox. So my suggestion is to do the following once a week 
or so (more often if you have lots of data): 

✦ Begin by dragging documents from your global Inbox to a specific 
database (thus moving them to that database’s inbox). In most 
cases, you should be able to tell at a glance which documents 
belong in which database. (If a document belongs in more than 
one database, you can Option-drag it from your global Inbox to 
make a copy in one database, then drag it normally to the next 
one.) 

✦ For each database-specific inbox, work your way through the list 
of documents, dragging them one at a time to the group or tag 
that fits best or using the Classify features (see Classify Docu-
ments) for extra help. 

✦ If you have way too many documents and way too little time, try 
the lazy approach, which is extremely fast (but not necessarily 
as accurate). Assuming you already have a reasonably good group 
hierarchy, try the Data > Classify command on a handful of docu-
ments. Once you’re satisfied that most documents are going to 
logical groups, select everything in your inbox and choose Data > 
Classify to move as many of the documents as possible into 
appropriate groups. (Remember: if Classify can’t find a good home 
for a document, it leaves the document alone.) Repeat this 
process for each database. 

Tag Documents 

Tags function almost, but not quite, like groups (and in some cases 
groups and tags are interchangeable). Tags let you apply categories 
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to documents without moving them to another location, and a given 
document can have as many tags as you need. 

Any tags you’ve applied in the Finder stay with the document or folder 
when you import it in to DEVONthink; likewise, any tags you apply in 
DEVONthink turn into Finder tags when you export a document or 
group (or drag it from DEVONthink to the Finder). Furthermore, any 
tags you apply to indexed items appear as Finder tags on those items. 
DEVONthink also recognizes tags applied to email messages using 
MailTags (part of the MailSuite plugin for Apple Mail). 

The remainder of this topic discusses tagging within DEVONthink. 

Use the Tag Bar 
Although it’s possible to create tags by themselves (select a tag in the 
Tags list and choose Data > New > Tag), that’s a rather odd thing to 
do; normally you’ll create a tag by applying it to a document. There are 
numerous ways to do this, of which the easiest is usually as follows: 

1. Select a document. 

2. Make sure the tag bar appears at the bottom of the window or view/ 
edit pane. If not, choose View > Show Tags (⌘-Control-Option-T). 

3. To make a new tag and apply it to the current document, click in the 
tag bar and start typing. 

Tip: For faster access, you can choose Edit > Tags (or press Control-
Return) to display the tag bar if it isn’t already visible and place the 
insertion point in it so you can begin typing immediately. This even 
works if the view/edit pane is hidden (meaning the tag bar can’t be 
displayed); if the inspector is visible, DEVONthink shows the Info 
inspector and places the insertion point in the Tags field, and if the 
inspector is also hidden, an Info popover appears instead. 

4. When you’re finished typing the name you want the tag to have, 
press Tab. 

The new tag appears in a blue rectangle, known as a token. You can 
repeat this process for as many tags as you want the document to have. 
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Use Autocompletion 
Once you’ve created some tags, DEVONthink uses autocompletion 
to help you apply them. That is, as you’re typing a tag name, DEVON-
think looks for matches in existing tag names (within the current 
database only). If it finds any, it displays them in a pop-up menu. To 
accept one of these suggestions, select it (using the arrow keys or the 
mouse) and press Tab or Return; if none of them is what you want, 
simply keep typing normally. 

Use Pop-up Tag Menus 
You may notice that if you hover over any tag in the tag bar, it displays 
a small arrow on the right side, indicating that it’s also a pop-up menu. 
Click the arrow to reveal the following commands: 

• Reveal Tag: Choose Reveal Tags to show the Tags list (described 
ahead) and highlight the selected tag in the main view. 

• Remove Tag: This command removes the tag from (only) the 
selected document. 

Tip: You can also remove a tag by selecting it and pressing Delete. 

• Related Tags: Any additional tags that DEVONthink’s artificial 
intelligence judges as potentially applicable to this document ap-
pear under Related Tags. (Tags that are dimmed are related, but 
already applied to the document.) To add one of these tags, select 
its name. 

Work with Group Tags 
If you enable groups to be used as tags (see Understand Groups and 
Tags), the tag bar shows not only ordinary tags  but also 
group tags representing the name of the tag group contain-
ing the document (if any—this doesn’t apply to documents in an inbox 
or at the top level of your database), as well as each of its parent tag 
groups. 

These tags behave much like ordinary tags. Use the pop-up menu to 
reveal the group in the current view, to remove the current group tag, 
or to apply related tags. (If you remove a group tag, DEVONthink 
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moves the document out of the selected group; if you remove all the 
group tags, the document moves to the database’s inbox.) 

Use the Tags List 
The Globals portion of the Navigate sidebar has a hierarchical Tags list, 
which contains a list of all your (non-group) tags, organized by data-
base. Click any of these tags to display all the documents with that tag. 

Note: If you prefer, you can go to Settings/Preferences > General > 
Interface and uncheck “Unify tags” in the Sidebar section; this causes 
the tags to disappear from the Globals list and appear in the item list 
for the database. 

You can do the following in the Tags list: 

• Rename a tag: Select it, then click its name again to make it ed-
itable, and type a new name. The new name applies to all docu-
ments with that tag. 

• Assign a tag to a document: If you drag a document to a tag in 
the Tags list, DEVONthink assigns that tag to the document. 

• Move a tag: Tags can contain other tags, such that applying a 
“child” tag to a document also applies all its “parent” tags. In the 
Tags list, you can drag and drop tags just as you would do for 
groups to rearrange their hierarchical structure. 

Apply Image Tags Automatically 
DEVONthink 3 can automatically tag images by analyzing them using 
Apple’s machine learning (the same technology used in Photos) to 
make educated guesses about their content. To try this, select an image 
and choose Data > Tags > Add Tags to Images. (This command is also 
available in smart rules.) Although you might have better luck, my 
results with this feature have been so-so. For example, I tried it on a 
photo I took in Redwoods National Forest in northern California and 
got the tag “rainforest.” A photo of a nearby roadside attraction, called 
the One Log House, got a tag of “motel.” 
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Tip: You convert certain kinds of metadata to tags using the com-
mands on the Data > Tags submenu. This can be used for hashtags 
(like #apple) found in the document body, PDF keywords and proper-
ties (which you can see on the Properties tab of the Document 
inspector), and geolocation. 

Using Labels and Flags 
In addition to groups and tags, DEVONthink offers two other ways to 
identify documents with shared characteristics: labels, each of which 
has a user-definable color and name; and a flag, which is similar to a 
label and calls attention to especially important documents. You have 
seven labels to choose from. Any document can have at most one 
label; applying a different label removes the previous one. 

Labels and flags are useful for marking items as needing further 
attention, and unlike tags or groups, they give you an instant visual 
representation of a document’s category. However, they’re much less 
flexible than tags, so I recommend using tags instead when feasible. 

To apply a label, select one or more items in DEVONthink and choose 
Data > Label > Label Name (or use the corresponding controls on the 
Actions pop-up menu on the toolbar or at the bottom of the 
sidebar, the right-click/Control-click contextual menu, or the Info 
inspector). To remove a label without applying a new one, choose 
None from this menu. To change the name or color of any label, go to 
Settings/Preferences > Colors > Labels. Be aware that changing the 
name or color of a label affects all the documents and groups that 
already have that label. 

To apply a flag, select one or more items and choose Data > Mark > 
As Flagged (⌘-Option-K). Again, there are corresponding commands 
in the usual places—and a flag icon in the Info inspector you can click 
to toggle the flag on  or off . To remove the flag, choose Data > 
Mark > As Unflagged (⌘-Option-K again). Flagged items have a small 
flag icon next to them in the item list; if the icon isn’t visible, 
choose View > List Columns > Flag. 

You can search for documents with a flag or a particular label (see Do 
an Advanced Search) or use labels or flags as part of a smart group 
(see Use Smart Groups). 
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Work with Metadata 

Numerous document attributes I’ve already discussed (such as title, 
tags, labels, flags, read/unread status, “Exclude from” settings, date 
added, and so on) can be considered metadata—that is, information 
about the document as opposed to the contents of the document. 

DEVONthink 3 adds even more kinds of metadata than earlier versions 
offered, and the Pro and Server editions go a step further by letting you 
create your own custom metadata types. The easiest way to see most 
metadata settings in one place is to select a document and display the 
Info inspector (Figure 56), with the Generic tab selected. Let’s take a 
quick spin through the three major new categories of metadata. 

Figure 56: Add or edit metadata in the Info inspector. 
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Geolocation Data 
Any document can have an associated geographical location. In fact, 
most modern smartphones, tablets, and cameras add this metadata 
automatically using GPS or Wi-Fi location data. If a photo or other 
document already has geolocation data, it appears in the Geolocation 
field in a human-readable form (such as “Los Angeles, CA, USA”)— 
even if, behind the scenes, your camera stored precise latitude and 
longitude. 

You can manually edit the geolocation data for any document, or add 
your own for documents that don’t already have it, by typing in the 
Geolocation field. You might do this, for example, to indicate where 
you were when you created a note, or the location that a book or article 
refers to. 

DEVONthink 3 also has a couple of other neat geolocation tricks: 

• To display a map showing pins for each document with geolocation 
data in the current selection in the Navigate sidebar, choose Tools > 
Filter > Maps. The map (Figure 57) appears at the bottom of the 
sidebar. 

Figure 57: This map has pins for each document with stored geolo-
cation data in the current view. 
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• To add tags based on geolocation data, select one or more docu-
ments and choose Data > Tags > Convert Geolocation to Tags. 
DEVONthink creates a tag for each portion of the geolocation data 
(as separated by commas). For example, if the geolocation data is 
“Los Angeles, CA, USA,” you’ll get three tags: “Los Angeles,” “CA,” 
and “USA.” Note that this adds tags but does not remove the con-
tents of the Geolocation field. 

Star Ratings 
You’re familiar with star ratings from apps such as Music, TV, and the 
App Store. DEVONthink 3 offers them too, allowing you to categorize 
documents according to how much you like them. Most of us would 
use this for only a subset of our documents, such as a collection of 
photos, ebooks, or articles. Rating documents lets you sort, search, and 
filter them based on how many stars they have. 

To assign, change, or remove a star rating, select a document and 
choose a number of stars (which can be zero) from the Data > Rating 
submenu (or from comparable locations on the Actions pop-up 
menu on the toolbar or the right-click/Control-click contextual menu); 
you can also change star ratings on the Info inspector. 

Custom Metadata 
Users of DEVONthink Pro or Server have even more options when it 
comes to metadata: you can use any of numerous additional prede-
fined fields, or create new ones of your own, and apply this custom 
metadata to any document. For example, if you store ebooks in your 
DEVONthink database, you might want to track author names or 
ISBNs; or if you store recipes, you might want metadata for the num-
ber of servings or type of dish (appetizer, main course, salad, etc.). 

Before you can apply custom metadata, you must tell DEVONthink 
which fields you want to use and how they should be configured. To do 
this: 

1. Go to Settings/Preferences > Data (Figure 58). 
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Figure 58: Configure custom metadata fields on the Data preference 
pane. 

2. If you want to use any of the predefined custom fields, simply select 
the checkboxes next to their names. (If no predefined custom fields 
are present, choose Add Default Templates from the Action 
pop-up menu to restore them.) 

3. To add a custom field of your own: 

a. Click the plus button, type a name for your custom field, and 
press Return. 

b. Choose a data type from the Type pop-up menu. (The options 
available are identical to those for sheets; refer back to Sheet.) In 
some cases, you’ll need to specify additional characteristics—for 
example, numbers and dates can have different formats, and the 
Set option lets you specify a list of choices for each field in that 
column (which appear as their own pop-up menu). 

4. To add another custom field, repeat step 3. Continue for as many 
fields as you want to add. 
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Once you’ve done this, you can apply your custom metadata to any 
document by visiting the Custom tab of its Info inspector (Figure 59), 
where the extra fields appear. 

Figure 59: Apply custom metadata to documents on the Custom tab 
of the Info inspector. 

You can also add your custom fields to table views by choosing View > 
List Columns > Field Name, and you can sort on these fields by choos-
ing View > Sort > by Field Name. 

Scan Barcodes 
If an image—or any of the first four pages of a PDF—contains a 
barcode, DEVONthink can sometimes decode it, if it’s sufficiently 
prominent. Select the image and choose Data > Tags > Scan Bar-
codes; the command is also available in smart rules. If DEVONthink is 
able to find and analyze the barcode, its value appears in a Barcode 
custom metadata field. 
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Make a Metadata Table 
If you’d like to view all the metadata for a set of documents in one 
place, you can. Select the documents in question and choose Tools > 
Create Metadata Overview. DEVONthink creates a new sheet (stored 
in your default location) with each type of metadata as a column and 
each document as a row. 

Work with Highlights 

DEVONthink 3, like most word processors and PDF readers, permits 
you to apply highlighting (in various bright shades) to selected por-
tions of text in a document, in much the way you might use a high-
lighter pen to mark up a book or magazine. 

You can apply highlighting in any type of document that supports 
formatted text, including PDF, rich text, HTML, and formatted notes. 
To do so, start by selecting some text. Click the Show Editing Bar 
icon on the navigation bar and then click the highlight icon on the 
editing bar or choose Format > Highlight (⌘-Shift-L). To remove 
highlighting from the selected text, repeat that action. You can also 
click and hold the highlight icon or choose Format > Highlight 
Color to display a menu from which you can select a different highlight 
color. 

If you’d like to make a list of all the highlighted passages in one or 
more documents, select those documents and choose Tools > Summa-
rize Highlights > As Rich Text, Tools > Summarize Highlights > As 
Markdown, or Tools > Summarize Highlights > As Sheet (depending 
on the format you prefer). You can also choose Insert Summary from 
the Annotations pop-up menu in the Annotations & Reminders inspec-
tor. DEVONthink creates a new document with each highlighted 
passage (and its line number) listed, grouped by document name. 

Note: Although you can apply highlighting in many kinds of docu-
ments, the Summarize Highlights feature works only on PDF and rich 
text (RTF) documents. 
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Work with Item Links and WikiLinks 

Webpages contain clickable links to other webpages (often represented 
by blue, underlined text). Other kinds of documents—including email 
messages and PDF files—likewise can contain links to webpages. 
DEVONthink documents, too, can contain links to webpages, but they 
can also contain links to other items in your database, which is the 
sort of link I’m concerned with here. DEVONthink refers to these as 
item links. 

Tip: Besides creating links to other documents in DEVONthink, you 
can also drag an event from Calendar, or an email message from 
Mail, into a rich text document to create a link to the event or email 
message. 

Like webpage links, item links appear in blue underline and let you 
navigate quickly to related content. Clicking a link replaces the current 
view with the linked document—after prompting you to save, if neces-
sary. To return to the previous document, click the Go Back icon on 
the navigation bar. You can ⌘-click a link to open it in a separate tab. 

A special kind of item link called a WikiLink lets you link directly to a 
particular document by name, creating the document if it doesn’t 
already exist. 

Note: Most document types can contain links to other DEVONthink 
documents (including WikiLinks), and the links can point to any 
document, group, or tag. 

Create a Standard Item Link 
You can create a link to another DEVONthink document in any of 
several ways. 

Note: Not all methods work in all document types; experiment to 
find what works best in your situation. 
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Your options are: 

• Start from the link’s source: Select some text in a rich text 
document, right-click (or Control-click) it, and choose Link to > 
Destination (that is, any group, tag, or document, in any open 
database) from the contextual menu. The text you selected becomes 
a clickable link to the destination you chose. 

• Start from the link’s destination: Select a document in your 
database and choose Edit > Copy Item Link (⌘-Control-Option-C) 
to put a link to that document on the clipboard. Then place your 
insertion point in any rich text document and choose Edit > Paste 
(⌘-V) to paste a link to the first document at that location. 

• Drag and drop: Double-click a rich text document to open it in 
its own window. Then ⌘-Option-drag a document from elsewhere 
in your database and drop it at the spot where you want the link to 
appear. The link appears as the linked file’s name. 

Documents containing links to other documents display an outgoing 
link icon in item lists; documents with links from other documents 
display an incoming link icon in item lists. Behind the scenes, 
DEVONthink calculates the number of incoming and outgoing links in 
each document, which can then be referenced in searches, smart 
groups, and list sorting. 

Tip: You can change the destination of a link (whether a standard 
link or WikiLink) by choosing Format > Edit Link, or remove it by 
choosing Format > Remove Link. (Both commands are also found on 
the right-click/Control-click contextual menu.) 

If the name of a document changes, you might want to update links to 
that document in other documents so the name matches. To do this, 
select the document(s) containing the link(s) to documents whose 
names have changed and choose Tools > Item Links > Update Names 
of Item Links. If you always want link names to update themselves 
automatically when the documents they link to are renamed, go to 
Settings/Preferences > WikiLinks and select “Update name of item 
links automatically.” 
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Create a WikiLink 
To create a link to another document or group by name—a WikiLink— 
type the other item’s exact name in a rich text document, select it, and 
choose Format > Make Link (⌘-Shift-M). The Make Link command is 
also found on the right-click/Control-click contextual menu. The text 
becomes blue and underlined. Clicking it opens the linked document 
or group. 

Tip: WikiLinks work with rich text documents. Plain text and Mark-
down documents are also supported if you enable automatic Wiki-
Links, described a few paragraphs ahead. 

If you select some text and choose Format > Make Link but there isn’t 
already a document or group with that exact name, DEVONthink 
creates a new document with that name (in the same location as the 
document you’re currently editing) the first time you click the link, 
using a special template. 

To adjust the text and variables used in this template, go to DEVON-
think > Preferences > WikiLinks (Figure 60). Make your desired 
changes in the Template field at the bottom of the window. The tem-
plate can include placeholders; refer back to Using Placeholders. 
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Figure 60: Adjust preferences for WikiLink behavior in the WikiLinks 
preference pane. 

If you use WikiLinks often, you can have DEVONthink create them as 
you work in a much more automatic manner. In Settings/Preferences > 
WikiLinks, check the Automatic box next to WikiLinks to turn on this 
feature. Then select one or more of the following checkboxes: 

• MashedWords: DEVONthink creates links automatically only
when you type a string with no spaces and a capital letter in the
middle (sometimes called CamelCase or an InterCap). For example,
type AppleScript and that word becomes a WikiLink to a (new or
existing) document named AppleScript.

• Square Brackets [[…]]: DEVONthink creates links automatically
only when you type a string surrounded by double square brackets,
like this: [[lorem ipsum]]. (This convention comes from Wikipedia.)

Note: MashedWords and double square brackets can be used at the 
same time. 

• Names and Aliases: With this (default) setting, DEVONthink
creates a link to any document in your database as soon as you
type its full and exact name. DEVONthink also creates links auto-
matically to any string of text that you’ve defined as an alias for a
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document. (To create an alias, which in DEVONthink is simply an 
alternative name, select a document and choose Tools > Get Info, 
⌘-Shift-I, or use the Info inspector. Type one or more aliases, 
separated by commas or semicolons, in the Aliases field. To change 
the separator options, see the Aliases Separators item below.) 

Note: If your database contains more than one document with the 
same name, DEVONthink might pick the wrong one to link to. You 
can’t force a correct automatic WikiLink, though you can manually 
Create a Standard Item Link instead. 

Tip: To toggle automatic WikiLinks in the current document, regard-
less of how your preferences are set, open it in a separate window 
and choose Format > Wiki Linking. 

DEVONthink 3 offers two preferences for working with automatic 
WikiLinks: 

• Item type: By default, you can create automatic WikiLinks to 
either documents or groups (including tags). To change the behav-
ior so that automatic links are created only to documents or only to 
groups, select the “Only documents” or “Only groups” radio button, 
respectively. To change back to the default, select “All items.” 

• Case sensitivity: By default, the names of documents in automat-
ic links must match exactly, including case. To make linking case-
insensitive (so the text “apple” would link to a document named 
Apple, for example), select “Case insensitive linking.” 

Finally, there are three miscellaneous preferences for working with 
WikiLinks (and item links): 

• Open new documents in separate windows: You can adjust 
DEVONthink’s behavior when you click a WikiLink. If this box is 
checked, DEVONthink opens a new window the first time you click 
a WikiLink for a document that didn’t previously exist. If it’s 
unchecked, as it is by default, the new document opens in the 
current view, replacing the existing document. 
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• Update name of item links automatically: When this is 
checked and the name of a document changes, any links to that 
document in other documents change to match. 

• Aliases Separators: As I mentioned about a page back, an alias is 
an alternative name for a document created in the Info inspector. 
You can type multiple aliases separated by commas or semicolons, 
by default, but if you want other separator characters, type them 
here. 

If you want to convert WikiLinks to standard item links, select one or 
more documents and choose Tools > Item Links > Convert WikiLinks 
to Item Links. 

Deep Linking with Selection Links and Annotation Links 
New in DEVONthink 3.9 is the capability to create and use deep links, 
meaning links to specific spots within PDF documents. You can use a 
standard item link or WikiLink to link to a PDF, but if you want to link 
to a particular paragraph within that document, a deep link is what 
you need. 

To create a deep link to a specific piece of text within a PDF, select 
the text, right-click or Control-click it, and choose Copy Selection Link 
from the contextual menu. You can then paste that link into another 
document (or even another app on your Mac). When you click the 
link, DEVONthink not only displays the document in question but also 
scrolls to, and selects, the linked text. 

Similarly, in a PDF with annotations, you can right-click or Control-
click an annotation and choose Copy Annotation Link from the con-
textual menu to get a link to that annotation. 

Move Data Between Databases 

Just as you can drag items from one group to another, you can drag 
items from one database to another. (And note: this really does move 
items, deleting them from one database and adding them to the other, 
although you can also copy items if you prefer, as I describe ahead.) 
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To move one or more selected items to another database, do any of the 
following: 

• With the Navigate sidebar visible (View > Navigate), drag the 
item(s) to the location of your choice in the other database. This 
moves them from the current database to the other database’s 
inbox. 

• Assuming you have enough room on your screen, open a new 
window for the second database (choose File > New Window > 
Name of Other Database) and then drag the item(s) from one 
window into the desired location in the other. 

Note: With either of the preceding procedures, you can hold down 
Option while dragging to copy the items instead of moving them. 

• Choose Move To > Destination in Other Database from the Actions 
pop-up menu on the toolbar or at the bottom of the sidebar, or 

the right-click/Control-click contextual menu. (To copy rather than 
move, use the Duplicate To submenu instead.) 

Split and Merge Documents 

From time to time you may encounter a document divided into sec-
tions that cover different topics—say, an academic paper or a long 
ebook—and realize that the data would serve you better if it were 
stored in DEVONthink as multiple documents, each containing part 
of the data. The reverse may also be true: you may have a bunch of 
snippets or fragments that make more sense in a single document. If 
either case applies to you, you can use DEVONthink commands to 
quickly split or merge documents. 

Split a Document 
To split a document, put the insertion point at the location where you 
want to divide the document in two and choose Tools > Split Docu-
ment. DEVONthink instantly creates two documents—one with the 
original name that contains the material before the insertion point, 
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and another with the original name plus 2 and the material after the 
insertion point. 

Note: Splitting works with plain and rich text documents, Markdown 
documents, and PDFs. 

Tip: After splitting a document, a quick way to give the second 
portion a more useful name is to select a few words of text near the 
top, right-click (Control-click) the selection, and choose Set Name As 
from the contextual menu. 

Merge Documents 
To merge two or more documents, select them and choose Tools > 
Merge X Documents, or use the Merge X Documents command on the 
Actions pop-up menu on the toolbar or the right-click/Control-
click contextual menu. DEVONthink creates a new document contain-
ing the contents of all the selected documents (and a name such as “5 
merged documents”) but normally does not delete the originals. If you 
want to delete the originals, hold down Option and choose Tools > 
Merge & Delete X Documents. 

You can create a merged document from almost any type of file 
(including graphics, plain and rich text, Markdown, PDF, sheets, and 
webpages). DEVONthink saves the resulting document as a PDF if the 
constituent documents include only PDFs, PostScript files, and/or 
images. If any of the merged documents is of a different type, the result 
is a rich text document. 

Note: Depending on what kinds of documents you merge, the 
merged document may or may not look quite like the originals, 
because some documents—especially webpages—contain special 
formatting that doesn’t translate well into rich text form. 
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Find Your Information 
One of the biggest reasons to store your stuff in DEVONthink (as 
opposed to, say, the Finder) is its fast, smart, and flexible filtering and 
searching. This chapter describes ways to find things in DEVONthink, 
from simple to complex, including a look at how to Use Smart Groups. 
It also discusses how to Search Using the Concordance, a specialized 
way of searching based on the frequency with which words appear in 
your database. 

Use Filters 

Early in this book, I talked about how to sort your information in List 
and Column views (see View as List, the sidebar A Word About Sort 
Order, and View as Columns). If you have hundreds or thousands of 
items in a single group or inbox, however, mere sorting might not be 
sufficient to pick out a particular item quickly. DEVONthink 3 adds 
filters, which provide various ways of narrowing down the items shown 
in a given view. (Unlike searching, which can extend across groups or 
even databases, filtering applies only to the list of documents currently 
shown in the item list, which is in turn dependent on what’s selected in 
the Navigate sidebar or on your search results. So, you can use filters 
to further narrow down a search, but not as a substitute for searching.) 

Three filter categories exist: info (which encompasses dates and 
marks—flag, label, read/unread state, and locked/unlocked state), 
tags, and location. You can display these filters at the bottom of the 
Navigate sidebar by choosing Tools > Filters > Info (Control-I), 
Tools > Filters > Tags (Control-T), or Tools > Filters > Maps (Control-
G)—or click the Info , Tags , or Maps icon at the bottom of the 
sidebar. Figure 61 shows each of the filter views. 
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Figure 61: Filters, from left to right: info, tags, and location. 

Here’s how to filter your view with each category: 

• Dates: From the pop-up menu at the top of the info filter, choose 
Any Date (the default), Date Added, Date Created, Date Modified, 
Date Opened, or Date Due. Then click a date on the calendar or drag 
to select a date range. DEVONthink hides any documents in the 
current view that are outside your specified date parameters. You 
can also choose Indexed or Imported from the File Location pop-up 
menu to filter by those locations, or Any to show all locations. 

• Marks: Click the flag , read , or unlocked icon to show only 
flagged, unread, or locked documents, respectively, in the current 
view. Or click the label icon and choose a label from the pop-
up menu to display only items with that label. 

• Tags: Click a tag to display only items in the current view that 
include that tag. To narrow down further, continue clicking to add 
more tags. To remove a single tag from the filter, delete it from the 
information bar; to remove all tags from the filter, click Reset on 
information bar. 

• Maps: Click a pin on the map to display only the items (such as 
photos) with that geolocation data. 

In all these cases, closing the Filters pane removes any filters from the 
item list, showing its full contents again. 
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Perform a Simple Search 

Most searches in DEVONthink are simple and straightforward—and 
the process couldn’t be easier. Type your search term into the search 
field on the toolbar, and DEVONthink almost instantly returns match-
ing documents from anywhere in the current database—with default 
settings, you need not even press Return (Figure 62). 

Figure 62: Type a term in the search box in the upper-right corner 
for a super-fast search. 

By default, results are ranked by relevance, and each item has a col-
ored bar that graphically indicates its score. Any occurrences of your 
search term are bolded in the results list and highlighted in the docu-
ments themselves (partial-word matches aren’t highlighted, however). 

Search Syntax 
Searches in DEVONthink are case-insensitive (cat matches Cat and 
vice versa). You can also use quotation marks to enclose phrases, 
wildcards (such as ? to match any single character and * to match 
any sequence of characters), Boolean operators (such as AND, OR, and 
NOT), parentheses to group items, and proximity terms (such as NEAR, 
BEFORE, and AFTER). See DEVONthink’s documentation for details. 
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Tip: If you Option-click a word in a document, DEVONthink automati-
cally performs a search for that term. 

Refine a Search with Search Options 

If a simple search doesn’t return the results you’re looking for (or 
returns far too many results)—or if you want to change the manner in 
which results are returned—you can click the magnifying glass in 
the search field to display a pop-up menu with additional search 
options. Choose one of these to refine your search—and note that your 
choice remains in effect for future searches until you change it (even if 
you quit and reopen DEVONthink), so you may want to reset it right 
after use to avoid future confusion. 

The first group of options, under the “Options” label, affects the way 
results are returned as you type: 

• Live while typing: When this is selected, as it is by default, 
DEVONthink starts returning results immediately as you type. If 
you deselect this, you must press Return or Enter to complete your 
search. 

• Partial matches while typing: Keep this option selected to have 
DEVONthink return items containing words beginning with what-
ever letters you’ve typed—even without pressing Return or Enter. 

When “Partial matches while typing” is unchecked, you must press 
Return or Enter to perform a search. And, even when it is checked, 
you can press Return or Enter to search for whole words—not only 
those beginning with whatever you typed. For example, if “Partial 
matches while typing” is checked and you enter app in the search 
field, documents containing strings like “approval” and “applica-
tion” may appear as potential matches—as though you’d included a 
wildcard asterisk at the end of the search term: app*. But when you 
press Return or Enter, only those that contain “app” as a full word 
remain in the list. 
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The second (unlabeled) group of options affects how matches occur: 

• Ignore Diacritics: With this option selected, DEVONthink 
ignores all diacritical marks (such as umlauts and accents) when 
searching, so, for instance, a search for creme brulee with this 
option enabled will match a document containing “crème brûlée”, 
and vice versa. 

• Fuzzy: With Fuzzy on, DEVONthink looks for alternative spellings 
with similar sounds (although I’ve rarely found this option to 
produce any useful effects). 

Options in the third group, under the “Search in” label, affect where 
DEVONthink searches and appear only after you have begun your 
search: 

• All Databases: Searches in all open databases 

• Inboxes: Searches only in your inboxes (including the global 
Inbox) 

• The current database or group: Searches in that location 

Tip: In lieu of choosing your search scope from a pop-up menu, you 
can type a shortcut in the search field—the letter s followed by a 
colon and one of the following words: all, database, databases, inbox 
(that, is the global Inbox), inboxes, tags, trash, selection, or a 
database name. For example, the search term robots s:databases 
would search for the word “robots” in all databases. 

At the bottom, there may be additional items: 

• Recent Searches: If you’ve performed searches recently, they 
appear here so you can perform them again quickly. However, note 
that (regardless of your settings in the first group of options), recent 
searches appear here only if you press Return or Enter after typing 
your search term. 

• Clear Entries: To remove recent searches from the pop-up menu, 
choose this command. 
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Use Search Prefixes 

Ordinarily, DEVONthink searches look everywhere—in documents’ 
titles, contents, and metadata. But suppose you want to search only in 
the title or only in the tags? For more specific searches like these, 
DEVONthink 3 introduces search prefixes, which are simply words, 
followed by a colon, that you type before a term in the search field that 
restrict the search in some way. (Spotlight has offered a similar option 
for many years.) 

For example, if you want to search for “cat” but only if it appears in a 
document’s name, you could enter name:cat in the search field. If you 
want to search for “cat” only when used as a tag, you can enter 
tags:cat. There are dozens of these search prefixes, which cover any 
type of metadata as well as various search scopes. They’re all detailed 
in the DEVONthink documentation—look for the “Search Prefixes” 
topic in the appendix. That topic also talks about how you can use 
operators besides the colon character (which means “equals,” more or 
less) to perform other types of comparisons (“earlier than,” ”is not,” 
“ends with,” “contains,” and so on). 

Although search prefixes are quite powerful, they’re not terribly user-
friendly, and you can perform most of the searches they permit in a 
simpler way with an advanced search, as I describe next. 

Do an Advanced Search 

Whether or not you modify your search criteria or use search prefixes 
as described above, you can extend a search with much more elaborate 
options than the search field offers alone. To do this, use the bar that 
appears below the path bar when you start searching (Figure 63). 
Although the DEVONthink documentation doesn’t give it an official 
name, I’ll call it the search scope bar, since it displays controls allowing 
you to change the scope of your search. 
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Figure 63: The search scope bar appears below the path bar after 
you enter a search term. 

One thing you can do immediately, if you like, is restrict the scope of 
the search to top-level items within the currently selected group, 
ignoring the contents of any subgroups. To do this, check the “Exclude 
Subgroups” box. 

Near the right side of the search scope bar is an Advanced button. Click 
that to expand the view with even more options, as shown in Figure 
64. 

Figure 64: The search scope bar after you’ve clicked Advanced. 

With the advanced controls showing, you’re now ready to perform an 
advanced search: 

1. Choose a search scope by clicking All Databases, the name of the 
current database, or Inboxes on the search scope bar. 

2. Enter your first search criterion. Start by selecting a predicate (that 
is, a search context) from the pop-up menu to the left of the word 
“matches.” You have dozens of choices, such as Content, Recipient 
(for email messages), Composer (for music), width (for graphics), 
word count, and date modified, not to mention any custom metada-
ta you’ve created. 

3. Once you’ve selected a predicate, enter any additional requested 
information. The exact options depend on the predicate. For exam-
ple, you can choose [Content] matches some text, [Height] [Is 
Greater Than] number of pixels, or [Date Added] [Is] [This Year]. 
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Note: As you make changes to your query using the advanced search 
tools, DEVONthink also updates the search field to reflect the raw 
syntax behind your search, so you can see how the search functions 
behind the scenes. Similarly, if you manually make changes to the 
contents of the search field, the advanced search controls change to 
match. 

4. Optionally, to add more criteria, click the plus button to the 
right of the first criterion and repeat steps 2 and 3 as necessary. 

When you have two or more criteria, you must tell DEVONthink 
whether to look for items that match all of them (choose All—the 
default—from the pop-up menu next to “of the following are true”) 
or items that match at least one of them (choose Any). 

You can also have compound predicates, which let you nest Any/All 
criteria so you can search using expressions like “(A or B) and C” or 
“A or (B and C).” 

To turn an existing single predicate into a compound predicate, 
hold down the Option key and click the ellipsis button to the 
right of any criterion (where the plus button usually is); then 
choose Any or All from the new pop-up menu that appears below 
the existing criterion and fill in the details for the additional compo-
nent just as in steps 2 and 3. 

Repeat as needed to create the set of conditions you’re looking for. 

To cancel a search, click the X icon in the search field. 

DEVONthink returns live search results as you add and modify your 
search criteria, so there’s nothing further to do unless you want to save 
your advanced search as a smart group; see Save an Advanced Search. 

Use Smart Groups 

Suppose you construct an elaborate search that returns just the docu-
ments you’re looking for, and you suspect you may have to search 
again later with the same criteria. Or, say you always want quick access 
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to documents having some set of attributes, even though their tags, 
groups, and other metadata may change. In cases like these, you might 
be able to use a smart group, a type of saved search that appears much 
like a regular group—but whose contents change dynamically along 
with the contents of your database. You can create a smart group in 
two ways: save an advanced search or use the Smart Group Editor (a 
method that provides more flexibility). 

Note: DEVONthink includes a few preinstalled global smart groups, 
listed under Smart Groups in the sidebar: Today and Yesterday (for 
items added or modified on those days) and Unread (for all unread 
documents). Each new database also contains, by default, smart 
groups for All Images, All PDF Documents, and Duplicates. To add 
any of numerous other prebuilt smart groups, choose one from the 
Data > New from Template > Smart Groups submenu. 

Save an Advanced Search 
After performing an advanced search (as described just previously), 
click the Save button just above the search criteria. Type a name for the 
saved search and click OK. A new smart group with a special gear 
icon appears in your database. 

Note: If your search includes all databases, the smart group icon 
appears in your sidebar under Smart Groups. Otherwise, it appears at 
your current location (or at the top level of the database, if you’re not 
in any particular group). 

Use the Smart Group Editor 
If you don’t want to start with an advanced search, you can build a 
smart group from scratch; doing so gives you a few extra options over 
an advanced search. If you’re familiar with creating smart folders in 
the Finder, smart playlists in Music, or smart mailboxes in Mail, you’ll 
be at home in the Smart Group Editor. 

To create a smart group with this method, follow these steps: 

1. Choose Data > New > Smart Group. 
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2. In the Smart Group Editor (Figure 65), enter a name for your 
smart group. 

Figure 65: Use the Smart Group Editor to construct more elaborate 
smart groups. 

3. Choose a search location from the “Search in” pop-up menu and 
optionally check Ignore Diacritics and/or Fuzzy—all these options 
work just as for other types of searches. 

4. Optionally select Highlight Occurrences to highlight matching 
terms in the documents themselves, just as during a regular search. 

5. Enter your search criteria just as in an advanced search. 

6. Click OK. 

DEVONthink saves your new smart group—under Smart Groups in the 
sidebar if your search includes multiple databases, or at your current 
location in the database otherwise. 

To display the smart group’s contents, click it, or click the disclosure 
arrow next to it (depending on the view). 

Note: If your smart group involves date criteria, it will have a special 
clock icon. 
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Tip: Do you use DEVONthink to store searchable PDFs of scanned 
documents? If so, you might appreciate having a smart group that 
identifies all the PDFs in your database without a text layer, so that 
you know which ones you still need to convert. To add such a group, 
choose Data > New from Template > Smart Groups > PDFs (not 
searchable). 

Modify or Delete a Smart Group 
To edit an existing smart group, double-click its name. The Smart 
Group Editor appears; make any changes you want and then click OK. 

To delete a smart group from the sidebar, right-click (or Control-click) 
it and choose Remove from the contextual menu. To delete a smart 
group from a location other than the sidebar, select it and press Delete. 

Search Within a Document 

The kinds of search we’ve covered so far are mainly intended to help 
you find matching documents. (And, as we’ve seen, they can also 
highlight search terms within matched documents.) But if you simply 
want to find something within a document—or if you want to do a find-
and-replace operation—there’s a new interface to do so in DEVON-
think 3: the Search inspector. 

To use the Search inspector, make sure a document is selected or open, 
and then press ⌘-F or choose Edit > Find > Find. (You can also choose 
Tools > Inspectors > Search (Control-U), or click the Search icon at 
the top of the inspector.) The Search inspector (Figure 66) appears. 
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Figure 66: The Search inspector lets you do simple searches and 
replacements within the selected document. 

To use the Search inspector, type a term into the search field and press 
Return or Enter—there’s no live searching as in the regular search 
field. (There’s also just one search option: Ignore Case, which is 
checked by default.) Matches appear in boldface in the list below; 
they’re also highlighted in the view/edit pane. You can also select an 
item in the list to jump right to it, or use the forward  and back 
arrow buttons to navigate. 

There are two search options: 

• Ignore Case: Selected by default, this makes searching case-
insensitive. 

• Enable Operators & Wildcards: Deselected by default; if you 
select it, the Search inspector lets you use operators such as AND, OR, 
NOT, and NEAR, and wildcards such as *, when searching within 
documents. See Searching for details. 
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To do a find-and-replace, enter replacement text in the Replace field 
and click Replace (for just the current or next occurrence), All (to 
replace all occurrences), or In Selection (to replace all occurrences 
within the currently selected text). 

Search Using the Concordance 

The final method of searching—available only in Pro and Server 
editions of DEVONthink—is to use the Concordance, which provides a 
list of all the words in the current selection, along with their usage 
frequency and other statistics. 

To use the Concordance in a single document, select it and choose 
Tools > Inspectors > Concordance > List (Control-8) or click the 
Concordance icon in the inspector. The concordance inspector ap-
pears on the right side of the window (Figure 67) with every word 
listed by frequency (number of occurrences). 

Figure 67: The Concordance inspector (shown here in List mode) 
shows all the words in your document, sorted by frequency. 
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You can click a column header to sort by that criterion, and click again 
to reverse the sort order. You can also drag to rearrange the columns’ 
order. The columns are: 

• Frequency: The number of times this word appears in the docu-
ment. 

• Groups: The number of groups in this database that contain this 
word. 

• Length: The number of characters in the word. 

• Weight: An indication of the word’s relevance in a given database. 

• Words: An alphabetical list of words. The number at the top indi-
cates the total number of unique words in the document. 

Select a word, and DEVONthink highlights each occurrence in the 
document. You can select multiple words by ⌘-clicking. If you select a 
single word, the (resizable) Related Words area at the bottom (Figure 
68) shows a graphical depiction of other words that frequently appear 
in proximity to this one throughout your database—not necessarily in 
this document. 

Figure 68: The Related Words view shows you other words that 
frequently cooccur with the selected word (in this case, “Recipes”). 

Although the Concordance’s list view is generally the most useful, 
DEVONthink 3 adds two more views. Click the Cloud tab at the top of 
the inspector to display a word cloud, in which each term’s size is 
relative to its weight; or click the Graph tab to show a simple (unla-
beled) line graph of word frequency in the document. 
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Tip: To export the cloud view of the Concordance as a PDF, right-
click (or Control-click) the cloud and choose Export from the contex-
tual menu. 

If your needs extend beyond a single document, such as analyzing 
word usage in a large corpus of texts, you can select multiple docu-
ments, a group, a tag, a smart group, or pretty much anything else to 
see statistics for the whole set. To show a concordance for a whole 
database, select the database in the Navigate sidebar and then make 
sure no items within that database are selected (meaning the view/edit 
pane should say “No Selection”). 
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Work with Your Information 
DEVONthink isn’t only about storing, organizing, and finding informa-
tion. It also contains a full set of tools for editing documents (ranging 
from plain and styled text to images) and for annotating PDFs—so you 
can do a great deal of useful work without leaving the app. And when 
you need to do editing that goes beyond DEVONthink’s capabilities, 
you can easily open a document in the external app of your choice. I 
discuss all these options in this chapter. 

Edit Documents in DEVONthink 

Editing most documents is straightforward, but I must mention 
something up front that could confuse you if you aren’t expecting it: 
the fact that you can view a document in DEVONthink doesn’t neces-
sarily mean you can edit it—or, in some cases, select text in it. 

Because DEVONthink uses the Mac’s Quick Look technology, it can 
index and display any kind of media the Finder can—including graph-
ics, audio, and video files, iWork and Microsoft Office documents, and 
others for which Apple or a third party has installed an appropriate 
plugin. However, although some of these files can be manipulated 
inside DEVONthink, others cannot. The bulleted list just ahead gives 
an overview of what you can and can’t do in various kinds of docu-
ments. 

Just as when viewing documents, you can edit a document directly in 
the view/edit pane, or double-click it to open it in a separate window. 
Either way, before you can make changes to a document, it must be in 
a writable (as opposed to read-only) state. If you see a read-only 
icon on the navigation bar, check the Info inspector to see if the docu-
ment is locked ; if so, click the lock so it displays the unlocked icon. 
But keep in mind that some documents can’t be edited, even if they’re 
unlocked—this is true, for example, of imported email messages. 
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Here are the types of editing you can do in which types of documents: 

• Select text: All document types except graphics, video, and audio 
(email messages must be in text-only mode—click the Text Alterna-
tive icon on the navigation bar or choose View > Document 
Display > Text Alternative, ⌘-Control-X, to enter this mode) 

• Edit: Plain text, rich text, formatted note, Markdown text, HTML 
page, web archive, sheet, graphics 

• Highlight: Rich text, formatted note, PDF, HTML page, and web 
archive 

• Imprint: Graphics and PDF (see Add Imprints, ahead; requires 
Pro or Server version) 

• Annotate: PDF only 

You should also know how to access the tools you’ll need when editing 
certain document types: the editing bar, which replaces the controls on 
the navigation bar when you click the Show Editing Bar icon, 
contains context-sensitive formatting controls that vary with the kind 
of document (see Figure 69). In most cases, there are other ways to 
perform the associated editing tasks (for example, using commands on 
the Format menu and its submenus), but it’s often useful to have those 
controls available in this handy area right above the body of the docu-
ment. 

Figure 69: The editing bar as it appears for a rich text document 
(top), a PDF (middle), and an image (bottom). 

With those preliminaries out of the way, let’s look at a few of the most 
common document types you may want to edit. 

Edit Text Documents 
To edit a plain text or rich text document (or formatted note) in 
DEVONthink, use the view/edit pane or double-click it to open the file 

180 



          
        

     

      
        

   

             
         

            

           
             

         
          

             
  

 

         
           
         

         
         

in a separate window (Figure 70), which gives you a custom—and 
customizable—toolbar. (Choose View > Customize Toolbar to adjust 
the toolbar’s buttons to your liking.) 

Figure 70: Editing a rich text document in its own window gives you 
access to a custom toolbar (not to mention the editing bar and 
optional format bar, shown here). 

When you open a rich text document in a separate window (as in the 
image above), the editing bar appears automatically, though you can 
hide it if you prefer by clicking the Hide Editing Bar icon. 

Whether or not you’re using a separate window, you can also optional-
ly display another set of tools called the format bar (see Figure 71), 
which appears right beneath the toolbar and contains font size and 
style pop-up menus, alignment buttons, and similar controls. To toggle 
the display of this bar, choose Format > Show Format Bar (or Hide 
Format Bar), ⌘-Shift-F. 

Figure 71: The format bar. 

The format bar is theoretically applicable only to documents with 
styled text, but that doesn’t apply to formatted notes, HTML, or Mark-
down documents—just rich text documents. On the other hand, oddly 
enough, it is available with plain text documents, though only when 
they’re displayed in separate windows. (Keep in mind that, although 

181 



             
         

   

         
          

          
            

              
           

   

    
        

         
            

         
         

           
        
          

   

             
         

          
           

           
   

          
           

      

           
          

           
    

you can modify the display of the text in plain text documents using 
these controls, the style changes aren’t saved with the document—it’s 
still just plain text.) 

DEVONthink’s text editing capabilities are almost identical to those 
in TextEdit (although some commands are found in slightly different 
locations, or have different keyboard shortcuts), so you should feel 
at home. All the important formatting commands are on the Format 
menu or one of its submenus, just as in TextEdit. In short, for plain 
text and rich text documents (as well as formatted notes), there’s not 
much to say—it just works. 

Edit HTML and Markdown Documents 
DEVONthink lets you edit HTML documents, Markdown documents, 
and web archives (which bundle HTML along with graphics and other 
resources in a single file) in much the same way as plain text and rich 
text documents. However, these three web-related formats share a 
unique characteristic: they are based on human-readable source code. 
And so, DEVONthink lets you edit these documents either in preview 
mode (which shows their final, rendered appearance) or in source 
mode (which shows their underlying tags); and you can even view both 
at the same time. 

To switch modes, use the icons on the right side of the navigation bar 
or the commands on the View > Document Display submenu: 

• Preview: The default mode, preview shows your document as it 
will appear with all styles, links, graphics, and so on. For preview 
mode, click the Preview icon or choose View > Document Dis-
play > Preview (⌘-Control-P). 

• Source: Shows the underlying HTML or Markdown source of the 
document. For source mode, click the Source icon or choose 
View > Document Display > Source (⌘-Control-X). 

• Side-by-Side: Shows a split view with the source on the left and 
the corresponding rendered page on the right (Figure 72). For 
side-by-side mode, click the Side-by-Side icon or choose View > 
Document Display > Side-by-Side (⌘-Control-Y). 
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Figure 72: Side-by-side view lets you see the source of Markdown 
(shown here), HTML, or web archive files beside the rendered con-
tent. 

Note: The source view is partially WYSIWYG: for simple formatting 
such as bold, italics, strikethrough, blockquotes, and some links, 
applying the relevant tag also produces styled text. For example, if 
you type a pair of asterisks on either side of a string, the asterisks 
and the string become bold: **Wow**. If you prefer to see only 
plain text, disable this by going to Settings/Preferences > Files > 
Markdown and deselecting “WYSIWYG editing.” 

When working in side-by-side mode, keep in mind that changes 
don’t appear in the rendered pane until you save the source docu-
ment (⌘-S). In addition, the two panes don’t scroll in sync; you 
must manually scroll each pane to the same spot. 

Tip: If you drop an image file from the Finder into the source of a 
Markdown document, the app adds a valid Markdown link to that 
graphic, with the image’s name as a caption. If you drop an email 
message from Apple Mail or an event from Calendar into a Markdown 
document, DEVONthink adds a link to the original message or event. 

DEVONthink includes the Prism syntax highlighting framework for 
Markdown documents. That means the preview pane in DEVONthink 
can show code examples embedded in your Markdown code with 
automatic syntax highlighting. To enable it, go to Settings/Preferences 
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> Files > Markdown and check “Prism support” in the Extensions 
section. Once you’ve done this, open a Markdown document in DE-
VONthink, insert a line just before the code example, and type three 
backticks (`) followed by the name of the language your code example 
is in. For example: 

```javascript 

Supported languages are AppleScript, bash, C, C++, Go, Java, Java-
Script, Objective-C, Python, Perl, PHP, Ruby, Swift, and Typescript. An 
example of how this works with a JavaScript snippet appears in Fig-
ure 73. 

Figure 73: Plain Markdown with a bit of embedded code (top) can 
appear, in preview mode, with syntax coloring (bottom). 
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Similarly, DEVONthink now supports the MathJAX framework, which 
lets Markdown previews display fully formatted mathematical equa-
tions. To enable it, go to Settings/Preferences > Files > Markdown and 
check “MathJAX support” in the Extensions section. Then use a 
supported syntax such as LaTeX or MathML in your Markdown 
document (for example, $$ \sqrt[3]{\frac xy} $$) and switch to the 
preview to see the rendered result. 

Starting with version 3.7, DEVONthink also supports transclusion, 
which means including the entire contents of one (Markdown, HTML, 
RTF, RTFD, formatted note, web archive, sheet, plain text, or SVG) 
document in another Markdown document via a special link. To 
transclude a document, type its name inside double curly braces 
({{myfile.md}}) or inside double square brackets preceded by an 
exclamation point (![[myfile.md]]); or, Control-drag the document to 
be transcluded to the spot in your Markdown document where you 
want it to appear. The transcluded document is automatically convert-
ed to Markdown; you can see this in preview mode or side-by-side 
view. 

Tip: The extension in your link is optional if the filename of the 
transcluded file is unique. 

Edit Images 
When I say you can edit images in DEVONthink, I don’t mean you can 
do the fancy things you can in Photoshop. What you can do, however, 
is rotate or flip an image; add line, shape, or text annotations; use the 
same image-manipulation tools built into Preview for adjusting overall 
attributes such as contrast, tint, and sharpness; and apply a few simple 
special effects. 

Note: DEVONthink supports graphics in most common formats, 
including JPEG, PNG, TIFF, and HEIC. When you flip or rotate an 
image, or copy a portion of an image, the result is saved in uncom-
pressed TIFF format, regardless of the format of the original. 
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To edit an image, select the document in your database (to edit it in the 
view/edit pane) or double-click the document (to open it in a separate 
window). Click the Show Editing Bar icon on the navigation bar to 
display the editing bar with graphics-specific icons; these controls are 
also present on the Format menu (or its submenus). 

To make adjustments to the image as a whole, double-click the image, 
or right-click (or Control-click) the image and choose Edit from the 
contextual menu. The Image Edit panel (Figure 74) appears. 

Figure 74: Use this panel to make quick modifications to photos. 

Tip: To change the magnification of the image (without altering the 
file itself), use one of the Zoom commands on the View menu or the 
right-click/Control-click contextual menu, or click a Zoom icon on the 
toolbar, if you’ve added those icons manually. 

Move the sliders to adjust your image, and explore the Effects and 
Details tabs for more options. Switching between the Adjust and 
Effects tabs discards changes made before the switch, so close the 
panel to apply your changes before switching tabs. 
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After making any change to an image, be sure to save it (Data > Save 
or ⌘-S). Switching to another item in DEVONthink also saves your 
changes. To discard your changes, click Reset All. 

Another way you can edit an image is to add an imprint; see Add 
Imprints, ahead. 

Navigate PDFs 

One of DEVONthink’s strongest features is its extensive support for 
PDF documents. Elsewhere in this book, I discuss how DEVONthink 
can convert scanned documents into searchable PDFs (see Scan 
Documents). You can also rotate and zoom them just as you would any 
other graphic. However, you can do considerably more with PDFs. 

For the moment, I want to focus on getting around within PDFs and 
performing a few basic tasks. Then, in Edit PDFs, I cover DEVON-
think’s features for basic, high-level editing; in Annotate PDFs, I 
explain how to add notes, comments, links, and shapes to PDF docu-
ments; and in Add Imprints, I tell you about a new, specialized type of 
annotation. 

Choose PDF Display Options 
Most of the commands dealing with the ways in which PDFs are 
displayed appear on the easy-to-miss View > PDF Display submenu. 
You have the following options: 

• Layout: In the first group of commands, choose Single Page (the 
default) to display the PDF in conventional “scroll” orientation, one 
page above the next. Or, for a more book-like view, choose Two 
Pages, which shows you pairs of pages side by side. (To make the 
view even more book-like, also choose Book Mode, in the second 
group of commands, which ensures that odd-numbered pages 
always appear on the right and even-numbered pages on the left, 
as in a physical book.) 

• Page presentation: In the second group of commands, choose 
Continuous Scroll (the default) to view pages in immediate succes-
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sion, as in a word processor—depending on your zoom level and 
how far you scroll, the window may show portions of two or more 
pages. (Optionally choose Page Breaks to show more visible empty 
space between the pages.) Uncheck Continuous Scroll to view only 
one page in the window at a time, regardless of the window size. 

• Crop box or media box: The third group of commands specifies 
which portion of the page DEVONthink displays. (For many docu-
ments, this setting has no effect, but if it seems as though DEVON-
think is showing too much or too little of a PDF, try the other com-
mand.) 

Move Around in a PDF 
To move from one point to another in a PDF, you can use the scroll 
bar; you can also use the Content inspector to view the table of con-
tents (Tools > Inspectors > Table of Contents, Control-4) or thumb-
nails (Tools > Inspectors > Thumbnails, Control-5), and click an item 
in one of those lists to jump to that spot in the document. However, 
you have a few other options, too: 

• Next/previous page: To move ahead by one page (or two, if 
you’re in Two Pages mode via View > PDF Display > Two Pages), 
click the Next Page icon on the navigation bar. To move back by 
one page (or spread), click the Previous Page icon. The PgUp and 
PgDn keys also work fine. 

Note: If you don’t see next/previous page buttons on the navigation 
bar, make sure the editing bar isn’t showing—click the Hide Editing 
Bar icon to hide it. 

• Forward/back: This is subtly (but importantly) different from 
next/previous. Because PDFs may contain links to other pages (or 
you may skip around by clicking thumbnails or table-of-contents 
entries), you may want to return to the last page you viewed, even if 
it’s not the previous page in the document. To do this, click the Go 
Back icon on the navigation bar (⌘-[), which works the same way 
as a Back button in a web browser. To move forward after going 
back, click the Go Forward icon on the navigation bar (⌘-]). 
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• Go to page: To go to a specific page in the PDF, choose Go > Go to 
Page, type the page number, and click OK. You can also click the 
page count on the navigation bar to display a Go to Page dialog. 

Tip: In PDFs (as in any document in DEVONthink), you can use the 
Edit > Find > Find command (⌘-F) to search for text within the 
current document and jump directly to it. 

Tip: You can select text in a PDF in the usual way—just click and 
drag. But you can also select a vertical column of text (such as a 
column in a multi-column document, or a sidebar). To do so, hold 
down the Option key while clicking and dragging 

Edit PDFs 

Although DEVONthink doesn’t offer the extensive PDF editing capabil-
ities found in apps such as PDFpen and Acrobat Pro DC, it does in-
clude tools that let you insert, delete, rotate, and rearrange pages, or 
split a PDF into multiple documents. 

While viewing a PDF in the view/edit pane or its own window, you can 
do the following: 

• Insert a blank page: Choose Tools > PDF Document > Insert 
Blank Page, right-click/Control-click the document and choose 
Insert Blank Page from the contextual menu, or click the Insert 
Blank Page icon on the editing bar. A blank page is inserted 
before the currently selected page. 

• Delete a page: Choose Tools > PDF Document > Delete Selected 
Page, right-click/Control-click the document and choose Delete 
Selected Page from the contextual menu, or click the Delete Selected 
Pages icon on the editing bar. 

• Rotate a page: Choose Tools > Rotate & Flip > Rotate Left, Rotate 
Right, or Rotate 180 Degrees; right-click/Control-click the docu-
ment and choose Rotate Left, Rotate Right, or Rotate 180 Degrees 
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from the contextual menu; or click the Rotate Left icon, Rotate 
Right icon, or Rotate 180 Degrees icon on the editing bar. 

• Rearrange pages: On the Thumbnails tab of the Content inspec-
tor (Tools > Inspectors > Thumbnails, Control-5), drag a page 
thumbnail up or down to move it in the document. 

• Reverse all the pages in the document: Choose Tools > PDF 
Document >Reverse Page Order, right-click/Control-click the 
document and choose Reverse Page Order from the contextual 
menu, or click the Reverse Page Order icon on the editing bar. 

• Split a PDF into chapters: For PDFs that have a table of con-
tents and chapter headings (including Take Control books!), you 
can choose Tools > Split PDF > into Chapters to create individual 
documents from each chapter. 

• Split a PDF into pages: To split any multipage PDF into a series 
of one-page files, choose Tools > Split PDF > into Pages. 

Annotate PDFs 

DEVONthink has the capability to annotate PDFs—that is, to add 
comments or notes, highlight interesting passages, or even draw 
shapes on the pages, all without changing any of the underlying text. 
Annotations can be useful when marking corrections on page proofs, 
discussing a report or paper with your colleagues, or jotting reminders 
as you read an ebook. 

To annotate a PDF, you can use the commands on the Tools > Anno-
tate submenu or display the editing bar (by clicking the Show Editing 
Bar icon) and use the icons that appear there. Figure 75 shows a 
PDF with a variety of annotations. 
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Figure 75: This PDF page has oval, text, and note annotations, as 
well as green highlighting. 

You can annotate a PDF in any of the following ways: 

• Add a shape: To call attention to a portion of the document, click 
the Oval tool, the Rectangle tool, or the Line/Arrow tool 
on the editing bar. Then click and drag to draw the selected shape. 
When you do this, an Annotations panel (Figure 76) appears, with 
controls to let you select the color, thickness, and other properties 
of the shape. (The range of options available in the Annotations 
panel varies depending on which type of annotation you’re entering 
or editing.) 
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Figure 76: Adjust the characteristics of an annotation here. This is 
how the Annotations panel appears when you add an oval shape. 

• Add a note: A note is a comment that appears with a small refer-
ence icon at the location of your choice on the page; double-click 
this icon to display the note’s contents in the Annotations panel. (In 
Catalina or later, if the document is open in its own window, click-
ing the icon displays the note’s contents in an overlaid “sticky 
note.”) 

To add a note, click the Note tool on the editing bar and then 
click where you want the reference icon to go. When the Annota-
tions panel appears, type your note in the Text field at the top and 
then click the close button in the upper-left corner of the panel. 

• Add text: Unlike notes, which normally appear as unobtrusive 
icons in your document, text annotations appear on top of the text 
(much like a sticky note). To add text, click the Text Annotation 
tool on the editing bar, and then drag out a box to hold your annota-
tion. When the Annotations panel appears, type in the Text field at 
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the top and then click the close button in the upper-left corner of 
the panel. 

• Add a link: You can add a link anywhere in the document, either 
to another location in the document or to an external URL. To do 
this, click the Link tool on the editing bar and then drag out a box 
where you want the link to appear. When the Annotations panel 
opens, do one of the following: 

‣ To link to a URL, choose URL (the default) from the Link Type 
pop-up menu, and then type or paste a URL into the URL field at 
the bottom. 

‣ To link to another page in the document, choose Link Within 
PDF from the Link Type pop-up menu. Then move to the loca-
tion in the PDF to which you want the link to point (by scrolling 
or clicking a thumbnail, for example) and click Set. 

Click the close button in the corner of the panel when you’re done. 
Your link will be clickable only when the Text tool or the Select 

tool is selected. (By the way, the purpose of the Select tool is to 
let you select annotations—to edit, move, or delete them—not to 
select contents of the PDF itself.) 

Note: Links you create yourself in DEVONthink are normally invisible; 
they appear with the gray crosshatch only when the Select tool or 
one of the annotation tools is selected. Regardless of visibility, they’re 
clickable only when Text or Select is selected—not when Move 

is selected. The pointer changes to this shape when over a link. 

• Apply underline or strikethrough: Select any text in a PDF and 
click the Underline or Strike Through icon on the editing bar, 
or choose Format > Style > Underline (⌘-U) to underline it or 
Format > Style > Strike Through (⌘-Control-S) to cross it out. 
These commands are also found on the Tools > Annotate submenu. 

• Highlight text: To apply a highlighter effect, select a range of text 
and click the Highlight icon on the editing bar, or choose For-
mat > Highlight (⌘-Shift-L). To adjust the highlight color, click and 
hold the icon and choose a color from the pop-up menu, or choose a 
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color from the Format > Highlight Color submenu. To remove a 
highlight, select the highlighted text and choose the Highlight 
command again. These commands are also found on the Tools > 
Annotate submenu. 

You can also add a note to highlighted text: Select the highlighted 
text, right-click (or Control-click), and choose Add Note from the 
contextual menu. 

After making any annotations, be sure to save the document. 

To remove an annotation, make sure an annotation tool is selected; 
then select the annotation and press Delete. To edit an annotation, 
double-click it, again with any of the annotation tools active. You can 
change the font and color of the selected annotation using the standard 
Fonts panel (⌘-T); move it using the arrow keys or by clicking and 
dragging. You can also view all the annotations for a PDF on the 
Annotations tab of the Document inspector. 

Add Imprints 

Imprints are present only in the Pro and Server versions of DEVON-
think 3. You can think of an imprint as an automated version of a text 
annotation. An imprint can add text (in your choice of font, size, color, 
and style; and with an optional shape border and fill) to a PDF or 
graphics file. But unlike text annotations, imprints can include place-
holder text, numbering, and precise positioning; and you can apply 
them to all pages or only particular pages of a document. Imprints are 
thus good for watermarks, stamps, page numbering, and other materi-
al that you might want to add to images and PDFs in an automated 
way. 

To create an imprint, start by going to Settings/Preferences > Imprint-
er. Click the plus button, then click the name (“New Imprinter”) 
under the Configurations heading, type your own name for the im-
print, and press Return. The window should then look something like 
Figure 77. 
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Figure 77: Set up the contents and appearance of imprints here. 

In the Title field, type the text you want to appear in the imprint. 
(You’ll notice a Font token in that field; this is a placeholder telling 
DEVONthink you want to specify the font information for the imprint, 
which you almost certainly do. You can delete that token, but DEVON-
think will put it back automatically. Basically: just ignore it.) 

Speaking of placeholders, you can use as many as you like in an im-
print. Right-click (or Control-click in the Title field) and choose a 
placeholder from the Insert Placeholder submenu of the contextual 
menu. Among the many options (see Using Placeholders for more 
information) are File Name, Counter, Page Number, various date and 
time options, Bates Number, and custom metadata. 

Use the controls below the Title field to specify the font, size, style, and 
color you want for your imprint. Use the Style pop-up menu to enclose 
your imprint in a shape; the choices are rectangle, rounded rectangle, 
oval, left-pointing arrow, and right-pointing arrow. If you choose one 
of these borders, you can then use the Border and/or Fill controls to 
specify whether the shape should have a border, fill, or both—and what 
the border/fill attributes should be. 

To specify where on each page the imprint should go, click the Loca-
tion tab (Figure 78). Click a square in the Position selector to anchor 
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the imprint to that relative spot on the page; then use the Offset fields 
to specify the number of pixels by which it should be offset from that 
location in each axis. To rotate the imprint, enter a number of degrees 
in the Rotation field. Finally, select an Occurrence radio button to 
specify which page(s) of a document the imprint should apply to. 

Figure 78: Set the location, rotation, and occurrence of imprints 
here. 

Three other imprint options are worth mentioning: 

• Duplicate item before imprinting: Because imprints perma-
nently change the document and DEVONthink offers no tools for 
removing them, you might want to hedge your bets by checking this 
box, which instructs DEVONthink to make a copy of each item you 
imprint, and then add the imprint to the copy. 

• Preview: Click the Preview button at the bottom of the Configura-
tions list to see what your imprint will look like on an example 
document page. 

• Combined Configurations: What if you want to put multiple 
imprints on the same document, each with different characteristics? 
You could manually apply multiple imprints, but an easier way is to 
create each imprint individually, then create a combined imprint 
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that applies them all at once. To do this, click the actions icon at 
the bottom of the Configurations list and choose New Combined 
Configuration from the pop-up menu. Select an imprint from the 
Configurations list on the right and click the left  arrow button to 
add it to the combined configuration. Repeat as necessary to add 
more imprints to the combination. 

Once you’ve configured an imprint, you can apply it to any image or 
PDF by selecting the document and then choosing Tools > Imprinter > 
Imprint Name. DEVONthink adds the imprint, converting placehold-
ers into real text as appropriate. 

Convert Document Formats 

Earlier I mentioned that scanned PDF documents can be converted to 
searchable formats (PDF, RTF, Word, and web archive) by choosing 
commands from the Data > OCR submenu. DEVONthink can perform 
other conversions too—find the commands on the Data > Convert 
submenu. 

The additional options and the document types they can convert are: 

• to Plain Text: Any text-based format, such as rich text, HTML, 
Markdown, PDF, Pages, Word, web archives, formatted notes, 
bookmarks, email messages, and EPUB 

• to Rich Text: Plain text and most other text-based formats (such 
as sheets and PDF, but not Pages), plus graphics 

• to Formatted Note: Plain text, rich text, and most of the text-
based formats (but not PDF or Pages) 

• to Markdown: Most text-based formats, such as rich text, HTML, 
PDF, Pages, Word, web archives, and email messages—but not 
EPUB 

• to HTML: Plain text, rich text, PDF, and most of the text-based 
formats (but not Pages) 
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• to Web Archive: Any text-based format, such as rich text, HTML, 
Markdown, PDF, Pages, Word, email messages, and EPUB 

• to PDF (Single Page): Any document type that DEVONthink can 
edit 

• to PDF (Paginated): Any document type that DEVONthink can 
edit 

• to PDF without Annotations: PDF only 

• Duplicates to Replicants: Items that have duplicates in your 
DEVONthink database 

Edit Documents in External Apps 

For documents that DEVONthink can’t edit itself—or in cases where 
you need special features found in a different editor—you can open any 
document in another app of your choice. 

To open a document in an external app, select the document and 
choose Data > Open With > Name of Application. (The Open With 
submenu also appears on the Actions pop-up menu on the tool-
bar and on the Control-click contextual menu.) The apps listed there 
are the ones that advertise themselves as being able to open the file 
format in question. For example, when you select a Word document, 
the Open With submenu shows not only Microsoft Word (as the 
default choice, at the top), but also TextEdit and other applications you 
may have that can read Word files, such as Pages and Nisus Writer 
Pro. 

If you prefer to not use DEVONthink’s document editing tools, you can 
also choose to have all files open in their default app when double-
clicked. The behavior here depends on what is set in Settings/Prefer-
ences > General > “Double-click opens documents externally”: 

• If that box is checked, then double-clicking any document—even 
one DEVONthink can edit intrinsically—opens it in the default app 
for that document type. If you want to open it in DEVONthink 

198 



          
    

        
         

    

          
           

             
             

instead, as a read-only preview, instead select the document and 
choose Data > Open (⌘-O). 

Note: You can also double-click an attachment within another docu-
ment (typically a rich text document or an email message) to open it 
in the appropriate external app. 

• If that box is unchecked, then double-clicking any document opens 
it within DEVONthink. If it’s a file format DEVONthink can edit, 
then you get an editing window; if not, you get a preview window. 
To force the document to open in the default external app, select it 
and press ⌘-Shift-O. 
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Automate DEVONthink 
DEVONthink offers plenty of power and utility when used manually— 
dragging stuff in; finding, organizing, and editing things; and sharing 
or exporting things. But you can also put DEVONthink to work for you 
by configuring it to automate repetitive or time-consuming tasks. 
Although older versions of DEVONthink supported AppleScript, 
DEVONthink 3 also includes several other types of automation. 

In this chapter, I cover four main ways to automate DEVONthink: 
using smart rules, reminders, AppleScript, and smart templates. 

Work with Smart Rules 

As you’ll recall (refer back to Use Smart Groups), a smart group is 
basically a saved search that lists items matching one or more criteria 
you specify. A smart rule builds on that concept—instead of merely 
listing items that meet your criteria, it does something when items 
meet your criteria. In this way, it’s much like the rules (or filters) your 
email app offers—for example, when a message comes in with a certain 
sender, a rule might file it into a particular mailbox; or if a message has 
a specific subject, your email app might send an autoreply. 

But DEVONthink’s smart rules can do fancier things—for example: 

• When DEVONthink opens, convert any web archives in your inbox 
that mention your name into PDFs 

• Every time you move a document with a certain label, change its 
modification date 

• Once a week, move any unread items in your global Inbox to the 
Trash 

• Perform OCR on every PDF document as it’s imported (not neces-
sary for incoming scans; see Configure OCR Preferences) 
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• Replicate items with a certain tag to a predefined group whenever 
you open them 

Set Up a Smart Rule 
What you’ll notice about the example smart rules above is that they all 
feature search criteria (which can include a specific location, or not, 
and zero or more attributes), an action (what DEVONthink does with 
them), and a trigger (what event happens that causes the action to 
occur, such as opening the app or moving a document). DEVONthink 
offers a long list of actions to choose from, and a smart rule can also 
perform a sequence of actions. Similarly, many different events can 
trigger a smart rule, or you can trigger the rule manually in multiple 
ways. 

To create a smart rule, follow these steps: 

1. Either choose New Smart Rule from the New pop-up menu at 
the bottom of the sidebar or right-click (or Control-click) an item in 
the sidebar and choose New Smart Rule from the contextual menu. 
The Smart Rule dialog (Figure 79) appears. 

Figure 79: Create a smart rule using this dialog. 

2. Type in a name for your smart rule. 

3. Specify the scope of the rule: from the “Search in” pop-up menu, 
choose an inbox, database, group, or tag; or choose Databases to 
search everywhere. 
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Note: If a location is selected in the sidebar when you create your 
smart rule (or if you use the contextual menu to create it), the 
“Search in” pop-up menu is initially set to that location. 

4. Fill in the options and search criteria just as you would when creat-
ing a smart group (refer back to Use Smart Groups). 

So far, what you’ve done is identical to what you would do when 
creating a smart group. But now, instead of displaying a list of 
matches, you specify what DEVONthink should do with matches, 
and when. 

5. From the “Perform the following actions” pop-up menu, choose a 
trigger—that is to say, an event that must occur in order to make 
your rule run. There are 38 options, including On Startup, Hourly, 
On Creation, On Open, On Replicating, On Tagging, and On Moving 
into Database. Most of these should be self-explanatory, but consult 
the DEVONthink documentation for details if need be. 

If you want your smart rule to run only when you ask it to—for 
example, by choosing a menu command or dropping a document 
onto your smart rule—choose On Demand (the default choice). 

A given smart rule can be triggered by more than one action. For 
example, you might have a rule that operates when a document is 
opened as well as when tags are added. To add another trigger, click 
the plus button next to the “Perform the following actions” pop-
up menu. 

Tip: To disable all event triggers, deselect the checkbox next to 
“Perform the following actions.” This can be useful if you want to 
temporarily disable a smart rule. 

6. From the unlabeled pop-up menu in the bottom portion of the 
dialog, choose an action that will occur when the rule is triggered 
and the conditions are met. There are dozens of options, such as 
Display Alert, Add to Reading List, Change Name, Add Tags, Move, 
Classify, and OCR. Again, see the documentation for details about 
any actions that seem unclear. 
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Some actions require additional information. For example, if you 
specify Display Alert, you must fill in the text of the alert; if you 
specify Move, you must fill in a destination. 

Note: One of the available actions is Execute Script, to run an Apple-
Script. Choose External to use a script already stored in the designat-
ed Smart Rules folder (or one you save there), or choose Embedded 
and click Edit Script to enter a script directly in DEVONthink. See 
Included Scripts, ahead, for more information. DEVONtechnologies 
strongly recommends that if you include an Execute Script action, 
you make it the last action in the rule. 

7. To make the rule perform an additional action, click the plus 
button and fill in the details; repeat as desired. 

8. Click OK. 

DEVONthink saves the smart rule, which thereafter appears in the 
Smart Rules section of the Navigate sidebar. (Smart rules are always 
considered global items, even when they apply only within specific 
databases.) 

From now on, whenever the trigger(s) you chose occur(s), DEVON-
think runs the smart rule—it looks in the location you specified for 
items that match the criteria you set, and if it finds any, it performs the 
action(s) you requested. 

To edit a smart rule later, double-click it in the sidebar; to keep the 
original and edit a copy, first right-click (or Control-click) the rule and 
choose Duplicate from the contextual menu. (You might also try this 
with the smart rules DEVONthink includes by default—such as Filter 
Duplicates and Automatic Locking—to see how they work.) 

Tip: To turn an existing global smart group into a smart rule, hold 
down Option while right-clicking or Control-clicking and choose 
“Duplicate as smart rule” from the contextual menu. 
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Run Smart Rules Manually 
If you chose On Demand as a trigger in step 5 above, you can run your 
rule manually in one of the following ways: 

• Drag one or more items onto the smart rule icon in the sidebar. 

• To apply a smart rule only to selected items (assuming they match 
the rule’s conditions), select one or more items and choose Tools > 
Apply Rules > Rule Name. 

• To perform a smart rule on any item in your database that might 
match it—regardless of what you may have chose when you created 
it—choose Tools > Perform Rules > Rule Name; read and consider 
the warning asking if that’s really what you want to do, and click OK 
if you still want to run the rule. 

Batch Processing 
A batch process is sort of like a manual, ad hoc smart rule—but just 
the action part, not the matching part. For example, if you want to 
rename a set of documents, or change something about their meta-
data, but just as a one-time task and not a recurring event, you can 
use a batch process to do so. 

To perform a batch process, select one or more items and choose 
Tools > Batch Process (⌘-Control-B). In the dialog that appears, 
choose an action from the pop-up menu and fill in any required 
details. (The list of actions available for batch processing is a subset 
of the actions available for smart rules.) As with a smart rule, click 
the plus button to enter more actions. Click OK to apply the 
actions you just specified to the selected items. 

Use Text Searches in a Smart Rule 
DEVONthink’s smart rules (and batch processes) include Scan Name 
and Scan Text actions. These actions enable DEVONthink to search 
either the name of a document or its contents for a pattern, which can 
then be used in a subsequent action. The patterns you search for can 
include wildcards and regular expressions. 
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As an example of how you might use one of these actions, see Figure 
80, below. In this smart rule, imported documents whose names begin 
with “TPS Report” are searched for a line that matches the pattern 
“Report Title: something” (followed by a return), using the regular 
expression Report Title: (.*)\n. The next action then uses that 
something (\1) to rename the document. 

Figure 80: This smart rule looks for a text pattern within certain 
imported documents and uses it to rename those documents. 

If you’re using a String search (instead of a regular expression, as in 
this figure), the wildcard * (any string) can’t appear alone; it requires a 
prefix and/or a suffix, such as Date: *. You can then reference that 
string in another action by typing %Document String% or by right-click-
ing or Control-clicking in another action’s field and choosing * Docu-
ment String from the Placeholder submenu of the contextual menu. 

Note: Scan Text actions in smart rules and batch processes scan only 
the first eight pages of PDFs and the first 40k of text. 

Use Reminders 

Reminders are yet another feature added in DEVONthink 3. If you’ve 
ever set an alarm in Apple’s Calendar or Reminders apps to alert you 
when an event is about to occur, DEVONthink’s reminders will look 
quite familiar. Any item can have a one-time or recurring reminder. 
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For example, if you’ve imported a webpage but you want to remember 
to revisit it to check for changes on a certain date, or if you want to set 
alarms for deadlines relating to a project you’re developing in DEVON-
think, reminders can help you with those tasks. 

I think of reminders as an automation feature partially because they 
make things happen at a fixed time or on a recurring schedule without 
manual intervention, and partly because one form a reminder alarm 
can take is running an AppleScript (which, as you’ll see later in this 
chapter, can do just about anything). 

To set a reminder: 

1. Select any document or group. 

2. Choose Tools > Inspectors > Annotations & Reminders (Control-3) 
or click the Annotations & Reminders icon at the top of the 
inspector (Figure 81). 

Figure 81: The Annotations & Reminders inspector as it appears 
with a weekly reminder set. 
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3. From the Remind pop-up menu at the top, choose when the re-
minder should occur—Never (the default), Once (including preset 
options of Today, Tomorrow, In Two Days, and In One Week), 
Hourly, Daily, Weekly, Monthly, or Yearly. 

4. For anything other than Never, fill in the details of the day(s), 
date(s), and time(s) for the reminder, just as in the Calendar app. 

5. From the Alarm pop-up menu, choose the type of alert. In most 
cases, something visible (Display Notification or Display Alert) or 
audible (Speak Text or Play Sound) is probably what you want, but 
you can also send an email, open a document, or run an Apple-
Script. As with smart rules, the script can be either external (that is, 
one that’s stored in the designated Reminders folder—see Included 
Scripts, ahead) or embedded (something you type or paste into 
DEVONthink). Be aware, however, that if you use an embedded 
script with a one-time reminder, the script will disappear from 
DEVONthink once the reminder occurs. 

Note: Unlike alerts in Calendar and Reminders, DEVONthink’s re-
minders can have only one alarm per item. 

Note: You can disable all reminder alarms if need be by going to 
Settings/Preferences > General and unchecking “Enable reminder 
alarms.” 

Use AppleScript with DEVONthink 

Despite DEVONthink’s incredibly long list of features, it may not do 
everything you want it to do. Fortunately, it also includes extensive 
support for AppleScript, which means you can add new capabilities to 
the app, automate complex sequences of tasks, and integrate DEVON-
think in novel ways with other apps running on your Mac. 

Many books have been written about AppleScript, and I couldn’t begin 
to offer a proper guide to using it here. (I can, however, put in a quick 
plug for my book Take Control of Automating Your Mac!) Instead, 
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what I provide here is simply a quick overview of DEVONthink’s 
AppleScript support, a few examples of included scripts, and pointers 
on where to learn more. 

AppleScript is an English-like scripting language that was designed 
to be reasonably easy for non-programmers to learn. (Whether that 
turned out to be true or not is open to debate!) Apple provides a tool 
called Script Editor (in /Applications/Utilities) that facilitates 
writing, running, and debugging scripts (although other, more ad-
vanced scripting environments also exist). 

An app that can be controlled by AppleScript is said to be scriptable, 
and DEVONthink is scriptable in the extreme, exposing 90 verbs 
(commands) and more than a dozen nouns (objects that can be acted 
on), each with various properties (parameters). 

However, you needn’t know any AppleScript to start using these 
capabilities. DEVONthink includes over 100 preinstalled AppleScripts, 
which can perform an astonishing range of useful activities as they 
stand—and can also be used as models when creating your own scripts. 
These scripts can be used without any special knowledge, in most cases 
simply by choosing them from a menu—so it’s like having 100 extra 
features to play with! 

Tip: DEVONthink’s AppleScripts are installed automatically when you 
first run the app, but you can reinstall them if needed by choosing 
DEVONthink 3 > Install Add-ons, checking Additional Scripts, and 
clicking Install. 

I encourage you to try them out, and then if you’re interested, open a 
few of them in AppleScript Editor to see how they work. 

Included Scripts 
DEVONthink’s preinstalled scripts fall into several broad categories: 

• Menu scripts: These scripts appear on DEVONthink’s Script 
menu only when DEVONthink is running, and thus are intended to 
be used from within DEVONthink. This is the largest category, with 
over 70 scripts. The script files themselves are stored in ~/Library/ 
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Application Scripts/com.devon-technologies.think3/Menu (and its 
subfolders); if you add your own script to that folder (or even to a 
subfolder you create yourself), they’ll appear on the menu too. A few 
noteworthy examples: 

‣ Images: Among the scripts on this submenu are ones that can 
rotate or flip an image, or scale it to various sizes—handy since 
DEVONthink itself can’t resize graphics, only zoom in or out 
when viewing them. 

‣ Reminders: These scripts create an event or to do in Calendar 
(or various third-party programs, such as OmniFocus and 
Things) based on the selected item in DEVONthink—including 
a link to the item. 

‣ Sheets: Although I said earlier that DEVONthink’s sheets can’t 
do calculations, as spreadsheets can, these scripts add a couple 
of rudimentary spreadsheet features, such as summing and 
averaging rows or columns. 

Note: DEVONthink has its own Script menu, which appears to the 
left of the Help menu. You may also have a system-wide Script 
menu on the right side of the menu bar that is available in all apps. 
(You can enable or disable this menu in Script Editor > Preferences > 
General.) The scripts above appear on DEVONthink’s Script menu; 
the Application-specific scripts described later in this list appear on 
the system-wide Script menu. 

• Smart rules scripts: A smart rule, discussed earlier in this 
chapter (see Work with Smart Rules) can trigger an AppleScript to 
run when the rule’s criteria are met. DEVONthink includes a num-
ber of prewritten scripts for smart rules, stored in ~/Library/Appli‐
cation Scripts/com.devon-technologies.think3/Smart Rules; again, 
you can add your own scripts to this folder. 

• Reminders scripts: These scripts are available as actions that run 
when a reminder’s alarm is triggered (refer back to Use Reminders). 
Only one example is included: Open Document (which, as the name 
suggests, opens a specified document when the alarm goes off). 
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These scripts are stored in ~/Library/Application Scripts/ 
com.devon-technologies.think3/Reminders, and you can add your 
own if you like. 

• Toolbar Scripts: You can customize a DEVONthink toolbar to 
add buttons that run specific AppleScripts. Although DEVONthink 
includes no prewritten toolbar scripts, you can add your own to 
~/Library/Application Scripts/com.devon-technologies.think3/ 
Toolbar. You must then quit and reopen DEVONthink, and then 
choose View > Customize Toolbar to add your custom script to the 
toolbar. 

• Application-specific scripts: DEVONthink includes numerous 
scripts that appear on the system-wide Script menu in other 
applications (such as DEVONagent, Mail, Outlook, and Safari), 
enabling you to import content of various kinds and formats into 
DEVONthink. These scripts are stored in ~/Library/Scripts/ 
Applications/Application Name. 

A few examples for Safari: 

‣ Add linked images to DEVONthink: This script looks for thumb-
nails on a webpage that link to larger images, and downloads the 
full-size image files into DEVONthink. 

‣ Add links to DEVONthink: Similar to the last script, this one 
looks for links on the current webpage and adds each one to 
DEVONthink as a bookmark. 

‣ Add tabs to DEVONthink: This script adds bookmarks for all 
open Safari tabs to DEVONthink. 

• Folder Action Scripts: These scripts (located in ~/Library/ 
Scripts/Folder Action Scripts) are designed to be attached to 
folders such that when anything new appears in the folder, DEVON-
think automatically imports it (with or without OCR) or indexes it. 

DEVONthink 3 also offers a feature called “triggered scripts,” which 
lets you attach a specially written AppleScript to any item in your 
database and have that script run whenever you select that item. These 
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scripts can be stored anywhere on your Mac, and DEVONthink 3 does 
not include any prewritten examples. I can’t think of any action I’d 
want to trigger automatically upon merely selecting an item in 
DEVONthink, so I won’t say more about this except to mention that 
you can find details in the documentation (search for “triggered 
scripts”). 

Extra Scripts 
Besides the automatically installed AppleScripts, DEVONthink in-
cludes 16 optional AppleScripts in the Support Assistant—choose 
Help > Support Assistant and click the Install Extras link at the bottom 
of the window to see and install them. 

Writing Your Own Scripts 
The best way to figure out how to automate something in DEVONthink 
using AppleScript is to open a related example script in Script Editor 
and see how it’s constructed. To view the complete list of AppleScript 
commands available in DEVONthink, in Script Editor, choose File > 
Open Dictionary, select DEVONthink 3, and click Choose. The most 
interesting terms are in the DEVONthink 3 Suite. 

To learn more about using AppleScript generally, including tutorials 
and example scripts, visit MacOSXAutomation’s AppleScript page or 
the MacScripter website. DEVONthink’s documentation also has 
helpful information about getting started with DEVONthink-specific 
AppleScripts; see the “Basic AppleScript Terminology” topic. For more 
on scripting DEVONthink specifically, try the Scripting category within 
the DEVONtechnologies discussion forum. 

Note: DEVONthink 2 supported Automator as well. Although DEVON-
think 3 no longer has direct Automator support, you can still embed 
AppleScript in Automator workflows, giving you a way to control 
DEVONthink from Automator. 
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Use Smart Templates 

Earlier, in Template, I described how to create documents from pre-
built templates and edit those templates or create your own. I also 
mentioned a variant called a smart template, which also appears in the 
Data > New from Template submenu but is composed of AppleScript 
rather than a simple document with placeholders. I’d like to say a bit 
more about smart templates here. 

Smart Templates enable you to perform any number of complex 
automated actions in the course of creating a new DEVONthink docu-
ment. For example: 

• The Daily Journal smart template (in Data > New from Template > 
Productivity) creates a document that includes a quote (fetched 
from a web service) and the day’s news headlines (fetched from 
another web service). 

• The Project smart template (in the same submenu) creates a group 
tag hierarchy, which can include contact information selected from 
the Contacts app and a project name that you’re prompted to pro-
vide. 

A smart template can be interactive, asking you to supply information 
that it then uses when creating your new document(s), tag(s), or 
group(s); it can also use logic to analyze or process information and 
behave differently depending on any of numerous variables, including 
information found online. 

However, unlike smart groups, smart rules, and conventional tem-
plates, smart templates are not easy to create. They’re built almost 
entirely in AppleScript, and so unless you have a fair bit of facility with 
the language, creating a smart template that works just the way you 
want may be challenging. 

I suggest, as does the DEVONthink documentation, that you start by 
opening, examining, and modifying (copies of) some of the existing 
smart templates to see how things are done. You can find these in 
subfolders of ~/Library/Application Support/DEVONthink 3/Tem‐
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plates.noindex; they’re the packages with the .templatescriptd exten-
sion. Right-click (or Control-click) one of these, choose Show Package 
Contents from the contextual menu, and examine the files inside— 
especially Contents/Resources/Scripts/main.scpt. 
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Sync DEVONthink 
Databases 

If you have multiple Macs—or a Mac and one or more iOS/iPadOS 
devices—you’ll probably want to use DEVONthink on each one, and 
that in turn almost certainly means you’ll want your data to stay in 
sync across your devices. We’ve all become accustomed to near-instant 
syncing of data such as email, contacts, and calendars. In addition, 
cloud services like Dropbox and iCloud Drive enable us to keep files 
and folders in sync everywhere. You can have that same experience 
with your DEVONthink data. 

Although DEVONthink has excellent sync capabilities, they work 
differently from other apps and services you may have used, and the 
configuration is a bit unusual. If you’re setting up syncing for the first 
time, there are a few things you’ll have to know, but after the initial 
setup, syncing should be nearly transparent. 

Tip: If your goal in syncing DEVONthink data between two Macs is 
less about having the data on two Macs and more about giving 
another person access to the data, see the sidebar later in this 
chapter, Choosing a Sharing Strategy, for tips on different methods 
of making your DEVONthink data available elsewhere. 

Understand Sync Basics 

Before you jump in and set up syncing, you should be aware of the 
numerous choices DEVONthink offers and how they compare. It’s 
worth taking a few minutes to think through your options in advance 
in order to achieve your desired results. 
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External vs. Built-in Syncing 
As I explained in How and Where Databases Are Stored, even though 
DEVONthink stores all your documents as individual files on disk, it 
also keeps a great deal of information in a proprietary database; the 
database and the files together are kept in a package—a folder that 
looks like a single file. Because of the way databases work, syncing is 
tricky and dangerous if you try to do it outside DEVONthink (for 
example, by using a sync app such as ChronoSync to sync files over 
your local network, or by storing your database in a folder that syncs 
via a cloud service). Making even a small change to a single document 
changes not only the corresponding document file but also various 
parts of the database. As a result, if the data is synced externally while 
the database is open in more than one place, errors and data loss could 
occur. 

However, using DEVONthink itself to perform the syncing is another 
story altogether. DEVONthink can sync any or all of your databases 
with any number of other Macs and iOS/iPadOS devices, and it’s safe 
to make changes with the database open on more than one device— 
DEVONthink knows how to merge your changes quickly and intelli-
gently. 

Sync Locations 
Any database can sync to one or more locations (or none, which is the 
default); you can choose whichever combination best meets your 
needs. Conceptually, the various destination choices fall into two 
categories: direct, in which a database syncs between two copies of 
DEVONthink running on different devices; and indirect, in which each 
copy of DEVONthink syncs independently with a sync store—a copy of 
the database stored in central location, such as a file server or cloud 
service. 

Each method has certain implications: 

• For direct Mac-to-Mac (or Mac-to-iOS/iPadOS, or iOS/iPadOS-to-
iOS/iPadOS) syncing to work, DEVONthink must be running on 
both devices, which must also be on the same network. If this 
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arrangement is possible, direct syncing is the fastest and most 
efficient option, and has the lowest risk of conflicts. 

• Indirect syncing lets any copy of DEVONthink sync at any time, 
without regard to whether another copy of DEVONthink is running. 
As long as each device can reach the sync destination, the devices 
need not even be on the same network. But because each Mac or 
iOS/iPadOS device syncs independently, it becomes slightly more 
likely that a given document could change in more than one location 
between syncs, resulting in a conflict (see Set Syncing Options). 

• With either method, you can sync more than two devices. However, 
each sync operation occurs between a single pair of locations. As a 
result, in order for any particular change to propagate from one 
device to another, two sync operations may be required (depending 
on the timing of the syncs). 

DEVONthink uses the term location to refer to a sync endpoint, which 
can be another Mac or iOS/iPadOS device on your local network (if 
you’re doing a direct sync) or the cloud storage destination for your 
sync store (if you’re doing an indirect sync). Here are the location types 
you can choose, and what you should know about each: 

• Bonjour (direct connection): This option lets you sync directly 
with a copy of DEVONthink running on another Mac or iOS/iPadOS 
device on your local network (or even over a USB cable; see How to 
Sync by Wire). Although the syncing is bidirectional, one device 
effectively acts as a server and the other(s) as client(s). You must set 
up a password on the server and then authenticate with that pass-
word on your other devices; this prevents unauthorized users from 
syncing with your databases. 

• Local sync store: The desktop versions of DEVONthink can sync 
a database to any folder you can navigate to in the Finder; typically, 
you would choose a folder on a local network server, although you 
could also use an external hard drive, flash drive, or other storage. 
After you’ve synced one copy of DEVONthink to this folder, copies 
running on other Macs can optionally sync with that same location. 
Unlike a direct (Bonjour) connection, this requires making a sepa-
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rate copy of your sync data; on the other hand, it also permits 
syncing when one or more of the devices is offline. 

• Dropbox account: If you have a Dropbox account with enough 
free space to hold your database, you can sync to it. You can then 
sync your other devices to the same Dropbox account. Keep in mind 
that you can’t sync to a Dropbox folder someone else has shared 
with you; for security reasons, DEVONthink can read and write files 
only in a single, specific location in your Dropbox. When you set up 
Dropbox syncing the first time, DEVONthink asks for your Dropbox 
credentials to authorize access. 

• iCloud (CloudKit): There are two methods of syncing data via 
iCloud. The newer one uses an Apple framework called CloudKit. 
Like the legacy version of iCloud syncing (described next), CloudKit 
requires enough space in your iCloud account to hold all your 
DEVONthink data, and does not require additional authentication 
steps like Dropbox. But the similarities end there. CloudKit directly 
writes to and reads from cloud storage rather than relying on a 
hidden folder within iCloud Drive, making it significantly faster and 
more reliable than the legacy method. It’s also more transparent, as 
DEVONthink can accurately report syncing progress. Changes are 
reflected almost immediately, and no additional storage space is 
required on the initial sync. 

• iCloud (Legacy): The legacy version of iCloud syncing relies on 
iCloud Drive: DEVONthink copies its files to a hidden iCloud folder, 
and then iCloud Drive syncs them up to the cloud and down to your 
other devices…whenever it gets around to it. On the plus side, 
legacy iCloud sync (like the CloudKit version) requires no additional 
authentication steps. On the other hand, iCloud (Legacy) syncing is 
generally slower, DEVONthink is unable to show you sync progress 
accurately, and your initial sync with iCloud may temporarily 
require lots of extra disk space. Be sure to read Database Size 
Considerations, ahead, to understand how this works—which may 
not be what you expect! 
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Tip: If you are trying to decide on an iCloud sync method, choose 
CloudKit—period. There is no advantage whatsoever to using Legacy. 
It’s still supported, however, so that syncing doesn’t suddenly stop 
when you upgrade from an older version of DEVONthink. Unfortu-
nately, you can’t convert one method to the other. If you were 
already using what is now called Legacy, you’ll have to turn that off, 
set up CloudKit, and allow DEVONthink to resync from scratch. 

• WebDAV Server or CloudMe: You can sync your database to a 
WebDAV server on your local network or on a remote network. 
You’ll have to specify the server address, the path to the desired 
location on the server, a Store Name (the filename you want to use 
on the server), your username, and your password. (DEVONthink 
uses HTTPS and/or a custom port if those are included in the URL.) 
Because the cloud storage offered by CloudMe is accessible over 
WebDAV, you can use those as locations for a sync store, and 
DEVONthink even offers shortcuts to set up those services. 

Note: You may have noticed that this list does not include many 
other cloud providers, such as Google Drive, Amazon Cloud Drive, 
and Microsoft OneDrive. Even though such services can sync folders 
on your Mac’s disk, that type of external syncing (see External vs. 
Built-in Syncing) is not reliable for DEVONthink data. 

Regardless of how you choose to sync your databases, DEVONthink 
strongly encrypts your data using AES-256. For direct connections, 
DEVONthink encrypts the data in transit. For all indirect connections, 
the sync stores are encrypted as long as you enter an encryption key 
when setting them up (see Configure Syncing), which I recommend. 

Database Size Considerations 
As I mentioned earlier in the sidebar How Many Databases Do You 
Need?, DEVONthink’s performance can suffer if a single database 
grows too large. That applies to syncing performance too. Although 
there are no hard limits on database size, depending on variables such 
as the bandwidth of your internet connection, the sync method you 
use, and the kinds and sizes of files in your database, databases over a 
few gigabytes in size (give or take) might sync much more slowly than 
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you like on their initial upload or download—or if you routinely add 
very large files. If you have large databases and are frustrated by the 
pace of syncing, splitting them into smaller databases may help. 

But syncing speed isn’t the only thing to worry about when it comes to 
database size—you should also bear in mind disk space requirements. 
Direct connections, WebDAV/CloudMe connections, and iCloud 
(CloudKit) don’t use any extra space on your Mac for syncing, while 
local sync stores are typically on network volumes or other external 
storage. But iCloud (Legacy) does require extra storage on your main 
disk, at least temporarily—however large your DEVONthink databases 
are, you’ll need that much space again for your initial sync, though 
that space will free up again afterwards. (Dropbox sometimes needs 
extra space too, but we’ll get to that in a moment.) If you have loads of 
empty space on your disk, there may be nothing to worry about. But if 
you’re highly constrained in your storage space, this fact may give you 
yet another reason not to opt for iCloud (Legacy). 

When you select Dropbox as a sync location, DEVONthink initially 
copies all your data to Dropbox’s servers, and then—assuming you 
have the Dropbox app installed—the Dropbox app copies all that data 
back to the Apps/DEVONthink Packet Sync folder inside your Dropbox. 
Afterwards, every time you sync, changes in your DEVONthink data-
base—still stored in its original location—are sent to the copy in your 
Dropbox, while any changes in the Dropbox copy of your database are 
absorbed into your main copy. The direct connection between 
DEVONthink and Dropbox means it works even if you don’t have the 
Dropbox app installed on your Mac. And it’s faster and more reliable 
than letting Dropbox sync the files externally. 

If you leave it at that, the amount of hard disk or SSD space on your 
Mac used by DEVONthink will double: the original copy of your 
DEVONthink database will still be in ~/Databases or wherever you put 
it, and a second copy will be in your Dropbox folder. (The same goes 
for any other Macs that use the same Dropbox account.) But you can 
avoid the storage hit by turning on Dropbox’s Selective Sync option for 
your DEVONthink data, as I explain in Add an Indirect Connection, 
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ahead. This feature lets you pick and choose which of your Dropbox 
folders are stored locally on any device. 

With iCloud (Legacy), DEVONthink makes local copies of all your files 
in the iCloud Drive folder; then, after they sync (which may take longer 
than with Dropbox, as it’s handled by macOS), DEVONthink deletes 
those local copies. Although it isn’t quite like Dropbox’s Selective Sync, 
you do get approximately the same end result—but only after syncing 
is complete. That means you’ll need to have at least as much free space 
on your disk as the size of your database for your initial sync; and 
afterwards, the amount of storage space used will rise and fall as files 
are synced and then the extra copies are deleted. iCloud (CloudKit), by 
contrast, enables DEVONthink to read from and write to cloud storage 
directly, without the extra folder on your disk. 

In sum, if you have very little free space on your Mac—or if you want 
the best syncing performance—either iCloud (CloudKit) or Dropbox 
will be a better choice than iCloud (Legacy), and of the two, iCloud 
(CloudKit) has the advantage of not requiring you to jump through any 
additional hoops to exclude that extra local copy of all your files. 

Choose Your Sync Method(s) 
Which option is best for you? That depends on numerous factors, such 
as database size (as I just described), which services you have accounts 
with, and personal preference. Personally, after having used Dropbox 
for a number of years, I switched to iCloud (CloudKit) once that option 
became available, and have never looked back. But then, I was already 
paying for 2 TB of iCloud storage, giving me plenty of room for my 
DEVONthink data; your mileage may vary. 

Once you’ve chosen one or more sync destinations for a given data-
base, you can optionally configure DEVONthink to sync automatically, 
manually, or on a recurring schedule. 
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Choosing a Sharing Strategy 
Suppose a colleague or family member needs access to all or part of 
your DEVONthink database from time to time. You can accomplish 
this in numerous ways. Which one is best? It depends on your needs: 

✦ Sync the databases directly: If both people have licensed 
copies of DEVONthink—running on Macs or iOS/iPadOS devices on 
the same network—and if the other person needs full access to an 
entire database on a regular basis, then a direct device-to-device 
sync is most efficient. 

✦ Sync the databases indirectly: If both people have DEVONthink 
but are on different networks, or if you can’t guarantee that both 
copies will be running at once, syncing to a mutually accessible 
location (such as cloud storage, a shared network volume, or a 
WebDAV server) is the easiest way to ensure full access to a 
database. 

This chapter covers these first two types of syncing, both of which 
can also be used with DEVONthink To Go (see Use DEVONthink To 
Go). However, depending on your needs, a different method of 
sharing DEVONthink data might work better for you: 

✦ Use the built-in web server: If the other person mainly needs 
to view documents in your database or occasionally create or 
upload new ones (but not modify existing documents), or when it 
doesn’t make sense to use the disk space and network bandwidth 
required to sync an entire database to another location, you can 
Use DEVONthink’s Web Server (which requires DEVONthink 
Server). 

✦ Share or export the data: When the other person needs only 
a single document, or only a handful of documents—and it’s not 
crucial to have access to updated versions of these documents 
later—you can send them via email (select one or more documents 
and choose Send by Email from the Actions menu), Share 
Data using the Share pop-up menu, or Export Data and then 
share it over a network or on physical media of some kind. 
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Configure Syncing 

Syncing is quite easy—it takes much longer to explain it than to set it 
up! The procedure requires three quick steps: Add a Location, Select or 
Import Your Database(s), and Set Syncing Options. You must go 
through these steps on each device you want to sync. 

Note: DEVONthink To Go uses the same sync mechanism as the Mac 
version of DEVONthink, but I don’t go into detail about setting up 
syncing on an iOS/iPadOS device in this chapter. For that, see Config-
ure and Sync DEVONthink To Go in the next chapter. 

All the following steps take place in Settings/Preferences > Sync, which 
initially looks like Figure 82. 

Figure 82: DEVONthink’s Sync preference pane looks like this before 
you configure syncing. 
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Add a Location 
The Locations list on the left side of the Sync preference pane shows 
all the locations to which you can sync DEVONthink. The list includes 
any Macs on your local network that are running DEVONthink and 
configured to accept incoming Bonjour connections, and one instance 
each of the various other account types. (You can add more, if need 
be—for example, you can have multiple CloudMe accounts, multiple 
WebDAV accounts, and so on, but only one iCloud account, though 
both CloudKit and Legacy methods can be selected at once. You’re also 
limited to one Dropbox account, though that account can contain 
multiple sync stores.) 

To add a location, select its checkbox and fill in the relevant details 
in the dialog that appears. Each location asks for slightly different 
information, and in particular, the details differ significantly between 
direct connections (discussed next) and indirect connections such 
as Dropbox, iCloud (CloudKit or Legacy), and WebDAV (see Add an 
Indirect Connection). 

Add a Direct Connection 
For direct connections, there’s not even a checkbox to select until 
you set up one of your Macs to function as a server (see Set Bonjour 
Options, just ahead). However, once you’ve done so, connecting from 
another device requires little more than entering your password (see 
Connect to a Local Mac). 

Direct connections are different from all the other location types in 
that you’re not syncing all devices to a central location; instead, one 
device (a Mac, for the purposes of this chapter) functions as a server 
and your other devices function as clients. Whichever Mac is going 
to be the server has to be set up before any of the clients. Syncing 
works the same way regardless of which Mac you choose as the server. 
If you have one Mac that’s on and connected to your network all the 
time, that one would be a better choice for a server than a Mac that 
spends a lot of time turned off, asleep, or offline. Other than that, the 
choice is pretty arbitrary. 
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Once you’ve chosen a Mac to function as the server, you must set its 
Bonjour options (as described next). Then, on the other Macs on your 
network, follow the steps under Connect to a Local Mac. 

Set Bonjour Options 
On the Mac you want to function as a server, click Bonjour Options 
and fill in the dialog that appears (Figure 83). 

Figure 83: Set up incoming connections in this dialog. 

Here are the options: 

• Enable incoming connections: Select this to permit DEVON-
think on this Mac to accept connections from DEVONthink on other 
devices on your local network. (If this is deselected, then regardless 
of your other settings, this Mac cannot function as a server.) 

• Open databases automatically: Once you’ve set up syncing and 
selected databases from this Mac on another device, you might 
(accidentally or intentionally) close one of those databases on this 
Mac, which would prevent it from syncing to your other devices. To 
avoid that problem, select this checkbox, which permits clients to 
request that this Mac open any databases previously set up for 
syncing when a sync is required. 

• Port: This is optional. If you leave it blank, DEVONthink picks 
a random, high number—and that’s fine for most users. However, if 
you want to use a specific port number (perhaps because of a fire-
wall configuration on your network), enter the port number here. 
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• Password: A password is mandatory; it enables DEVONthink to 
encrypt your data while it’s in transit over your network, and pre-
vents eavesdropping. 

After you’ve filled in a password and at least selected the first check-
box, click OK. Once you’ve done that, this Mac appears in the Loca-
tions list as an option for other Macs and iOS/iPadOS devices on your 
local network. On those devices, you can then proceed to the next 
topic. 

Connect to a Local Mac 
Once you have a server set up to receive connections, go to your next 
Mac, open Settings/Preferences > Sync, and select the checkbox next 
to the first Mac’s name in the Locations list. In the Password alert that 
appears (Figure 84), type the password you set up on the server Mac. 
(You don’t even need to press Return or click OK!) That’s it—you’re 
connected. Proceed to Select or Import Your Database(s). 

Figure 84: Enter the password you set up on the server Mac here. 
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Don’t Do Mutual Syncs 
Let’s say you’ve set up Mac A as a server (by selecting “Enable 
incoming connections” in Bonjour Options), and you’ve set up Mac B 
to be a client (by selecting Mac A in Mac B’s Locations list). You may 
be tempted to do the reverse, too—enable incoming Bonjour connec-
tions on Mac B, and select Mac B as a sync location on Mac A. Don’t 
do that! 

All syncs in DEVONthink are bidirectional. So it’s unnecessary—and 
indeed, a bad idea—for two Macs to function as both server and client 
for each other. Doing so won’t solve any problems, but it will de-
crease performance, and may increase the likelihood of sync errors. 

Add an Indirect Connection 
For indirect connections (all locations other than direct connections), 
after you select the appropriate checkbox in the Locations list, you 
must specify account and sync store settings in a dialog (Figure 85). 

Figure 85: This dialog appears after you select WebDAV in the 
Locations list. (Other locations display variations on this dialog with 
fewer controls.) 
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The fields and controls in this dialog vary somewhat from one location 
to another. You may see one or more the following: 

• URL: For WebDAV locations only, enter the server’s full URL. (For 
local sync stores, in place of a URL, a standard file selection dialog 
appears; use its menu to select a location.) 

• User Name and Password: For WebDAV locations, enter the 
credentials you use to log in. 

• Sync Store Name: If prompted, enter a name for the sync store— 
that is, the package that’s stored in your Dropbox, on a local server, 
or wherever you choose—that serves as the central repository for 
syncing between this Mac and other devices. (For local sync stores, 
the field is labeled Save As.) 

What sort of name should you enter? Well, the sync store can hold 
sync data for multiple databases if you like, so you may not want to 
name it after a particular database. It can also sync data from many 
devices, so you shouldn’t name it after your Mac. In fact, the only 
reason the name might matter is if, for some reason, you wanted to 
set up multiple sync stores in the same location. So, enter anything 
you like here, though for compatibility reasons, it’s safest not to 
include spaces or punctuation other than hyphens and underscores. 
(I named mine HomeDepot. As in, you know, a store where you can 
buy sinks. Because that’s how I roll.) Once you’ve set up a sync store 
for one device, you should enter exactly the same name when 
setting up additional devices. 

• Encryption: If you want your sync store to be encrypted—and you 
absolutely do!—enter and verify a password in the fields provided. 

• Options: The bottom of the dialog has a series of checkboxes that 
let you specify sync options for this sync store: 

‣ Synchronize label names & colors: Choose whether to sync label 
names and colors (see the sidebar Using Labels and Flags) using 
this sync store. It’s optional because this is a global preference, 
not a database-specific preference, and you may want different 
copies of DEVONthink to use different label names or colors. 
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‣ Synchronize reading list & positions: Select this to synchronize 
reading and playback positions along with document contents. 
(This applies to PDF, plain text, rich text, Markdown, audio, and 
video files.) 

‣ Synchronize custom metadata definitions: This option, selected 
by default, lets you sync Custom Metadata definitions across 
devices. 

‣ Synchronize content of indexed items: By default, DEVONthink 
syncs the content of any indexed items (that is, items whose 
original files are not stored within your DEVONthink database), 
so you can view and work with the files on your other devices. 
However, if you deselect this checkbox, DEVONthink syncs only 
their metadata, not the original files themselves. 

Note: This option must be selected if you’ll be syncing your data to a 
mobile device running DEVONthink To Go. 

‣ Verify uploaded items: Select this checkbox to make DEVON-
think verify the integrity of each file after it has uploaded to 
another device. This option is usually unnecessary (and may 
slightly increase the amount of time each sync requires), but if 
you experience missing or corrupted files during syncing, you 
can enable it to confirm that each transfer took place correctly. 

Once you’ve filled in the dialog with all required information, click OK. 
DEVONthink copies your sync store to the location you selected. 

You can then move on to Select or Import Your Database(s)—unless 
you added a Dropbox location, in which case you should complete a 
few additional steps first: 

1. If your web browser opens automatically to a sign-in page for Drop-
box, enter your Dropbox username and password, and click Sign In. 
(If your browser does not open automatically, skip to step 5.) 

2. If you have Dropbox’s two-factor authentication enabled (always 
a good idea, though not a requirement to sync with DEVONthink), 
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you’ll be prompted to enter your authentication code. Do so and 
click Submit. 

3. Click Allow to give DEVONthink access to its own folder (and no 
other folders) in your Dropbox. 

4. Your browser should return you to DEVONthink to finish the setup 
process; if it doesn’t, you can switch back manually. 

At this point, DEVONthink begins copying your sync store to Drop-
box—but you aren’t done yet. I strongly recommend that you use 
Dropbox’s Selective Sync feature to avoid storing a local copy of the 
synced data, as I described in Database Size Considerations. To do 
this, continue with the remaining steps. 

5. Go to the Dropbox menu on the menu bar. 

6. Click your account photo or avatar in the upper-right corner, and 
choose Preferences from the pop-up menu. 

7. Click Sync, then click “Select folders” under Selective Sync. 

8. Navigate to Apps and deselect the DEVONthink Packet Sync check-
box (Figure 86). 

Figure 86: Deselect the DEVONthink Packet Sync checkbox to avoid 
making a duplicate copy of your sync data on your Mac. 
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9. Click Update. 

Dropbox may take several minutes to remove the local copy of that 
folder. 

Note that even though this procedure removes the sync folder from 
your Mac, it’s still stored on the Dropbox servers, so you’ll need to be 
sure you have enough storage space in your account to hold it. And, 
you’ll have to repeat this procedure on each of your Macs. 

Note: For most users, a single sync location is adequate. However, if 
you need to add more than one account of a particular type (as in, 
two Dropbox locations), you can click the plus button on DEVON-
think’s Sync preference pane and choose the desired account type 
from the pop-up menu. 

Select or Import Your Database(s) 
Now that you have a location (or more than one) configured, you must 
next determine which databases will sync to that location. You can 
sync all your databases to the same location, each to a different one, or 
certain databases to each of several locations—whatever you like. The 
most common scenario is to sync any given database to just one 
location. 

With your location selected in the Locations list on the left, look in the 
Databases list on the right. (Figure 87 shows the list as it might 
appear for a direct connection.) 

230 



     
        

   

          
           
            
             

            
            

           
          

           
 

  
            

          

Figure 87: With a location selected (that is, not just checked, but 
also highlighted) on the left, select which databases to sync with that 
location on the right. 

The LOCAL portion of the Databases list contains the databases 
currently open on this Mac. In the REMOTE portion, for direct con-
nections, you’ll see databases open on the other Mac that can be 
imported (or opened, if they already exist on your Mac but are closed); 
for indirect connections, you’ll see databases in the sync store that do 
not already exist on this Mac. (If you previously synced a database 
between these two Macs in some other way—using file sharing, an 
external sync utility, or the previous version of DEVONthink’s syncing 
capability, for example—and it’s open on both Macs, it appears in the 
LOCAL section.) 

Sync a Local Database 
To sync a database in the LOCAL category, simply select its checkbox. 
If the location is anything but a direct connection, DEVONthink 
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immediately begins uploading your data to the sync store (or, if the 
database already exists in the sync store, merging it). 

Note: Because DEVONthink treats your global Inbox as a separate 
database, you must select Global Inbox separately from any other 
databases. 

Sync a Remote Database 
To sync a database in the REMOTE category, you must import it, thus 
creating a local copy. To do so, double-click the database in the RE-
MOTE portion of the list. Leave the database’s name as it is in the 
remote location, navigate to where you want it to be stored, and click 
Create. DEVONthink imports the database, enables syncing, and 
begins the sync process immediately. 

Tip: To import a remote database as an encrypted database, instead 
select it in the REMOTE portion of the list, right-click (or Control-click) 
it, and choose Import Encrypted Database from the contextual menu. 

Use Additional Sync Controls 
Under the Databases list are two additional icons you may find useful: 

• Sync now: Click the Force Sync button to force an immediate 
sync, if syncing is not set to Automatic (see just ahead). 

• Refresh: If the list of databases on this Mac, on the remote Mac, or 
in the sync store changed recently and the current selections don’t 
appear here, click the Refresh button to refresh the view. 

Set Syncing Options 

The final three syncing options can be set at any time (including before 
setting up locations and databases). These settings, at the bottom of 
the Sync preference pane, apply to all locations and databases: 

• Synchronize: When this pop-up menu is set to Automatic, the 
default, DEVONthink frequently checks for changes in both remote 
and local copies of each database and syncs them with the other 
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location soon after they occur. If you prefer to sync on a fixed 
schedule, you can instead choose “Every minute,” “Every 5 
minutes,” “Every 15 minutes,” “Every 30 minutes,” Hourly, or Daily 
from this menu. Or choose Manually to sync only when you Click 
the Force Sync button. If you also want DEVONthink to sync 
when you quit the app, even if it’s not otherwise time to do so, check 
On Quit or Deactivation. (This can avoid surprises of last-minute 
changes that weren’t synced, though it also prevents DEVONthink 
from quitting instantly.) 

• Max. Connections: DEVONthink can open up to 16 multiple, 
simultaneous connections to any location (8 for Dropbox), enabling 
it to copy multiple documents at the same time. If you suspect that 
DEVONthink is slowing down your network because it has too 
many connections active, you can reduce this number. 

• Conflicts: If a document changes both locally and remotely be-
tween syncs (a rare occurrence when Synchronize is set to Automat-
ic and you have a fast network connection), this set of controls 
determines what will happen. If you select “Use latest document,” 
the more recently changed document will overwrite the older one. 
If you select “Duplicate documents,” both copies sync in both 
directions—preventing data loss, but forcing you to manually sort 
out, later on, which version of each document you want. 
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Use DEVONthink To Go 
If you have an iPhone, iPad, or iPod touch, you can take your DEVON-
think data with you and work with it when you’re away from your Mac. 
For that matter, you can use the majority of DEVONthink’s features on 
the go even if you don’t have a Mac at all! To do this, you’ll need an 
iOS/iPadOS app called DEVONthink To Go, at version 3.5.4 as of 
publication time. 

With DEVONthink To Go 3, following a one-month free trial, you have 
three pricing options: 

• You can pay a one-time fee of $39.99 to purchase DEVONthink To 
Go 3 outright. 

• You can subscribe to DEVONthink To Go for $1.99 per month or 
$14.99 per year. 

• If you were already using DEVONthink To Go 2.x, you’ll get a dis-
count on the one-time purchase ($19.99 instead of $39.99) if you 
choose that route. 

Of these, the one-time purchase (with or without the discount for being 
a user of the previous version) seems the most cost-effective to me. 

Note: As of version 3.5, DEVONthink To Go requires iOS 14/iPadOS 
14 or later. 

When you install DEVONthink To Go 3 on a device that already has 
version 2 installed, it automatically migrates the data and settings 
from the old app on first launch. (If you really want to, you can run 
both versions side by side, but unless you’re just trying out version 3 
while trying to decide if you want to purchase it, there’s no point in 
doing so.) 

Although DEVONthink To Go 3 doesn’t have all the features that the 
desktop versions of DEVONthink do, it does have a surprisingly rich 
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range of capabilities for viewing, creating, capturing, and managing 
information directly on your iOS or iPadOS device. 

Note: The list of new features in version 3 is quite long, and I won’t 
cover them all here, but highlights include syncing via CloudKit, dark 
mode support, multiple windows in iPadOS, context menus, OCR, 
Shortcuts actions (iOS/iPadOS only), unified inboxes, and more global 
smart groups. 

If you have no iOS or iPadOS device, or if you’re not interested in 
taking your DEVONthink data with you, there’s nothing to see here— 
move on to the next chapter, Get Information Out of DEVONthink. 
Otherwise, keep reading to learn about using this extremely handy 
tool. 

Get to Know DEVONthink To Go 

Just as DEVONthink for Mac is a complex product, DEVONthink To 
Go is quite deep, with a huge number of features that may not be 
obvious at first glance. Detailing all those features would require its 
own book, and I can offer only an overview in this chapter. I do, 
however, suggest you download the user handbook for DEVONthink 
To Go, which is available in PDF, EPUB, and Mobipocket formats. 

So, what can DEVONthink To Go do? It appears to have, at a rough 
estimate, about 80% of the capabilities of the desktop versions of 
DEVONthink. For example, here’s a partial list of what you can do in 
DEVONthink To Go: 

• Sync data from DEVONthink for Mac (or DEVONthink To Go 
running on other iOS or iPadOS devices) via Dropbox, iCloud 
(CloudKit or Legacy), CloudMe, WebDAV, or a Bonjour connection 
over Wi-Fi 

• View any document type supported by iOS/iPadOS 

• Capture data from other apps (such as bookmarks, PDFs, text, and 
images) to a specific database or your global Inbox 
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• Create new databases, groups, and tags 

• Create and edit documents in plain text, rich text, Markdown, and 
formatted note formats; rotate and apply filters to graphics; anno-
tate PDFs; and convert (most) documents to other formats 

• Move, duplicate, replicate, group, tag, or delete items 

• Perform OCR on photos or scanned documents 

• Use complex search criteria to find your documents 

• Share documents using the share sheet 

• View and add to your Reading List (as a built-in smart group) 

However, you should also be aware of some limitations compared to 
the desktop versions of DEVONthink. Among the features DEVON-
think To Go does not include are the following: 

• Indexing documents stored elsewhere on your iOS/iPadOS device 

• Creating new smart groups, or using smart groups created on your 
Mac (but you can tap Edit on the home screen to use any of more 
than 20 built-in smart groups) 

• Editing RTFD documents (RTF with graphics) 

• Splitting or merging documents 

• The Concordance feature 

In short, DEVONthink To Go lets you view and manage your DEVON-
think databases effectively with an iOS/iPadOS device, and can also 
function as a standalone tool for gathering and organizing informa-
tion—but if you’re a power user, you’ll most likely find that it can’t 
replace the desktop versions of DEVONthink. 

Configure and Sync DEVONthink To Go 

Assuming you want to use DEVONthink To Go mainly to store copies 
of documents from your desktop version of DEVONthink, you should 
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configure syncing, and perform your first sync, before doing anything 
else. 

As in the desktop versions of DEVONthink (see Sync DEVONthink 
Databases), sync configuration involves three elements—first add a 
location, then select databases, and finally (or whenever you prefer) set 
syncing options. 

Add a Location and Select Databases 
To add a location and select databases to sync in that location: 

1. If you’re not already on the home screen (where the global Inbox, 
smart groups, and databases live), tap the arrow in the upper-left 
corner of the screen until you get there. 

2. Tap the Settings icon. 

3. In the Sync section, next to Locations, tap Edit Locations. 

Note: You can also set up your iOS/iPadOS device to be a sync 
server; tap Bonjour > “Enable incoming connections” to do so. This 
feature works similarly to the equivalent Mac version; see Set Bon-
jour Options. 

4. Tap the green plus icon next to the location type you want to add. 
(If you already have a location specified, tap Edit to see the list of 
locations.) For Dropbox accounts, follow the prompts to authenti-
cate; for direct connections, enter the password when prompted. 

5. For indirect connections such as Dropbox, iCloud (CloudKit or 
Legacy), and WebDAV, enter the requested information, which may 
include the sync store name and password; and, if applicable and 
desired, turn on Verify Uploaded Items. If you already set up a sync 
store on another device, use its name and encryption key. (Refer 
back to Add an Indirect Connection for details on these options.) 

6. Tap Always to download full copies of every document, or On De-
mand to sync only metadata (with full documents available at a 
tap). 
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Note: If you choose On Demand here, you can override that setting 
for a given database or group, so that just that subset of your files 
sync all the time; see the sidebar On-Demand Syncing, ahead. 

7. Select whether you want to sync “Labels and Colors” and/or “Read-
ing positions” (both on by default; again, see Add an Indirect Con-
nection). 

8. Tap Save. 

At this point, your location has been created, and you need only select 
which databases to sync in that location: 

1. Tap the location name. 

2. Turn on the switch for each database in this location that you want 
to sync. 

DEVONthink To Go starts syncing your data. While that’s happening, 
you can tap outside the location window to perform other activities in 
DEVONthink To Go. You can touch and hold the Cloud icon at any 
time to display the current sync progress. 

Tip: If you’re using an iPhone or an iPad with a cellular radio, you 
might want to prevent DEVONthink To Go from syncing over a cellu-
lar connection. To do so, go to the main iOS/iPadOS Settings app, tap 
DEVONthink, and turn off Cellular Data. 

Set Sync Options 
Either before or after you set up locations and select databases, you 
can configure sync options, which are similar to those in the desktop 
versions of DEVONthink (refer back to Sync DEVONthink Databases): 

1. If you’re not already in the Settings window, go to the home screen 
of DEVONthink and then tap the Settings icon. 

2. Set the following options as you prefer: 

‣ Conflicts: Tap an option to choose what happens if a document 
changes both locally and remotely between syncs. If you select 
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Newest, the more recently changed document overwrites the 
older one. If you select Duplicate, both copies sync in both direc-
tions—preventing data loss, but forcing you to manually sort out, 
later on, which version of each document you want. 

‣ Schedule: Tap Automatic (the default) to make DEVONthink 
watch for changes and upload or download new or changed 
documents automatically (which does not necessarily mean 
“instantly”). Or tap Manually to sync only when you tap the 
Cloud icon or swipe downward to initiate a sync. 

‣ Keep: This slider is applicable only in cases where you’ve select-
ed On-Demand Syncing. If it’s set all the way to the right (“Keep 
all”), DEVONthink To Go keeps local copies of all downloaded 
files. If you want DEVONthink To Go to purge the contents of 
less-recently-used files (keeping only the metadata, so you can 
re-download the files as needed), move the slider to the left (to 
“Keep 100 items,” “Keep 250 items,” “Keep 500 items,” or “Keep 
1000 items”). DEVONthink purges the contents of any older files 
over that number. 

3. Tap the close icon to close the Settings window. 

Your new sync options apply immediately. 
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On-Demand Syncing 
You have the option to sync only the metadata for your files rather 
than all their contents (saving a great deal of storage space and 
making syncing go much more quickly). Once you’ve done this, when 
you select a document that hasn’t yet been copied to your mobile 
device, you can tap a Download link to download a local copy imme-
diately. 

You may want to use on-demand syncing as a default setting for your 
location but override it for particular databases or groups that you 
want to sync all the time. (However, if an entire location is set to 
Always, you can’t override that setting for individual databases or 
groups.) To change your on-demand sync settings: 

✦ For a location, tap Settings > Locations > Edit and tap the Edit 
link next to a location name; then tap Always or “On demand” and 
tap Save. 

✦ For a database or group open the database or group, and at its 
top level, tap the Info icon. Then tap Always to keep every-
thing in that database or group synced or “On demand” otherwise. 

Find Your Way Around 

Like most iOS/iPadOS apps, DEVONthink To Go has a predictable, 
hierarchical interface, which reconfigures itself depending on the size 
and orientation of your device’s screen. You should be able to navigate 
it without much difficulty. However, I would like to bring a few less-
than-obvious things to your attention. 

The Home Screen and Sidebar 
On an iPhone, the home screen (the top level of DEVONthink To Go) is 
special—that’s where you find your inboxes, tags, Trash, smart groups, 
and databases; and it’s also where you see the Settings icon. If 
that’s where you want to be, tap whatever text is in the upper-left 
corner of the screen until you get there. 

On iPads, DEVONthink To Go uses a three-column view, similar to the 
one in Apple Mail. The sidebar—the leftmost column—contains the 
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controls that are on DEVONthink To Go’s home screen in iOS, includ-
ing Settings . Next to that is a folder list, and to its right is a portion 
of a selected document. However, when you tap a document, the 
sidebar slides out of view. To bring it back, tap DEVONthink in the 
upper-left corner. 

Note: DEVONthink To Go 3 adds unified inboxes and tags, as in the 
Mac version. These are enabled by default, but if you prefer to see 
the individual inbox and tags for each database on the home screen, 
tap Settings and turn off “Unify inboxes” and/or “Unify tags.” 

On the home screen (or, on an iPad, the in the sidebar), tap Edit in the 
upper-right corner to display additional smart groups, reorder smart 
groups, or delete databases. 

List Views 
In other list views (that is, the top level of a database, or the contents 
of any group), tap the View Options icon to display options for 
sorting the list (by name, kind, date, URL, rating, label, or size— 
ascending or descending), filtering it (displaying only items with 
certain metadata characteristics), displaying summaries in various 
formats, and toggling the display of details and hidden items. 

Tap Edit to reveal controls you can use to select one or more items. 
Having selected them, you can tap the Organize icon to move, repli-
cate, duplicate, convert, group/ungroup, or delete them; or, if a single 
item is selected, tap the Share icon to display the share sheet. (Note 
that the item(s) must be downloaded to your device before you can 
share it, duplicate it, or move it to another database.) 

Tip: You can select multiple items at once by swiping up or down 
over the selection circles on the left side of an item list. 

Multiple Windows on iPad 
DEVONthink To Go 3 supports multiple windows on iPads (where a 
“window” is really an additional split-screen view of DEVONthink). 
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You can create a new window in either of these ways: 

• Touch and hold an item name, then tap Open in New Window on 
the context menu. 

• Select the item, tap the Share icon, and tap Open in New Window 
on the share sheet. 

A split view appears with the selected item shown on the right. You can 
then drag the divider left or right to change the size of the split view, or 
drag it all the way to one side of the screen to remove the split. 

Note: DEVONthink To Go 3 also gains basic mouse pointer support. If 
you have a supported iPad model, you can connect a Bluetooth 
mouse or trackpad to your iPad, and use the pointer (which appears 
as a gray circle) to manipulate controls in DEVONthink To Go much as 
you would otherwise do with a finger. 

Searching 
To search for a document in DEVONthink To Go, look for the search 
field at the top, and if you don’t see it, swipe downward on the list to 
reveal it (just as in Mail for iOS/iPadOS). Enter the text you’re search-
ing for. If you’re anywhere other than the home screen, you can tap 
“All databases,” “This database,” or “This group” to narrow your search 
to that location. 

As you type, DEVONthink To Go immediately returns matches that 
appear in the titles of documents and groups; if you want to search 
contents as well, tap Search. 

Note: Just as in the desktop versions of DEVONthink, you can use 
parentheses, quotation marks (to search for a phrase), Boolean 
operators (AND, OR, and NOT), and the word NEAR when constructing 
your searches. You can also add an asterisk * at the end of a partial 
word as a wildcard to find matches that begin with the characters you 
entered. (The asterisk is implied for partial matches while typing, but 
must be entered explicitly to aid in matching after you tap Search.) 
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You can also search within the text of an open PDF document (sorry, 
other formats aren’t supported) by tapping the Search icon. 

Context Menus 
DEVONthink 3 adds contextual menus (or “context menus,” in DE-
VONthink’s terminology) to give you quick access to commonly used 
commands. To display one of these menus, touch and hold any docu-
ment, group, database, or search result. As the name suggests, these 
menus have different contents depending on what is selected; Figure 
88 shows an example with a PDF selected. Menu commands followed 
by an ellipsis (…) display submenus with additional commands. 

Figure 88: A context menu as it appears with a PDF selected. 
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Add Items to DEVONthink To Go 

In addition to items you’ve synced from your Mac or a different iOS/ 
iPadOS device, you can add many kinds of items to DEVONthink To 
Go right on your iOS/iPadOS device. The two most common approach-
es are creating a new document (or group, or other item) within 
DEVONthink To Go (discussed next) and adding content from other 
apps using the Clip to DEVONthink extension (see Use Clip to 
DEVONthink). 

Create and Edit Content 
To create a new document or other item in DEVONthink To Go, 
navigate to the location where you want the document to be stored and 
tap the plus icon. A panel appears, which may show just a list of 
item types (on smaller screens) or item types plus an editing area (on 
larger screens). Select an item type from the list of choices, and then 
use the editing view to fill in the details. Your choices are: 

• Text from Clipboard: If you happen to have text on the clip-
board, you can tap this to create a plain or rich text (as appropriate) 
document containing that text. 

• Text: Create a document in plain text, rich text, Markdown, or 
formatted note formats. Fill in the title and body of the document, 
and optionally apply metadata (see Apply Metadata, ahead, for 
details). Then click the tiny right arrow in the upper-right corner 
of the editing view, tap the name of the format you want to use, and 
tap Done. 

Note: If your clipboard already contains text copied from another 
app, DEVONthink prefills it in a Text document. If you don’t want to 
use it, then on an iPad, just tap a different document type followed 
by Delete. On an iPhone, tap the left arrow icon in the upper-left 
corner of the panel followed by Delete; then tap a different document 
type. 
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• Media: Tap New Photo (to take a photo), Existing Photo (to add a 
photo already in your Photos library), Photo from Clipboard (only 
if there already is a graphic on your clipboard), Last Photo Taken, 
Video Note (to record a new video), or Voice Note (to record audio). 

• Bookmark: Enter a name and URL for the bookmark, and option-
ally apply metadata. 

• Sheet: After tapping Sheet, tap the Add Heading icon and type a 
name. Press Return and repeat as needed. Then click the tiny right 
arrow in the upper-right corner of the editing view, enter a name 
for the sheet, and tap Done. DEVONthink To Go creates a new, 
empty sheet in that location; tap it to open it. To edit a table, tap 
Edit. You can then double-tap a cell to change its contents, or use 
the controls on the floating toolbar to select, add, and delete col-
umns and rows, among other actions. 

Note: The current version of DEVONthink To Go provides no way to 
change column types or formatting, as the desktop versions of 
DEVONthink do (see Sheet). 

• Tag: Type a tag name. (Normally, you create tags in the process of 
applying them to existing items, but if for some reason you need to 
create a standalone tag, this is how you do it.) 

• Group: Type a group name and optionally apply metadata. 

• Database: Type a database name. To protect the database data 
during syncing with a password, turn on Protect with Password, tap 
Proceed after reading the warning, enter a username, and enter and 
confirm a password. This does not encrypt or lock the database; it 
only encrypts data in transit during syncs. 

• From Template: DEVONthink To Go now offers templates for 
creating new PDF documents. (It’s not yet as fully featured as the 
Template feature in the Mac version, but it’s a start.) Tap From 
Template to see a selection of predefined templates for PDF docu-
ments. You have a choice of various combinations of page size (US 
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Letter, US Legal, and A4), background (Blank, Lined, and Grid), 
and orientation (portrait or landscape). 

After filling in the required information, tap Done. 

You can also edit plain text, rich text, formatted note, and Markdown 
files, plus (to a limited extent) graphics—whether or not you created 
them in DEVONthink To Go. To do so, select the document and either 
tap in the document body or tap Edit at the top of the screen. When 
you’re finished making changes, tap Done. (Note that, for graphics, 
your only options are to rotate the image and apply filters using the 
icons at the bottom of the screen.) 

It’s All About Location 
When you create any new document in DEVONthink To Go, the 
document can automatically record your geographic location—where 
you were when you created it—as metadata. (In order for this to 
work, you must have agreed to let DEVONthink To Go know your 
location when it prompted you to do so—if you’re unsure, open the 
Settings app, tap DEVONthink > Location, and make sure While Using 
the App is checked. If you don’t see that setting there, you may need 
to wait until DEVONthink prompts you again for location permission.) 
You can later see this location data by opening a document, tapping 
the Organize icon followed by Info, and looking in the Geolocation 
field. 

Use Clip to DEVONthink 
In iOS and iPadOS, Clip to DEVONthink is a system-wide extension 
that can add an icon to the share sheet in nearly any app. By tapping 
that icon, you can capture information from elsewhere on your device 
and add it to DEVONthink. 

Before you use Clip to DEVONthink, you should make it more easily 
accessible—this step is optional (but a good idea): 

1. Open a document or webpage in any app that supports share sheets 
(such as Safari). 
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2. Tap the Share icon, swipe the row of app icons toward the left, 
and tap More. 

3. Enable the extension: Tap Edit. Then scroll down until you find 
DEVONthink. Make sure its switch is turned on, and tap the plus 
icon to add it to the Favorites list at the top. 

4. Use the handle on the right to drag it closer to the top (which means 
it will appear closer to the left in the list of icons in the future). 

5. Tap Done. 

Once you’ve done this, you can use almost the same procedure to 
capture information: 

1. While viewing content you want to capture in to DEVONthink To 
Go, tap the Share icon. 

2. Tap the DEVONthink (or Clip to DEVONthink) icon. (If you did not 
add DEVONthink to your Favorites list, you can instead swipe to the 
left, tap More, scroll in the list until you find DEVONthink, and tap 
it.) 

3. In the panel that appears, you can optionally edit the document’s 
name and metadata. The Database line indicates which database the 
item will be stored in; to pick a different one, tap the database name 
and then select a different database or Global Inbox. 

4. Tap the right arrow icon. 

5. Tap the format in which you want to capture the document—Book-
mark, Web Archive, Web Archive (clutter-free), Markdown, Mark-
down (clutter-free), PDF, or PDF (clutter-free)—and tap Done. 

The extension puts the document in the inbox of the selected database 
(or in your global Inbox). 
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Importing PDFs from Other Apps 
The Clip to DEVONthink extension cannot send documents to DEVON-
think To Go in PDF format (as it can on a Mac). However, there are a 
couple of easy workarounds. 

One way is to use the Make PDF shortcut in the Shortcuts app. Tap 
Share followed by that shortcut to make the PDF; then tap Share 

again followed by DEVONthink or Clip to DEVONthink. (I talk about 
other ways of using Shortcuts with DEVONthink ahead in the sidebar 
Use Shortcuts with DEVONthink To Go.) 

Another way is to tap Share followed by Print. Then pinch out to 
expand the thumbnail at the bottom of the page so it fills the whole 
screen. Now tap the Share icon again followed by DEVONthink or 
Clip to DEVONthink. This extra step causes the document to be sent 
to DEVONthink as a PDF. 

Manage Documents 

Once you have documents in DEVONthink To Go—whether you synced 
them from your Mac or added them manually on your iOS/iPadOS 
device—you can do quite a few things with them. Here are some of the 
most useful examples. 

Organize Files and Groups 
With a single document or group open—or with one or more items 
selected in a list view in Edit mode—tap the Organize icon to 
display a pop-up menu (Figure 89) with the organizational options 
and numerous other commands. (Not all options apply to every item.) 
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Figure 89: This pop-up menu displays whichever organizational 
commands are relevant to the selected item(s). 

Your choices for organization are in the second group of commands: 

• Move: Navigate to the location where you want to move the item 
and tap Move. 

Note: Move and Duplicate require the documents to reside locally on 
your device. 

• Replicate: Navigate to the location where you want to create the 
replicant and tap Replicate. 

• Duplicate: Navigate to the location where you want to copy the 
item and tap Duplicate. 
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• Group: Create a new group containing the selected item(s). 

• Convert: Tap Convert followed by the format you want to use. (The 
options are To Bookmark, To Formatted Note, To Searchable PDF, 
To PDF (One Page), To Markdown, To Plain Text, or To Rich Text— 
but not all formats apply to every source document.) DEVONthink 
To Go makes a copy of the document in the same location, but with 
the new format. (If you were editing the document, the original 
version remains open.) 

• Add to Favorites: Add this item to your Favorites list. 

• Add to Reading List: Add this item to your reading list. 

• Create Thumbnail or Remove Thumbnail: Create or remove a 
thumbnail for the selected item. 

• Download: For documents in groups, databases, or locations 
configured to use on-demand downloads, tap this to download the 
document. 

• Purge: Removes the local copy of the item to free up space; it re-
mains in synced locations and can be re-downloaded. 

• Move to Trash: Move the item to the Trash. 

Tip: In any list view, you can swipe left on an item’s name to reveal 
buttons for Trash and Flag—this is much like the comparable gestures 
in Mail for iOS/iPadOS. 

Use Grid Mode to Organize Documents 
On an iPad or a larger-screen iPhone, while in any list view, you can 
tap the blue number to the right of a group name (which indicates 
how many item the group contains) to display the group’s contents as 
a grid of thumbnails. 

You can then touch and hold an item and drag it to a new location. If 
you drag a file onto another file, DEVONthink To Go makes a group 
containing those two files. (In other words, this is much like moving 
and grouping apps on the home screen.) 
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Apply Metadata 
Any document or group in DEVONthink To Go can have various kinds 
of metadata, just as in the desktop versions of DEVONthink. To apply 
this metadata to the currently open group or document, tap the Orga-
nize icon followed by Info, or press ⌘-Shift-I to open the Info 
popover (Figure 90). 

Figure 90: Apply metadata such as tags and labels in this popover. 

You can then specify or edit the following: 

• Name: Tap to edit the document or group name. 
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• URL: If the item is a URL, this field holds the bookmark’s location. 
For all other item types, you can optionally fill in any URL that’s 
relevant to it. Tap in the URL field to type or paste the URL. To 
open the URL in Safari, tap the Safari icon. 

• Tags: Tap the Tags icon, then type one or more tags. (After you 
type at least three characters, suggestions for matching tags may 
appear.) After typing a tag, tap Return; this turns it into a token 

. 

• Label: Tap the Label icon and then use the selector that 
appears to apply a predefined label (such as To Do, Done, or Impor-
tant). The Label icon then assumes the color of the corresponding 
label: . 

• Flag: Tap the Flag icon to flag the item. The icon then turns 
orange: . Tap it again to remove the flag. 

Note: For more on labels and flags, see the sidebar Using Labels and 
Flags. 

• Unread: Tap the Read icon to mark the item as unread. The 
indicator then turns blue to show that it’s unread; tap it again to 
mark it as read. 

• Lock: To make the item read-only, tap the Lock icon, which then 
turns magenta: . Tap it again to unlock the item, making it ed-
itable. If you have a keyboard attached, you can also lock/unlock 
with ⌘-Control-K. 

• Rating: Tap a star to set a rating. 

• Comments: To add a comment, type in the Comments field. 

Annotate PDFs in DEVONthink To Go 
As in the Mac version, you can annotated PDFs in DEVONthink To Go. 
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With a PDF open in DEVONthink To Go, tap Edit. A narrow vertical 
toolbar appears at the left with icons for various types of annotation 
actions (much like those in the desktop versions of DEVONthink): 

• Text Highlights: Touch and hold Highlight and then tap an 
icon to select a tool with which you can add a background color, 
underline, wavy underline, or strikethrough to text that you drag 
over with your finger. 

• Annotations: Touch and hold Text and then tap an icon to 
select a tool with which you can add a text annotation, callout, or 
signature. 

• Note: Tap the Note icon and then tap in the document to add a 
note. 

Note: Depending on screen size and orientation, some of these icons 
may be grouped with others (in various configurations); touch and 
hold any icon with a tiny arrow in the lower-right corner to see other 
tools. 

• Pen: Tap the Pen icon to draw with a pen on the PDF. 

• Highlighter: Tap the Highlighter icon to draw with a high-
lighter on the PDF. 

• Shapes: Tap and hold Shapes and then tap an icon to select a 
tool with which you can draw arrows, lines, squares, circles, and 
other shapes. 

• Photo: Tap Photo and then tap either Camera or Photo Library 
to insert a graphic on top of the PDF. Or, tap and hold Photo and 
then tap an icon for media, stamp (like “Approved” or “Sign Here”), 
clipboard, link, or audio recording. 

• Erase: Tap Erase to activate the eraser tool, with which you can 
wipe away annotations you made with the pen or highlighter. 

• Select: Tap Select to draw a selection rectangle, which selects 
any existing annotations. 
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In addition to all these tools, you can select text in a PDF to display the 
standard iOS/iPadOS pop-up toolbar with additional options. 

Note: Separately, DEVONthink To Go also adds support for the Mac 
version’s document-wide annotations, which are stored as separate 
files and can be added to any document type. To add an annotation, 
tap the Info icon, tap Add Annotation, and tap Edit. Type (or 
modify) your annotation, and then tap Done. 

Use Shortcuts with DEVONthink To Go 
The Shortcuts app in iOS and iPadOS offers powerful automation 
capabilities, and DEVONthink To Go can interact with Shortcuts in a 
variety of ways. The app adds 11 actions to Shortcuts, such as Create 
Item, Find Items, Get Content of Item, and Update Item Metadata, as 
well as a Focus filter. 

For some ideas of how to put these actions to work, see this thread 
on the DEVONthink discussion forum or visit the MacStories Shortcuts 
Archive and search on that page for “DEVONthink.” Examples of 
shortcuts provided there include DEVONmenu, which gives you an 
easy way to import a wide variety of files, and DEVONimage, which 
lets you save images from various places into DEVONthink To Go. 

To learn much more about using Shortcuts, read Take Control of 
Shortcuts by Rosemary Orchard. 

Configure DEVONthink To Go Settings 

You can adjust the behavior of numerous DEVONthink To Go features. 
To do this, navigate to the home screen of DEVONthink To Go and tap 
the Settings icon. There, you can change the following: 

• Security: Optionally require a passcode (possibly along with Face 
ID or Touch ID) to access your DEVONthink To Go data, and 
configure how long the app should wait before requiring it. 

• Sync: See Set Sync Options for a description of these settings. 
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• Databases & Groups: Turn on or off these features: 

‣ Unify inboxes: Turn this on to show the inbox for each of your 
databases in the Inboxes section of the home screen. Turn it off 
to show each database’s inbox separately. 

‣ Unify tags: Turn this on to display a Tags section on the home 
screen, with subcategories for the tags in each of your databases. 
Turn it off to show each database’s tag group separately. 

‣ Keep groups on top: Turn this on to sort all groups above indi-
vidual documents within each item list. 

• Documents: The following options are available: 

‣ Text: Tap Text Settings to reveal controls for plain text size, 
automatic caps, spelling correction, and data detectors. 

‣ PDF: Tap PDF Settings to reveal controls for Fit (tap Automatic 
to adjust document width dynamically; tap Width to fill the full 
width of your screen), Pages (tap Automatic to let DEVONthink 
To Go display two PDF pages side-by-side if space permits; tap 
Single to view only a single page at a time), “First page single” 
(turn on to show the first page of a PDF as a single page), 
Scrolling (tap an icon for left-right or up-down scrolling while in 
PDFs), Continuous (turn this on to scroll PDFs continuously; 
turn it off to scroll a full page at a time), “Show quick navigation” 
(turn on to show the quick navigation bar; turn off to hide it), 
and “No dark background” (turn this on to leave PDF back-
grounds unchanged even when dark mode is enabled). 

‣ Markdown: Tap Markdown Settings to reveal controls to force 
line breaks in Markdown documents; to enable support for 
MathJAX, Mermaid, and Prism; and to enter custom CSS for 
control over how Markdown text is rendered in previews. 

‣ Web: Tap Web Settings to reveal three switches: “Use Safari 
view” provides an alternative way of viewing linked webpages 
within DEVONthink; and “Delete cookies on launch” and “Delete 
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cache on launch” remove those items, respectively, from DE-
VONthink’s cache when you open the app. 

‣ Use dark background: Turn this on to display documents with a 
dark background when the system-wide dark mode is enabled. 
Turn it off to leave document backgrounds unchanged, regard-
less of dark mode setting. 

‣ Remote images in emails: Turn this on to automatically down-
load any images that are stored on a server rather than embed-
ded in the email message itself. Turn it off to leave those images 
out by default. 

‣ Automatically mark as read: When this is turned on, as it is by 
default, documents are marked as read as soon as you view them 
and move to a different document. When it’s off, you must man-
ually mark documents as read. 

• OCR: Tap Settings next to “Text recognition” to display the follow-
ing OCR settings: 

‣ Keep annotations: If you run OCR on a document that already 
has annotations, they’ll be preserved in the final file if this switch 
is on. Turn it off to discard any existing annotations. 

‣ Auto correct orientation: By default, DEVONthink tries to figure 
out the page orientation and adjust it so that text is readable 
without turning your device; turn this off to keep the original 
orientation. 

‣ Move original to the trash: If this is on when you use the Con-
vert command to perform OCR on an image or PDF, the original 
file (without a text layer) is moved to the trash once the new 
version with searchable text is created. 

‣ Quality: Use this slider to set image quality in the final file. 
Higher quality also means larger file sizes. 

‣ Installed Languages: Turn on any language you want to consider 
when converting documents. For best results, enable only the 
languages you’re very likely to encounter in your files. 
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‣ Available Languages: Tap the plus icon to add a language you 
may want to use for OCR. 

• Editing: Turn on or off the following text editing features: 

‣ Automatic caps: Capitalize the first letter typed after a period 
and a space. 

‣ Spelling correction: Use the iOS/iPadOS spelling correction 
feature as you type. 

‣ Data detectors: Look for, and highlight, text that might be dates, 
phone numbers, addresses, and so on (for ease of adding the 
information to Contacts, Calendar, and the like). 

• Previews & Spotlight: Set your preferences for these two items: 

‣ Create previews: Turn this on to cause DEVONthink to create 
thumbnails of each document automatically. 

‣ Spotlight: Turn this on to enable Spotlight to index and return 
results for your DEVONthink documents when performing 
system-wide searches in iOS/iPadOS. 

• Share & Integration: 

‣ Share: When sharing items from DEVONthink, choose which 
format to use: File, Link, or Markdown. 

‣ TextExpander: If TextExpander touch is installed, tap Update to 
make any recently added snippets available in DEVONthink To 
Go. 

• Backup: Enable “Backup data to iCloud” to make a backup of your 
database that’s accessible to the Files app. 

• Your Subscription: Tap Manage to add a subscription or up-
grade, or switch between monthly and yearly subscription. 
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In addition, there are a few system-level settings you can adjust in 
Settings > DEVONthink; there may be more or fewer options depend-
ing on your device and how you’ve used DEVONthink To Go so far: 

• Location: To enable DEVONthink To Go to record the location 
where a document was created, make sure this is set to While Using 
the App. To keep DEVONthink To Go from knowing your location, 
set it to Never. 

• Local Network: If you plan to use Bonjour to sync your iOS/ 
iPadOS device directly with another Mac on your network, turn this 
switch on to allow local network access. 

• Photos: Turn this on to give DEVONthink To Go access to your 
photos. 

Note: If you don’t see this item, it may be that DEVONthink has not 
yet attempted to access your photos. Try adding a media item to 
your database; then a prompt should ask for access to your photos. 
After you respond to that prompt, the Photos item should appear in 
Settings. 

• Siri & Search: Use these switches to specify in what ways, if any, 
Siri and the iOS/iPadOS system-wide search tools can interact with 
DEVONthink To Go and its data. 

• Notifications: Configure the ways in which you would like 
DEVONthink To Go to be able to get your attention. 

• Background App Refresh: Turn this on to enable DEVONthink 
To Go to perform certain tasks (such as syncing and indexing) even 
when the app isn’t open. This capability is entirely controlled by 
iOS/iPadOS, however—it’s not under DEVONthink’s control. 

• Cellular Data: For iPhones and iPads with cellular radios, turn 
this off if you want to prevent DEVONthink To Go from syncing 
over a cellular connection. 

• Language: Choose DEVONthink To Go’s default language here. 
Unless you specify otherwise, it uses the language set in Settings > 
General > Language & Region > Device Language. 
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Get Information Out of 
DEVONthink 

Ordinarily, you’ll interact with the data in your DEVONthink database 
using DEVONthink itself. However, in some cases you may want to 
copy or move documents out of DEVONthink to send to other people 
or use in other apps. DEVONthink lets you copy, share, or export static 
information from DEVONthink in a dizzying array of formats to suit 
almost any need. (If you want to give other people on your local net-
work live access to your database, see the next chapter, Use DEVON-
think’s Web Server.) 

Tip: If you’re setting up a DEVONthink-based web server in order to 
share your data with others, read the sidebar Choosing a Sharing 
Strategy, earlier, to make sure you are aware of your sharing op-
tions, just in case one of the others is a better match for your needs. 

Copy Data 

The simplest way to get a document out of DEVONthink is to drag it to 
your desktop (or any other convenient folder). You can also drag 
documents into other appropriate places—for example, you can drag a 
document into a Mail message to add it as an attachment, drag a 
graphic into Photos to import it, or drag a text file onto the BBEdit 
Dock icon to open it for editing in BBEdit. 

Another option is to select one or more documents and choose Edit > 
Copy (⌘-C), then switch to the Finder or another app and choose 
Edit > Paste (⌘-V). 
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Note: Although some metadata is preserved when you copy it from 
the app (for example, DEVONthink tags become Finder tags), meta-
data that’s exclusive to DEVONthink (such as star ratings and custom 
metadata) won’t be included, unless you use File > Export > Files 
and Folders and then import that data into another DEVONthink 
database. 

Share Data 

If you want to send one or more documents to another person, or to 
another app on your Mac, select the document(s), click the Share 
icon, and choose a destination from the pop-up menu. 

This menu is the same as the one that appears in other Mac apps that 
support Share extensions. (See Use the Share Extension for more 
about DEVONthink’s Share extension.) 

Export Data 

If neither copying nor the Share feature meets your needs, you can 
export your data in many different formats. You might do this, for 
example, to save documents in a different format (exporting can 
convert file formats at the same time), or to create a standalone web-
site from a portion of your database. 

All the export commands live on the File > Export submenu, and there 
are lots of them! (However, not every document format can be export-
ed in every other format—for example, you can’t export a graphic as a 
text file.) Here are your options: 

• Document: Saves the selected item in its original format, with the 
option to add tags in the process. 

• Files and Folders: Saves selected items in their original formats, 
preserving any group hierarchy as folders. It’s safest to store export-
ed files and folders in a new folder, rather than intermixing them 
with existing documents. 
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Note: The next nine commands combine all selected documents into 
a single file in the selected format. With Rich Text (RTF and RTFD), 
Text, and Word formats, you can optionally select the “Include names 
of documents” checkbox in the Save dialog to include individual 
document names in the file. 

• as HTML Bookmarks: Exports the URLs of selected items and 
sub-items as an HTML bookmarks file. 

• as OPML: Exports the selected groups and documents as an 
Outline Processor Markup Language (OPML) file, suitable for 
importing into most outliners. 

• as PDF Document: Exports the selected documents as PDF. 

• as Rich Text (RTF) Document: Saves selected documents as a 
single rich text file, including styles but omitting graphics. 

• as Rich Text (RTFD) Document: Saves selected documents as a 
single RTFD file, including styles and any graphics. 

• as Text: Saves selected documents as a single plain text file (that is, 
without styles); you can optionally specify the encoding using the 
Text Encoding pop-up menu. 

• as Unix mailbox: Exports selected email messages, or email mes-
sages in selected groups or smart groups (applies only to documents 
in .eml or .emlx format) as a Unix .mbox file, which many email 
clients can import. 

• as Word 2007 Document (DOCX): Saves selected documents 
as a Word 2007 (.docx) file, including styles but not including any 
graphics. 

• as Word 97 Document (DOC): Saves selected documents as a 
Word 97 (.doc) file—again, including styles but not including any 
graphics. 

• as Website: Saves the selected items as a set of HTML file(s) and 
linked media, in the process converting non-web-friendly file 
formats to PDF. 
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“Website” in this context means a collection of files and folders; by 
default, DEVONthink doesn’t create an index page. If you want such 
a page (with links to each of the other documents), click Options in 
the Save dialog and then select Create Index Pages. This export 
option can be useful if you have a collection of, for example, rich 
text documents with embedded graphics and you want to convert it 
to a format that will display in a webpage (which requires that 
graphics be stored as separate files). 

• as Template: Saves the current (single) document as a template 
in ~/Library/Application Support/DEVONthink 3/Templates.noindex, 
adding it to the Data > New from Template submenu (for more 
information, see Template). 

• Database Archive: Saves a copy of the entire selected database, 
compressed as a Zip file; see Back Up and Restore from Backup. 

• Metadata (JSON): Exports the metadata of the selected items in 
JSON format. 
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Use DEVONthink’s Web 
Server 

The Server version of DEVONthink has a built-in web server that lets 
you share your database live on a network. This is useful for giving 
yourself (or other family members) access to your data from other 
computers in your home, or for running an internal website that 
provides shared information for all the employees of a small company. 
It also makes it possible to add new information to your database from 
a web browser. Although the web server was present in DEVONthink 
Pro Office, the version in DEVONthink Server has been redesigned 
with a new look and feel, improved security, and granular per-user and 
per-database access controls. 

I want to emphasize, though, that this is not a full-blown database 
server, and it’s not suitable for running a public website. Compared to 
standalone servers, DEVONthink lacks many standard logging, perfor-
mance, and customization features. So it’s good at what it does—but 
just bear in mind that what it does is limited. 

Note: By default, unless the Mac on which you’re running DEVON-
think has its own publicly routable IP address, your database will be 
visible only inside your internal network. It’s possible to work around 
this by using techniques such as port forwarding, but that’s beyond 
the scope of this book. Consult your router’s documentation. 

To set up the web server, follow these steps: 

1. Go to Settings/Preferences > Server (Figure 91). 
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Figure 91: Set up DEVONthink’s web server here. 

On the General tab, edit any or all (or none) of the following fields 
to taste: 

‣ General: Check Start on Launch if you want to activate the web 
server automatically when you open DEVONthink. Check “Con-
vert incoming images & PDF documents to searchable PDF” if 
you want DEVONthink to perform OCR on all images and PDFs 
uploaded via the web interface. 

‣ Bonjour Name: Enter the name your DEVONthink web server 
will have on the local network. 

‣ Bonjour Domain: If your local network contains more than 
one Bonjour domain (an unusual situation), enter the domain 
name at which your database will be reachable (to enable proper 
generation of relative links). Most people can ignore this setting. 

‣ Port: Enter the number for the port on which the server should 
listen (if blank, DEVONthink chooses a random, high port num-
ber such as 60149). 
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‣ TLS Certificate: These controls enable DEVONthink to com-
municate via an encrypted HTTPS connection. If you already 
have a TLS certificate for your Mac installed (for example, one 
obtained from Let’s Encrypt), you can choose it from the pop-up 
menu. If you don’t have an externally managed certificate, how-
ever, click “Create self-signed certificate” to make your own and 
select it, all in one step. (Self-signed certificates are just as secure 
as those provided by certificate authorities, but visitors to your 
site may receive a warning that the connection may not be pri-
vate because the certificate is not trusted.) If you have a P12 file 
rather than a TLS certificate, click “Load P12 file,” navigate to the 
file, and click Choose. 

‣ Allow insecure HTTP connection on port: If, despite 
having HTTPS enabled, you want to enable insecure, HTTP 
connections, check this box. 

2. On the Users tab, set up accounts and permissions for each person 
who will connect to DEVONthink via the web server. A guest user is 
included by default (and you can set up that user’s preferences to 
your liking), or you can add other users, as follows: 

a. Click the plus  button, type a name, and press Return. 

b. In the Password field, enter the password that user will type to 
log in. (A password is mandatory; if this field is left blank, the 
user will be unable to log in.) 

c. For each database (including the global Inbox), select the check-
box(es) for the activities that user is permitted to do via the web 
interface: Read, Download, Add, Write, Organize, and Delete. 

Note: You can change users and permissions at any time, but if the 
server is running, you must stop it to make these changes, and then 
restart it. 

3. Click Start. (You can also choose Tools > Start Server, which is 
useful when the Preferences window is closed.) 
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The web server starts, and DEVONthink displays, at the bottom 
of the window, the address at which it can be reached—in both 
Bonjour format and as a numeric IP address (such as http:// 
iMac.local:60150, http://172.16.85.1:6015). 

The web server is now running. To turn it off later, click Stop, choose 
Tools > Stop Server, or quit the app. 

To visit your database, open a web browser (on the same Mac, an iOS/ 
iPadOS device, or another computer on your network), enter the 
address DEVONthink gave you in step 3, and enter the username and 
password for one of the users you set up in step 2. You should then see 
something like Figure 92. 

Figure 92: Your database looks something like this in a browser. 

Because the controls available on this webpage are so simple and 
largely self-explanatory, I’ll refrain from detailing each one. But I do 
want to point out just a few key features (which are dependent on the 
permissions of the currently logged-in web sharing user): 

• Uploading and downloading: Remote users can add new docu-
ments to the database (tagging them in the process) and retrieve 
entire files in their original formats. 

• Creating and editing: Remote users can add bookmarks, plain 
text notes, formatted notes, and Markdown documents to the 
database (again, including tags) from the browser, and can edit 
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existing documents in those formats. Remote users can also add 
feeds and groups. 

• Search: Use the full-featured Search field on the right side of the 
toolbar to search either the current database or all databases. 

• Organization: You can move, copy via drag and drop, and rename 
documents. You can also use the actions pop-up menu on the 
toolbar to apply labels or star ratings, or to mark them as 
(un)flagged/(un)read/(un)locked. 

In addition, the browser interface has buttons to delete and refresh, 
switch between Standard and Widescreen views, change the language 
between English and German, hide or display the sidebar and inspec-
tor (which supports editing custom metadata and includes a See Also 
view), or log out. 

If you’re wondering about another favorite feature, chances are it’s 
simply not there—sorry! The web server is great for basic access, but 
it makes no attempt to replicate all of DEVONthink’s functionality. 

DEVONthink and Mobile Devices 
If you connect to a DEVONthink web server with an iPhone, iPod 
touch, or iPad, you may be pleasantly surprised to see that the page 
is optimized for the device’s small screen. Even so, this method of 
getting at your database may be problematic if you need access when 
you’re away from your local network, and the user interface is still 
somewhat cumbersome to work with. A much better solution for iOS 
devices and iPads is to Use DEVONthink To Go. 
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Dig Deeper 
Although I can’t cover every last DEVONthink feature, I want to wrap 
up this book with a brief discussion of a few key features that are a bit 
more obscure or advanced than what the average user may need on a 
daily basis. I hope you’ll use this information as a starting point to 
explore and experiment with the app on your own. 

Maintain Your Databases 

In certain situations, your DEVONthink databases can become cor-
rupted. For example, if a system process DEVONthink depends on 
crashes while data is being written, the files may not be stored correct-
ly or completely. Disk errors and other random events having nothing 
to do specifically with DEVONthink can also cause problems with your 
databases. If you begin noticing problems—weird error messages; 
missing documents, groups, or tags; or anything else that’s out of 
whack—you can use any of several techniques to fix them. (And, it 
doesn’t hurt to use these from time to time as a preventive measure, 
even if you haven’t noticed any problems.) 

Verify & Repair Database 
The File > Verify & Repair Database command checks the selected 
database for errors, and if it finds any, it fixes those it can. So choosing 
this command is a quick and easy way to solve many common prob-
lems. 

During the repair process, if DEVONthink finds any files in its package 
on disk that don’t have corresponding entries in your database, it 
(re)imports them and puts them in a new group, at the top level of 
your database, called Orphaned Files. You can then move these newly 
adopted documents to the group(s) of your choice. DEVONthink also 
reports any missing files in Window > Log. 
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Optimize Database 
Over time, as you add, delete, and modify items, your database can 
become less efficient in the way it stores your data, leading to decreas-
ing performance. DEVONthink offers an easy way to reorganize your 
database’s internal structure behind the scenes—it won’t look any 
different afterward, but it may work better. (You needn’t do this often, 
perhaps every few months if the app feels a bit less zippy than usual.) 

To optimize a database, select it and choose File > Optimize Database. 
DEVONthink creates an extra backup of your database behind the 
scenes and then rebuilds its structure. Normally this takes just sec-
onds, even with a huge database. To optimize all open databases at 
once, go to DEVONthink’s Script > Data submenu and choose Verify 
& Optimize Databases (⌘-Control-Option-Y). 

Back Up and Restore from Backup 
You should, of course, back up your DEVONthink databases by includ-
ing the ~/Databases folder (or whatever folder you store them in) in 
your regular backups—for example, those you make using Time Ma-
chine, Carbon Copy Cloner, or Backblaze. (For extensive advice on 
backups, see my book Take Control of Backing Up Your Mac.) Howev-
er, in addition to whatever ways you may back up your database 
outside DEVONthink, the app backs up its own data internally once a 
week (assuming you open it at least once a week). 

If you’re experiencing problems with DEVONthink that the Verify & 
Repair Database is unable to fix, you can try restoring DEVONthink’s 
internal backup, which affects only your metadata, not the documents 
themselves. To do this, hold down Option and choose File > Restore 
Backup. Select a backup (DEVONthink stores two, and usually the 
most recent one is the logical choice), and click Open. DEVONthink 
reverts to the version of the metadata and index stored in that data-
base. It doesn’t hurt, after doing this, to choose Tools > Verify & Repair 
again, just in case your backup was also damaged. But keep in mind 
that if you’ve made further changes to your DEVONthink database 
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since that backup, they may not be reflected in DEVONthink after you 
restore your backup. 

If you want to create an extra, manual backup of your full DEVON-
think data (which you can then copy to the media of your choice), 
choose File > Export Database Archive, select a location, and click 
Save. DEVONthink stores the backup as a Zip file. 

Rebuild Database 
If all else fails (namely, you still see error messages or weird behavior 
even after Verify & Repair and Restore from Backup), your best course 
of action may be to ditch your index and rebuild it from the raw docu-
ments. Doing so generally preserves your group and tag structure, 
although some metadata may be lost. 

To rebuild your database, choose File > Rebuild Database and click 
OK. DEVONthink exports and then re-imports all your documents. 

Link DEVONthink Documents to Other 
Apps 

You can also access particular documents in your database from 
another application on your Mac. Select any item and choose Edit > 
Copy Item Link (⌘-Control-Option-C). This puts a specially formatted 
URL on your clipboard. Go to that URL from anywhere else on your 
Mac and it opens the selected item in DEVONthink. 

Tip: In a PDF, you can also link to a particular page: if the Content 
inspector is open with Thumbnails selected, select a thumbnail, hold 
down Shift, and choose Edit > Copy Page Link (⌘-Control-Option-
Shift-C). In a rich text document, you can link to a particular para-
graph by selecting text, right-clicking (or Control-clicking), and 
choosing Copy Paragraph Link from the contextual menu. In a video, 
you can link to a particular frame by clicking the gear icon in the 
video’s control area and choosing Copy Frame Link from the pop-up 
menu. 
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Why would you want to do this? I’ll give you a quick example. Calendar 
has a URL field for each event. If you put the link to a DEVONthink 
item in one of these fields, you can jump to that item—say, a report 
related to a meeting, or a research document you need to present at a 
conference—directly from Calendar. (DEVONthink’s included Re-
minders scripts do just this; see Included Scripts.) 

Tip: DEVONthink also works with a terrific third-party app called 
Hook, which lets you link any document to one or more other docu-
ments, anywhere on your Mac. For complete details, see this Hook 
support page. 
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Appendix A: Keyboard 
Shortcuts 

Many of DEVONthink’s menu commands have corresponding key-
board shortcuts, and you can see those easily enough by looking at the 
menus. However, some keyboard shortcuts—particularly those involv-
ing a combination of keyboard and mouse—aren’t apparent from 
looking at the screen. In addition, DEVONthink adds a number of 
menu commands to locations outside the DEVONthink app itself, and 
although you can see those on the relevant menus, you may not think 
to look for them. So, in this brief appendix, I’ve compiled a list of the 
most useful yet non-obvious DEVONthink keyboard (and keyboard-
plus-mouse) shortcuts. 

Keyboard-and-Mouse Combinations 

The following shortcuts within DEVONthink occur with a combination 
of keyboard and mouse usage: 

• Duplicate to another location: Option-drag. 

• Replicate to another location: ⌘-Option-drag. 

• Create compound predicate (Smart Group or Advanced 
Search): Option-click the plus button to the right of any crite-
rion, which then becomes an ellipsis button. 

• Select a rectangular region of text in a PDF: With the Text 
tool selected, Option-drag. 

• Display a contextual menu: Right-click (or Control-click). 

• Resize all columns in Column view: Option-drag any column 
divider. 
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• Select multiple contiguous documents, groups, tags, etc.: 
Shift-click. 

• Select multiple discontiguous documents, groups, tags, 
etc.: ⌘-click. 

• Open a link in a new background tab: ⌘-click. 

• Open a link in a new foreground tab: ⌘-Shift-click. 

• Create a link from one DEVONthink document to another 
(rich text) document: ⌘-Option-drag the first document into 
the desired spot in the second. 

In addition, you may want to use these keyboard shortcuts in the 
Finder on occasion: 

• To display the ~/Library folder, hold down Option and choose Go > 
Library. 

• To move items into DEVONthink (that is, import and then move the 
original to the Trash), hold down ⌘ while dragging the items to 
DEVONthink. 

• To index (not import) items when dragging into DEVONthink 
(including to the Sorter and the system-wide global Inbox), hold 
down ⌘-Option while dragging the items. 

Other Shortcuts 

Several other miscellaneous shortcuts exist: 

• Sorter: The commands Take Note, Copy Selection, and Clip to 
DEVONthink have no keyboard shortcuts by default, but you can 
define hotkeys for them in Settings/Preferences > Sorter. 

• Apple Mail: The shortcut for Message > Add to DEVONthink 3 is 
⌘-Control-Option-M. You can also add the entire selected mailbox 
to DEVONthink with ⌘-Control-Option-Shift-M. 
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• Services menu: DEVONthink optionally adds several commands 
to the system-wide Services menu, such as Take Plain Note and Add 
to DEVONthink 3. Some of these may be disabled by default. You 
can enable them, change existing shortcuts, or add missing short-
cuts; see Use the Services Menu. 

274 



           
 

       
       

        

        
       

        

        
          

       

Learn More 
You can learn more about DEVONthink by consulting any of the 
following resources: 

• DEVONthink User Handbooks: The official documentation from 
DEVONtechnologies (available in PDF, EPUB, and Mobipocket 
formats) covers other features that didn’t fit into this book. 

• DEVONtechnologies User Forum: Share your tips and experiences 
with other DEVONthink users, get problem-solving advice, and 
learn new ways to accomplish tasks in the User Forum. 

• Devonian Times: To keep up with news about DEVONtechnologies, 
its products, and more, read Devonian Times, a blog by DEVON-
technologies employees (including the company president, Eric 
Böhnisch-Volkmann). 
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About This Book 
Thank you for purchasing this Take Control book. We hope you find 
it both useful and enjoyable to read. We welcome your comments. 

Ebook Extras 

You can access extras related to this ebook on the web. Once you’re 
on the ebook’s Take Control Extras page, you can: 

• Download any available new version of the ebook for free. 

• Download various formats, including PDF, EPUB, and Mobipocket. 
(Learn about reading on mobile devices on our Device Advice page.) 

• Read the book’s blog. You may find new tips or information, as well 
as a link to an author interview. 

• Learn about any update plans for the book. 

About the Author and Publisher 

Joe Kissell is the author of more than 60 books about technology. In 
2017, he also became the publisher of Take Control Books, when alt 
concepts—the company he runs along with his wife, Morgen Jahnke— 
acquired the Take Control series from TidBITS Publishing Inc.’s 
owners, Adam and Tonya Engst. 
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Joe is also a contributing editor to TidBITS and was formerly a senior 
contributor to Macworld. Before he began writing full-time in 2003, 
Joe spent nearly eight years managing software development. He holds 
a bachelor’s degree in Philosophy and a master’s degree in Linguistics.

In his rare non-work hours, Joe likes to travel, walk, cook, eat, and 
practice t’ai chi. He and Morgen live in Saskatoon, Saskatchewan, 
Canada, with their two children and their cat. To contact Joe about this 
book, send him email and please include Take Control of DEVONthink 3 
in the subject. But note that although Joe is happy to receive feedback 
on this book, he cannot offer any technical support for using DEVON-
think. You can also follow Joe on Mastodon (@joekissell) or visit his 
personal website, JoeKissell.com.

Credits
• Publisher: Joe Kissell
• Editor: Kelly Turner
• Cover design: Sam Schick of Neversink
• Logo design: Geoff Allen of FUN is OK
• Special thanks: Eric Böhnisch-Volkmann, Christian Grunenberg,

and Jim Neumann

More Take Control Books
This is but one of many Take Control titles! We have books that cover 
a wide range of technology topics, with extra emphasis on Macs and 
other Apple products.

You can buy Take Control books from the Take Control online catalog 
as well as from venues such as Amazon and the Apple Books Store. 
But it’s a better user experience and our authors earn more when you 
buy directly from us. Just saying…

Our ebooks are available in three popular formats: PDF, EPUB, and 
the Kindle’s Mobipocket. All are DRM-free.
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Also by Joe Kissell 
Click any book title below or visit our web catalog to add more ebooks 
to your Take Control collection! 

Take Control of 1Password: Use this powerful password manager to 
create, store, enter, and sync personal data on all your devices. 

Take Control of Apple Mail: Learn the ins and outs of Apple’s email 
app in macOS and iOS/iPadOS. 

Take Control of Automating Your Mac: Work more efficiently on your 
Mac with time-saving shortcuts of all kinds. 

Take Control of Backing Up Your Mac: Protect your Mac’s valuable 
data from any sort of mishap. 

Take Control of iCloud: Make the most of Apple’s online service for 
storing, syncing, and sharing data. 

Take Control of the Mac Command Line with Terminal: Master your 
Mac’s command-line interface and learn basic Unix skills. 

Take Control of Ventura: Discover what’s new in macOS 13 and get all 
the information you need to upgrade safely. 

Take Control of Your Digital Legacy: Make sure your important 
digital information is preserved for future generations. 

Take Control of Your Online Privacy: Learn what’s private online (not 
much)—and what to do about it. 

Take Control of Your Paperless Office: With your Mac, scanner, and 
this ebook, you’ll finally eliminate the chaos of overflowing paper. 

Take Control of Your Passwords: Overcome password overload! Stay 
safe while eliminating the hassles and confusion of passwords. 
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